LINUX.ORG.RU

Ответ на: комментарий от anonymous

Хорошо, что вы делаете в убунту, когда наставили кучу новых пакетов, которые еще не входят в стабильный дистрибутив, но нужны вам, а после обновления кэша пакетов все намертво блокирует друг друга?

cvs-255 ★★★★★ ()

Если тебе интересно, что делаю я, то это emerge -C. Но у тебя может не получиться. Обычно со временем кстати исправляют все эти циклические блокировки всё же, попробуй обновиться через полгода.

anonymous ()
Ответ на: комментарий от anonymous

Ну точнее emerge -C не всегда спасает, и даже маскировка проблемного ебилда (часто он находится только через полчаса), иногда приходится исправлять флаги и параметры сборки. Но эбычно этого хватает.

anonymous ()
Ответ на: комментарий от cvs-255

в убунту так не бывает, её делают настоящие профи

anonymous ()
Ответ на: комментарий от RazrFalcon

Бывает, просто редко. На тестинге каждый день, иногда месяцами не исправляют. Особенно часто тот неадекватный пузан косячит.

anonymous ()

Я пытаюсь разобраться, почему возникла блокировка. Обычно, получается.

Black_Shadow ★★★★★ ()

Решаем проблему. Благо в Генту всё для этого есть.

Kroz ★★★★★ ()
Последнее исправление: Kroz (всего исправлений: 1)
Ответ на: комментарий от anonymous

На тестинге каждый день, иногда месяцами не исправляют.

будь потоньше. А то ведь в дверь скоро пролазить не будешь.

Deleted ()

буквально сегодня мне вот такое выдало:

 * Error: circular dependencies:

(dev-java/ant-core-1.9.2:0/0::gentoo, ebuild scheduled for merge) depends on
 (virtual/jdk-1.7.0-r2:1.7/1.7::gentoo, ebuild scheduled for merge) (buildtime)
  (dev-java/icedtea-7.2.6.6:7/7::gentoo, ebuild scheduled for merge) (runtime)
   (dev-java/ant-core-1.9.2:0/0::gentoo, ebuild scheduled for merge) (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.
лечилось так:
# emerge -1 ant-core
# emerge -1 icedtea

Deleted ()

вижу вариант здесь снести некоторые блокирующие пакеты, обновиться, поставить те пакеты.
/debian пользователь мимокрокодил

sehellion ★★★★★ ()

Внимательно читаю выхлоп портажа, добавив ключики -t и --verbose-conflicts. Дальше по обстоятельствам

XMs ★★★★★ ()

Я так всё не обновлюсь до KDE 5, иногда замаскировываю что-то.
Кстати, а кто перешёл, как вообще пятая плазма в генте, кдешные приложения, уже можно пользоваться, брат жив?

TheAnonymous ★★★★★ ()

Ну я редко обновляюсь, ну никак не привыкну, хотя уже лет десять как на сабже. Но все решается и чинится, иногда я просто сношу какие-то пакеты, либо обновляю разом пролемные комбинации или как выше.

Бывало, что заигрывался, приходилось gcc собирать на другой машине и ставить бинари и тд.

WerNA ★★★★★ ()

Раз уж переехали в толксы... Если не можете разрулить зависимости - резать вдоль.

А вообще - в генте достаточно методов для «ремонта» такой ситуации. Помню, трехлетнюю систему как-то обновлял. Посидел пару часов чтения ебилдов и все как-то обновилось.

l0stparadise ★★★★★ ()

Самый тупой вопрос этой недели.

Каждый гентушник знает, что ему делать в этой ситуации, а кто не знает, тот ходит в документацию, и читает до просветления.

Алсо, емерж сам даёт подсказки решения, в том числе ссылку на документацию.

r3lgar ★★★★★ ()
Ответ на: комментарий от TheAnonymous

Я так всё не обновлюсь до KDE 5, иногда замаскировываю что-то.
Кстати, а кто перешёл, как вообще пятая плазма в генте, кдешные приложения, уже можно пользоваться, брат жив?

Нормально, но если пользуешься стабильной веткой, приготовься кучу всего размаскировать. И нужен подключенный оверлей kde, потому как многое ещё не попало в основное дерево. Например, kdepim (это мне совершенно непонятно, не заметил с ним никаких проблем, с моей точки зрения, вполне готово для стабильной ветки в основном дереве).

Black_Shadow ★★★★★ ()
Последнее исправление: Black_Shadow (всего исправлений: 2)

за два года такого не было

Deleted ()

что вы делаете в генту

А что там вообще можно делать? Использую плавающий арчик и не знаю проблем.

Zaskard ()
Ответ на: комментарий от TheAnonymous

Кстати, а кто перешёл, как вообще пятая плазма в генте, кдешные приложения, уже можно пользоваться, брат жив?

Можно, но столкнулся с косяком перевода с установленным kde-l10n, когда Gwenview забыл не ASCII раскладки - не мог открыть файлы с кириллицей. При разбирательствах оказалось, что kde-l10n стоит поверх kde4-l10n, поставленного из метапакета.

Собственно, оставил только kde4-l10n, но у него перевод неполный, только процентов 80%. ЧСХ именно его и советует вики для локализации кед.

MahMahoritos ★★★ ()

Так я перешел от Calculate к LinuxMint и не вижу проблем ;)

bookman900 ★★★★★ ()
  • Не обнаруживаю такого, тк использую ~.
nvidia ()
Ответ на: комментарий от RazrFalcon

У меня тоже весь kde5 из стейбл, ничего для него не размаскировывал

grem ★★★★★ ()

Удаляю блокирующие пакеты, как правило помогает.

l-_-l ()

format /s a:
format /q c:
setup.exe

Ябформатнул.

Deleted ()
Ответ на: комментарий от TheAnonymous

Kdevelop в основном дереве до сих пор четвёртой ветки, пришлось на бету переходить, чтобы блокирующие зависимости разрешить. Пятая плазма хороша мелкими фичами (например, пункт «взаимозаменяемые виджеты», благодаря которому можно легко найти более подходящий аналог, не утруждая себя удалением старого и вознёй с размещением нового) и плоха падучестью (вчера упала впервые за много лет), какими-то совершенно фееричными глюками (например, контекстное меню открывается не в месте клика, а вообще на другом экране, меню приложений открывается за пол-километра от кнопки, etc; причём это началось не сразу), ужасным качеством приложений, многие из которых растеряли свою функциональность в процессе портирования (akregator из значка открывается строго заданным окном, не запоминая, что его развернули на весь экран, отрисовка (полагаю, это камень в сторону kwin-а) может при сворачивании окна перерисовать маленький прямоугольничек, а остальное оставить; приходится открывать yakuake, который открывается на другом экране) и вырвиглазной попугайностью — цвета рекомендуется настраивать в первую очередь, значки в бризе варьируются от вообще лютый треш до вполне ничего.

В общем, очень жду апдейтов, в первую очередь приложений

XMs ★★★★★ ()
Ответ на: комментарий от RazrFalcon

У меня тоже 5 кеды на stable. С установкой особых проблем не было.

sudopacman ★★★★★ ()

emerge -C решает

ass ★★★★ ()

, что пакеты намертво блокируют друг друга и вы ни обновиться, ни пересобрать мир, ничего другого не можете

и часто это так в генту? :-D

Ygor ★★★★★ ()

GuixSD

Ставлю Guix, там подобные проблемы невозможны.

Camel ★★★★★ ()
Ответ на: комментарий от TheAnonymous

Я так всё не обновлюсь до KDE 5, иногда замаскировываю что-то.

Мужик! А я поддался на провокации майнтейнеров.

Кстати, а кто перешёл, как вообще пятая плазма в генте, кдешные приложения, уже можно пользоваться, брат жив?

KDE Framework 5.6 != KDE 5. Многие приложения не подтянули, например, digikam. Нету аналога QtCurve, в kfaenza иконки в трее могут выглядеть ужасно (например, для deadbeef). Каких-то преимуществ по сравнению с KDE 4 не заметил.

iVS ★★★★★ ()
Ответ на: комментарий от r3lgar

Алсо, емерж сам даёт подсказки решения

Я, например, долго допирал, что делать с circular dependencies. Если это где-то описано, ткни в мануал.

iVS ★★★★★ ()
Ответ на: комментарий от XMs

приходится открывать yakuake

С переходом на пятые кеды, он перестал сохранять настройки профиля.

iVS ★★★★★ ()
Ответ на: комментарий от iVS

Это не описано (кроме банального «подождите, может, это кто-нибудь починет»), но довольно часто проблема в USE-флагах, задаваемых пользователем. Портаж даёт довольно подробный список того, что от чего и почему зависит

XMs ★★★★★ ()
Ответ на: комментарий от iVS

У меня сохраняет (прозрачность и шрифт, остальное не менял)

XMs ★★★★★ ()

что вы делаете в генту

я больше ничего в генту не делаю. когда-то давно, когда у меня их стало много, я понял, что это тупиковый путь.

crypt ★★★★★ ()
Ответ на: комментарий от MLP_Fan

никуда не делся. просто он фигово развивается. нет поддержки GTK3

Deleted ()
Последнее исправление: Lifun (всего исправлений: 1)
Ответ на: комментарий от iVS

А разве не логично самому-то? Если пакеты тянут друг друга, то юзом можно собрать один без другого, а потом пересобрать с зависимостью друг друга. Или, если юзом не регулируется, то ставится пакет меньшей версии, который не привязан, и потому уже обновляется. Вообще, это всё не требует даже документации, это и так должно быть понятно. Не венда же.

r3lgar ★★★★★ ()
Ответ на: комментарий от MahMahoritos

Гентопроблемы

Можно, но столкнулся с косяком перевода с установленным kde-l10n, когда Gwenview забыл не ASCII раскладки - не мог открыть файлы с кириллицей. При разбирательствах оказалось, что kde-l10n стоит поверх kde4-l10n, поставленного из метапакета.

Мда.

Camel ★★★★★ ()
Ответ на: комментарий от RazrFalcon

Я не говорил, что его нельзя поставить без размаскирования. Просто куча привычного софта в версии для kde5 ещё замаскировано.

Black_Shadow ★★★★★ ()
Ответ на: комментарий от r3lgar

То, что ты пишешь, мне не логично, т.к. есть универсальное решение — emerge -C для всего, что вызывает блокировки. Например, при обновлении KDE 4 -> KDE 5 удаляются пакеты, тянущие четвертые кеды, включая ktorrent, yakuake, digikam. После удачного обновления уже можно поставить удаленные пакеты по одному, включая размаскировку, правку USE и чтение ebuild.

iVS ★★★★★ ()

Разбираюсь. Последний раз было из-за qtquick1, который выкинули и из-за чего не мог Qt обновится. Решение нашел на гентуфоруме.

Loki13 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.