LINUX.ORG.RU
ФорумTalks

Поддержка Internet Explorer?

 , ,


0

1

Вопрос к WEB разработчикам. Изучая web технологии , решил не кидаться сразу же в программирование , а начать так сказать с основ - с верстки ( хотя это может и не основа , поправьте , если не прав). Читаю замечательную книгу Влада Мержевича «Верстка веб страниц» 2011г (кстати прекрасная книга , рекомендую тем кто решил начать с нуля изучение web, минимум воды , максимум информации , правда устарела). В его книге немало внимания уделяется косякам ишака и методам их обхода. А я вот подумал :«А , оно надо?». В итоге для себя решил что - «ишак не нужен». Хотелось бы услышать разные аргументы :«за» и «против», и если «за», то какую версию ишака есть смысл поддерживать?

Никакую. Ползователи IE должны страдать.

StReLoK ☆☆ ()

Может быть так,что ты решил изучать устаревшею технологию,так как интернет переходит на html5.
Правда я простой пользователь и на счёт нецелесообразности изучения старой версии могу заблуждаться.
Но тем не менее,изучение старья потянет за собой адобефлеш,
а он выводится из использования,так как нужный функционал есть в html5.

torvn77 ★★★★★ ()
Ответ на: комментарий от StReLoK

Вот и я так думаю.Но опять же это потеря части аудитории == потеря части дохода.

SliFly ()

Зависит от целей. Я бы проверял работу сайта в ишаке версии, которая нынче стоит на семёрках. Если сайт функционален, но выглядит немного не так как задумывалось, то не вижу смысла выдрачивать скруглённые уголки.

PolarFox ★★★★★ ()

Если ты не собираешься заниматься версткой как профи, то такие вопросы тебя должны волновать только в теории. А так да, правильно что с верстки начал, базис там получить легко и быстро.

umren ★★★★★ ()

В его книге немало внимания уделяется косякам ишака

уж не версии 6.0 ли?

Аргумент за и против может быть один - если доход от пользователей со старыми браузерами больше затрат на их поддержку - их нужно поддерживать. От себя могу сказать, что сейчас имеет смысл поддерживать ie 8 и выше, но это мой трафик и его количество, у тебя могут быть другие данные.

shimshimshim ()
Ответ на: комментарий от SliFly

Пусть они плачут и колятся!
Можно и сверстать, но при каждом заходе редирект на страницу со ссылками на браузеры.

Hurenweibel ★★ ()
Ответ на: комментарий от shimshimshim

уж не версии 6.0 ли?

Да, но я думаю и в последующих версиях багов хватает.

SliFly ()

В общем для себя решил что смысл изучать спец.верстку в ишаке имеет место быть при создании корпоративных приложений , когда эти самые корпоративные предприятия повязаны анальным контрактом с Microsoft.

SliFly ()

Только HTML4, только lynx/links/elinks/w3m. Мультимедиа только в оффлайне после скачивания, интерактивность через POST, telnet и ssh.

saahriktu ★★★★★ ()
Ответ на: комментарий от shimshimshim

Возможно.Следовательно поддерживают стандарты и вопрос об особенностях верстки можно оставить.А, если нет , то и соответственно я не желаю каждый раз менять себе ноги под новые ботинки. Мне проще ботинки выкинуть на мороз. Может , если бы все web разрабы объявили этот .. хм... «продукт» вне закона, тогда бы их ушлые топ-манагеры задумались б, что стоит придерживаться общих тенденций, а не придумывать новые яйца на старый лад.Но, увы.

SliFly ()
Ответ на: комментарий от SliFly

Всё правильно!
Корпы, хоть за это платят. А вендовозные хомячки пусть страдают!

Hurenweibel ★★ ()

На первых порах не стоит заморачиваться. К тому же есть куча инструментов, которые могут помочь исправить косяки. Например для CSS есть autoprefixer. Не панацея конечно, но вроде работает.

Потом, когда уже более менее освоишься, стоит подумать. Да и в конце-концов зависит от задачи. Если это какой-то личный бложек, то можно и забить. А если тебе за это платят деньги, то как ни крути, придётся проверять и исправлять косяки. Ну это очевидно должно быть.

Kilte ★★★★★ ()
Ответ на: комментарий от Kilte

Ну это очевидно должно быть

Не совсем очевидно, как часто, данный перк требуют при устройстве на работу.

SliFly ()
Ответ на: комментарий от SliFly

Не, это не так делается. Под каждую версию пишется свой вариант css и вставляется условными инклудами, вроде

<!--[if lt IE 9]><script src="/static/js/html5.js"></script><![endif]-->

shimshimshim ()

Проблемы в основном со старыми версиями IE, новые работают более-менее сносно. Так же количество пользователей IE не велико. Поддерживать не стоит.

Black_Roland ★★★★ ()
Ответ на: комментарий от shimshimshim

не дописал


<!--[if lte IE 7]>
    <link rel="stylesheet" type="text/css" href="/templates/magent/skin/frontend/ultimo/default/css/styles-ie7.css" media="all" />
<![endif]-->
<!--[if lte IE 8]>
    <link rel="stylesheet" type="text/css" href="/templates/magent/skin/frontend/ultimo/default/css/styles-ie8.css" media="all" />
<![endif]-->

shimshimshim ()

Никакую. Пиши по стандартам. Если браузер криво отображает - это проблема пользователя.

Ровно как и с всякими плакатами/рекламой: то, что большинство населения малограмотно, не значит, что плакаты надо с ошибками писать для таких.

cvs-255 ★★★★★ ()
Последнее исправление: cvs-255 (всего исправлений: 1)

А где тег «спв»?

Ишак не нужен. Но! Нужно знать этого врага в лицо, иначе можешь сесть в лужу. Да и кроме ишака разницы хватает между движками браузеров и их версий. Так что, назвался грибом — полезай в короб сиди и впитывай все что там пишут.

deep-purple ★★★★★ ()

Ослик кончился. Теперь только спаааартааа!

Lordwind ★★★★★ ()

Последние версии осла, 10-11, какой то особой отдельной поддержки не требуют обычно. А на старье имхо можно и забить

Nagwal ★★★★ ()
Ответ на: комментарий от cvs-255

Если браузер криво отображает - это проблема пользователя.

С формальной точки зрения - это проблема как раз разраба.

В книге Джона Резига и Беэра Бибо «Секреты JavaScript ниндзя» 2013 года, с. 28-31, приводится анализ затрат в сравнении с преимуществом поддержки различных браузеров (грубо, аудиторией пользователя). Если вкратце: IE6 - нинужно; IE 7,8 - дрочево, но скорее всего придётся; IE 9 - придётся, но уже не такое дрочево; Firfoxe (так написано на диаграмме), Chorme - must have; Safari, Opera - рекомендуется иногда посматривать. Думаю с CSS, HTML5 и прочими технологиями ситуация такая же.

DarkAmateur ★★ ()
Ответ на: комментарий от DarkAmateur

Если читатель не умеет читать, это что, проблема автора книги?

cvs-255 ★★★★★ ()

смотри тут http://gs.statcounter.com/ , можно для любого региона смотреть, как правило из старых ослов только IE8 имеет мало мальски значительную долю, но не большую. Для IE8 существую специальные костыли, которые инклюдядся через подобное <!--[if lte IE 8]>.
Также если твой продукт выходит на рынок не завтра а через год-два, если смысл построить прогноз доли IE8 через это время, вероятно она окажется совсем маленькая. IE6,7 уже практически нигде не поддерживаются, и для их пользователей поехавший сайт являтеся нормной, видимо им так нравится, или отрывают 3.5 старых сайта в год.
Насчёт IE9 если не ошибаюсь, там уже всё терпимно.
Но само собой даже в IE11 нет многих фич которые есть в других браузерах, это ты сможешь узнать на сайте http://caniuse.com

GanGSISoft ★★ ()
Ответ на: комментарий от cvs-255

Если автору похрен, будет доступна его книга для не умеющих читать, то это не проблемы автора - ему похрен

WindowsXP ★★ ()
Ответ на: комментарий от WindowsXP

КО: Книги по-умолчанию предназначены для умеющих читать

cvs-255 ★★★★★ ()
Ответ на: комментарий от cvs-255

ЛОЛ... то есть - не умеешь читать, уходи из нашей песочницы? есть аудиокниги, детям книги читают, ибо они читать не умеют...

WindowsXP ★★ ()
Ответ на: комментарий от WindowsXP

не умеешь читать, уходи из нашей песочницы

Если не умеешь читать, иди в школу учись

cvs-255 ★★★★★ ()
Ответ на: комментарий от cvs-255

Если читатель не умеет читать, это что, проблема автора книги?

Если цель автора - донести мысль максимальному числу людей, то да - это проблема автора.

DarkAmateur ★★ ()
Последнее исправление: DarkAmateur (всего исправлений: 1)
Ответ на: комментарий от DarkAmateur

Какие же все авторы глупые, пишут буквами, а ведь не все люди умеют читать!

cvs-255 ★★★★★ ()

Есть Bootstrap
С ним и Angular.js или Knockout.js все работает изкаробки.

grim ★★★☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.