LINUX.ORG.RU

KPTI для arm64

 , , ,


0

2

Конфигурирую ядро для девайса на Exynos 5420 (Cortex-A15 + Cortex-A7). Как я понял, Cortex-A15 подвержен meltdown & spectre, поэтому хотелось бы от этого как-то защититься. Нашел в конфиге KPTI (PAGE_TABLE_ISOLATION), а там в дескрипшене написано:

Depends on: X86_64

То есть это значит, что фикс есть только для X86_64?

Ответ на: комментарий от ZenitharChampion

Да, точно, судя по табличке отсюда https://developer.arm.com/support/security-update, A15 подвержен только 3-м из 4х вариантов уязвимостей. Там есть куча всяких pdf'ок с low-level описанием уязвимостей, ассемблерными листингами и т.д., но пока не совсем понятно, что конкретно требуется сделать, чтобы поставить патчи.

Занятный абзац:

For Cortex-A15, Cortex-A57, and Cortex-A72:

In general, it is not believed that software mitigations for this issue are necessary.

driver ()
Ответ на: комментарий от ZenitharChampion

retpoline

Что это за зверь и где его достать?

новый компилятор

Только собрался gcc 6.4 (под gentoo)... Там, может, флажок какой надо включить? Или нужен прям новый-новый компилятор? :)

driver ()
Ответ на: комментарий от dhampire

А, да? Ну, тогда пусть ТС сносит свою генту arm64, раз такие пироги.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.