LINUX.ORG.RU

Восстановление звука в avi-файле

 , , , ,


0

1

Приветствую!

Ситуация: Записал с ip-камеры я видео, писал примерно 2ч 9мин, писал вот так:

mencoder -ovc copy -oac copy -o cam_rec.avi rtsp://10.0.9.100:554/video.mp4

Менкодер работал замечательно и я окончил запись нажав сочетание Ctrl+C. В результате получилось видео размером в 800Мбайт и такими данными:

AVI file format detected.
ID_VIDEO_ID=0
[aviheader] Video stream found, -vid 0
ID_AUDIO_ID=1
[aviheader] Audio stream found, -aid 1
VIDEO:  [mp4v]  0x0  0bpp  30.000 fps  -17179870.0 kbps (-2097152.0 kbyte/s)
Clip info:
 Software: MEncoder SVN-r34106-4.6.1
ID_CLIP_INFO_NAME0=Software
ID_CLIP_INFO_VALUE0=MEncoder SVN-r34106-4.6.1
ID_CLIP_INFO_N=1
Load subtitles in ./
ID_FILENAME=cam_rec.avi
ID_DEMUXER=avi
ID_VIDEO_FORMAT=mp4v
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=0
ID_VIDEO_HEIGHT=0
ID_VIDEO_FPS=30.000
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=7
ID_AUDIO_BITRATE=64000
ID_AUDIO_RATE=0
ID_AUDIO_NCH=0
ID_START_TIME=0.00
ID_LENGTH=0.50
ID_SEEKABLE=0
ID_CHAPTERS=0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
ID_VIDEO_CODEC=ffodivx
==========================================================================
Opening audio decoder: [alaw] aLaw/uLaw audio decoder
AUDIO: 8000 Hz, 1 ch, s16le, 64.0 kbit/50.00% (ratio: 8000->16000)
ID_AUDIO_BITRATE=64000
ID_AUDIO_RATE=8000
ID_AUDIO_NCH=1
Selected audio codec: [ulaw] afm: alaw (uLaw)
==========================================================================
AO: [null] 8000Hz 1ch s16le (2 bytes per sample)
ID_AUDIO_CODEC=ulaw

И все вроде бы замечательно, но при воспроизведении с помощью VLC длина всего 40мин, видеоряд идет ускоренный, а звук идет нормально как есть. Я решил «подшаманить» файл вот так:

avifix -i cam_rec.avi -f 10,1
В результате поменялся заголовок ID_VIDEO_FPS=10.000 и видео стало размером в 2ч 1мин, но звук обрывается на 40мин, а потом идет видеоряд без звука.

Просьба помочь разобраться:
1. Как вы считаете остались ли данные звука в контейнере? Имеет ли смысл дальше пытаться добыть звук?
2. Поможет ли мне выставление заголовка ID_LENGTH=7200? Появится ли звук после 40мин? И как/чем можно изменить этот заголовок?

Ну если писали mencoder, проверить mplayer'ом не судьба? Чего там шаманить извлеките аудио и видео, а потом соберите все заново, например

mplayer -ao pcm -vo jpeg file.avi

потом собрать назад ffmpeg или mencoder

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.