LINUX.ORG.RU

(openSUSE) Пропало изображение при воспроизведении видео


0

0

ВНЕЗАПНО после обновления пропало изображение при воспроизведении видео: звук есть, а картинки нет. Примечательно, что проблема и у vlc, и у mplayer. Обновлял KDE (4). Вот что пишет mplayer:

dmitry@linux-8ogq:~/Desktop/futurama> mplayer Futurama\ \[s05e12\]\ Spanish\ Fry.avi                                    
MPlayer dev-SVN-r29116-4.3-openSUSE Linux 11.1 (x86_64)-Packman (C) 2000-2009 MPlayer TeamCan't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick                                                                                                                                     
mplayer: could not connect to socket                                                                                                                          
mplayer: No such file or directory                                                                                                                            
Failed to open LIRC support. You will not be able to use your remote control.                                                                                 

Playing Futurama [s05e12] Spanish Fry.avi.
AVI file format detected.                 
[aviheader] Video stream found, -vid 0    
[aviheader] Audio stream found, -aid 1    
[aviheader] Audio stream found, -aid 2    
VIDEO:  [XVID]  640x480  12bpp  25.000 fps  931.7 kbps (113.7 kbyte/s)
Clip info:
 Software: VirtualDubMod 1.5.10.2 (build 2540/release)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 56.0 kbit/3.97% (ratio: 7000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mpeg4 @ 0xc707e0]Invalid and inefficient vfw-avi packed B frames detected
VDec: vo config request - 640 x 480 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 640x480 => 640x480 Planar YV12
A: 119.6 V: 119.6 A-V: -0.000 ct:  0.000 2992/2992  5%  0%  0.3% 3 0

Какбэ, вроде все норм. Кто-нибудь сталкивался?

Re: (openSUSE) Пропало изображение при воспроизведении видео

Точно обновилось только КДЕ?

В у меня генту при обновлении иногда перестаёт работать mplayer. Если обновились иксовые драйверы, помогает перезапустить X Window. Если ядерный модуль видео — выгрузить старый, загрузить новый. Иногда требуется обновить какую-нибудь библиотеку. От каких библиотек зависят оба плеера? Судя по ругани на "неправильное видео", может быть что-то не в порядке с ffmpeg.

question4 ★★★★★ ()

Re: (openSUSE) Пропало изображение при воспроизведении видео

Иксы перезапускал. Оба плеера зависят от разных библиотек.
А где там ругань на неправильное видео?
"Invalid and inefficient vfw-avi packed B frames detected" было и раньше, это ерунда.

Вот список всех обновленных пакетов:

openSUSE-release 11.1-1.18
libdirac_encoder0 1.0.0-3.5
libdirac_decoder0 1.0.0-3.5
gfxboot 4.1.19-2.1
yast2-trans-en_US 2.17.5-1.8
xkeyboard-config 1.3-32.30
x11-tools 0.1-167.7
update-alternatives 1.14.19-1.40
ulimit 1.2-1.12
ralink-firmware 1.0-24.8
qlogic-firmware 1.0-148.14
polkit-default-privs 0.1_200811250855-1.5
pm-profiler 0.1-15.4
pciutils-ids 2008.11.26-2.4
openSUSE-build-key 1.0-3.18
netcfg 11.1-1.14
myspell-american 20060207-8.3
iwl5000-ucode 5.4.A.11-2.9
iwl4965-ucode 228.57.2.21-1.9
iwl3945-ucode 15.28.1.8-1.7
ipw-firmware 8-67.9
hicolor-icon-theme 0.10-102.14
gtk2-theme-openSUSE 11.1-1.12
fonts-config 20080121-25.34
dejavu 2.26-1.41
bundle-lang-kde-en 11.1-11.6
branding-upstream 11.1-2.20
atmel-firmware 1.3-138.9
apparmor-utils 2.3.1-5.5
apparmor-profiles 2.3-42.5
alsa-firmware 1.0.17-1.42
adaptec-firmware 1.35-1.5
SuSEfirewall2 3.6_SVNr208-1.9
OpenOffice_org-templates-labels-letter 1.0-2.3
OpenOffice_org-templates-labels-a4 1.0-2.3
libraptor1 1.4.18-30.1
krusader-doc 2.0.0-4.3
python-sip 4.7.9-1.1
libstrigi0 0.6.4-3.3
kio_iso 2.0.0-4.3
libphonon4 4.3.1-4.1
kdebase4-workspace-ksysguardd 4.2.3-1.5
kdebase4-runtime-branding-upstream 4.2.3-2.6
python-kdebase4 4.2.3-3.5
libksane0 4.2.3-1.6
libkonq5 4.2.3-2.6
libkipi6 4.2.3-1.6
libkexiv2-7 4.2.3-1.6
libkdepimlibs4 4.2.3-1.6
libkdegames4 4.2.3-1.5
libkdcraw7 4.2.3-1.6
libkcddb4 4.2.3-1.6
libakonadiprotocolinternals1 1.1.2-1.4
kde4-kdm-branding-respin 11.1.1-67.2
kde4-filesystem 4.2.3-1.1
compiz-branding-upstream 0.7.8-8.7
plasma-theme-aya 4.2.3-2.1
kde-susetranslations 11.1-17.1
gfxboot-branding-upstream 4.1.19-2.1
xorg-x11-fonts-core 7.4-1.32
xerces-j2-xml-apis 2.8.1-238.15
xerces-j2 2.8.1-238.15
suseRegister 1.3-13.3
libakonadi4 4.2.3-1.6
kdepimlibs4 4.2.3-1.6
phonon-backend-xine 4.3.1-4.1
phonon-backend-gstreamer-0_10 4.3.1-4.1
kdebase4-libkonq 4.2.3-2.6
kdebase4-workspace-branding-respin 11.1.1-67.2
strigi 0.6.4-3.3
python-qt4 4.4.4-2.1
libkdepim4 4.2.3-2.6
libkcompactdisc4 4.2.3-1.6
oxygen-icon-theme 4.2.3-4.1
desktop-data-openSUSE 11.1-38.1
kde4-kupdateapplet 0.8.34-2.1
phonon 4.3.1-4.1
libsmoke2 4.2.3-1.6
kde4-kupdateapplet-packagekit 0.8.34-2.1
kdebase4-runtime 4.2.3-2.6
ruby-kde4 4.2.3-4.1
krusader 2.0.0-4.3
kdemultimedia4 4.2.3-1.6
kdenetwork4-filesharing 4.2.3-1.7
kdegraphics4 4.2.3-1.6
kdegames4 4.2.3-1.5
kdebase4 4.2.3-2.6
kde4-ksnapshot 4.2.3-1.6
kde4-krfb 4.2.3-1.7
kde4-krdc 4.2.3-1.7
kde4-kopete 4.2.3-1.7
kde4-konsole 4.2.3-2.6
kde4-okular 4.2.3-1.6
kde4-kwalletmanager 4.2.3-1.5
kde4-kwrite 4.2.3-2.6
kde4-kfind 4.2.3-2.6
kde4-konqueror 4.2.3-2.6
kde4-kgreeter-plugins 4.2.3-1.5
kde4-kgamma 4.2.3-1.6
kde4-kdnssd 4.2.3-1.7
kde4-kmix 4.2.3-1.6
kde4-kgpg 4.2.3-1.5
kde4-kcolorchooser 4.2.3-1.6
kde4-knotes 4.2.3-2.6
kde4-kmplot 4.2.3-2.6
kde4-kmail 4.2.3-2.6
kde4-kio_kamera 4.2.3-1.6
kde4-keditbookmarks 4.2.3-2.6
kde4-kcalc 4.2.3-1.5
kde4-akregator 4.2.3-2.6
kde4-kalgebra 4.2.3-2.6
gwenview 4.2.3-1.6
kde4-kaddressbook 4.2.3-2.6
kde4-ark 4.2.3-1.5
PolicyKit-kde 0.2-8.6
kdepim4 4.2.3-2.6
kdebase4-workspace 4.2.3-1.5
kdebase4-nsplugin 4.2.3-2.6
kde4-kreversi 4.2.3-1.5
kde4-kpat 4.2.3-1.5
kde4-ksudoku 4.2.3-1.5
kde4-kscd 4.2.3-1.6
kde4-kio_audiocd 4.2.3-1.6
kde4-kmines 4.2.3-1.5
kde4-kmahjongg 4.2.3-1.5
kde4-dolphin 4.2.3-2.6
kde4-kdm 4.2.3-1.5
ktorrent 3.2.1-4.7
kdepim4-wizards 4.2.3-2.6
kdebluetooth4 0.3-8.3
kdeartwork4-screensaver 4.2.3-2.6
kdebase4-openSUSE 11.1.1-67.2
kde4-korganizer 4.2.3-2.6
kde4-plasma-addons 4.2.3-1.9
kde4-kwin 4.2.3-1.5
kde4-kget 4.2.3-1.7
ktorrent-lang 3.2.1-4.7
kdebase4-openSUSE-lang 11.1.1-67.2
kde4-kontact 4.2.3-2.6
compiz-kde4 0.7.8-8.7
kde4-kio_sysinfo 11.1.1-67.2
compiz 0.7.8-8.7
compiz-manager 0.0.1_git080201-52.1
kde4-kio_sysinfo-branding-respin 11.1.1-67.2

пакеты libdirac* уже откатил обратно, не помогло

mipt_student ()

Re: (openSUSE) Пропало изображение при воспроизведении видео

> Оба плеера зависят от разных библиотек.

Значит в Suse их собирают иначе.

> пакеты libdirac* уже откатил обратно, не помогло

Вроде они задействуются только при декодировании соответствующего формата и на вывод от FFmpeg не влияют.

> Вот список всех обновленных пакетов:

Ничего не могу сказать. Разве что предложить откатить компиз — с ним чаще всего проблемы.

question4 ★★★★★ ()

Re: (openSUSE) Пропало изображение при воспроизведении видео

вот казалось бы зачем с KDE4 использовать компиз? ведь kwin в KDE4 умеет все то же самое. плюс с ним нет никаких проблем при проигрывании видео

HighwayStar ★★★★★ ()

Re: (openSUSE) Пропало изображение при воспроизведении видео

Проблема решилась установкой Video Output в "X11 Video output" вместо "Default". Поскольку раньше работало с "Default", не иначе как кеды что-то напортили.

mipt_student ()

Re: (openSUSE) Пропало изображение при воспроизведении видео

KDE 4.3 (4.2.88)?

Попробуй отключить композитные эффэкты kde

aJJ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.