LINUX.ORG.RU

buggy video


0

0

Здравствуйте. Есть пара файликов с такими симптомами:

Cache fill:  0.00% (0 bytes)    AVI file format detected.
AVI: ODML: Building odml index (2 superindexchunks)
VIDEO:  [DX50]  384x288  24bpp  25.000 fps  1955.6 kbps (238.7 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3

Badly interleaved AVI file detected - switching to -ni mode...
big_values too large!
big_values too large!
mpg123: Can't rewind stream by 356 bits!
AUDIO: 48000 Hz, 2 ch, s16le, 256.0 kbit/16.67% (ratio: 32000->192000)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
AF_pre: 48000Hz/2ch/s16le
alsa-init: 1 soundcard found, using: default
alsa: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch s16le (2 bps)
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
Starting playback...
VDec: vo config request - 384 x 288 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 384x288 => 384x288 Planar YV12 
alsa-space: xrun of at least 0.872 msecs. resetting stream??,?% 0 0 0%                                                
Broken pipe   6.3 A-V:4194.385 ct:  0.632 159/159  2%  0% 325.5% 0 0 0%                

При этом он долго думает перед началом просмотра, идет без звука, а при попытке перемотать зависает со 100% загрузкой компа.

Пробовал прогнать через mencoder - то же самое. Проблема по-моему именно в звуке... Что можно сделать ?
anonymous

Re: buggy video

Mplayer-то какой версии? можно попробовать не-дефолтные декодеры mp3 - "-ao help" : libmad, ffmp*

anonymous ()

Re: buggy video

По симптомам очень похоже на банально недокачанный из p2p-сети файл (особенно подвисания при перемотке).

> Пробовал прогнать через mencoder

Индекс пересобирали?

Obidos ★★★★★ ()
Ответ на: Re: buggy video от Obidos

Re: buggy video

MPlayer 1.0pre7-3.4.3 (C) 2000-2005 MPlayer Team

файл докачанный, это кто-то криво кодирует с тв-тюнера

да, пробовал пересобирать индекс - не помогает. щас попробую аудио декодре поменять

anonymous ()
Ответ на: Re: buggy video от anonymous

Re: buggy video

ОГРОМНОЕ СПАСИБО :)) поробовал -ac mad и все ок ;)

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.