LINUX.ORG.RU

Bumblebee+vdpau = trouble


0

1

Пытаюсь завести vdpau по этой доке.

Windump этот.

Запускаю:

DISPLAY=:8.0 optirun compiz --replace &

DISPLAY=:8.0 optirun mplayer -vo vdpau filename

./windump -w 1 -a 0 -i 0x1400001 :8 :1 &

И получаю зелёное окошко заместо видео, в выхлопе mplayer2 показывается, что vdpau работает.

Что где надо подкрутить?

ЗЫ Если допустим запустить glxgears таким вот способом, то он будет работать, как надо. Мож как то по другому надо запускать compiz? Без optirun он не запускается.

★★★★★

Ответ на: комментарий от RussianNeuroMancer

И как его прикрутить к mplayer'у на убунте?

Ygor ★★★★★ ()
Ответ на: комментарий от Ygor

Поставив mplayer-vaapi из любого PPA, где есть mplayer-vaapi (их несколько штук). Или не тратить время на mplayer-vaapi годичной давности с его глюками, а поставить VLC и одной галкой включить аппаратное декодирование видео.

RussianNeuroMancer ★★★★★ ()

Ну и как, получилось?

У меня

DISPLAY=:8.0 optirun mplayer -vo vdpau filename
запускает видео, но выхлоп идет черт-те куда. На экране пусто.

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от Eddy_Em

То как ты пытаешься это запустить - оно не взлетит. Точный мануал есть в топике. У людей работает, но у меня не взлетело. Там есть рассуждения об xpra, у меня оно тормозит. Скорее всего у меня проблема или в драйверах, или в каких то настройках. Пробуй сделать всё по мануалу, авось взлетит.

Ygor ★★★★★ ()
Ответ на: комментарий от Ygor

Точный мануал есть в топике.

Там нужно какое-то г., вроде компиза.

Да я вчера проверил на vaapi ворованный блюрей — отлично работает. Так что, можно не париться. Как-нибудь на досуге еще попробую куду прикрутить. А то видеокарта там приличная: OpenGL4 поддерживает, куду вроде тоже приличную держит.

Eddy_Em ☆☆☆☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.