LINUX.ORG.RU

bumblebee


0

1

Делал все по вики. Не работает. Ошибка:

sudo optirun glxspheres 
Polygons in scene: 62464
No protocol specified
ERROR (585): Could not open display

главное, что в версии 2.4 все работало(

Ответ на: комментарий от kostik87

дистрибутив archlinux. видеокарта gt325m на ноутбуке asus n61 j.

trinimak ()

Это если от рута запускать.
А от обычного пользователя bumblebee не хочет запускаться:

[parallax@laptop $ rc.d start bumblebeed 
:: Starting Bumblebee                                                                                                                                                ERROR: could not insert 'bbswitch': Operation not permitted
/etc/rc.d/functions: line 203: /run/daemons/bumblebeed: Отказано в доступе

пользователь в группе bumblebee состоит. не пойму в чем дело.

trinimak ()

Пытался поставить bumblebee на Slackware 13.37 x86. Возился два дня, нагуглил и прочитал кучу инфо, накачал кучу вариантов, но так и не удалось запустить. Пока только bbswitch собрал из сырцов и выключаю nvidia карту для экономии батарей.

cadaber ★★ ()
Ответ на: комментарий от cadaber

Кажется заработало. Наверное какие-то глюки с правами доступа у группы bumblebee, не знаю. Сначала ставил bumblebee из git, при запуске была ошибка которую выше описал. Поставил стабильную, снова прописал пользователя в группу, перезагрусился, работает...Если не считать этой маленькой проблемы, то 3-я версия получше, намного лучше, больше ни какой еб*и с acpi_call и настройкой bumblebee.

trinimak ()
Ответ на: комментарий от thelonelyisland

Не стартует Х нвидии на bumblebee

Здравствуйте! помогите с bumblebee. Все установил из репозитроиев, драйвера рабочие. При запуске любого приложение ч/з optirun в логе демона появляется следующее:

[ 1515.373088] [WARN][XORG] (WW) NVIDIA(0): Unable to get display device for DPI computation. [ 1515.392776] [ERROR]X did not start properly

, а в терминале, откуда выполняю запуск следующее:

[ERROR]Cannot access secondary GPU - error: X did not start properly [ 1515.392853] [ERROR]Aborting because fallback start is disabled.

Мои конфиги: xorg.conf.nvidia:

Section «ServerLayout» Identifier «Layout0» Option «AutoAddDevices» «false» EndSection

Section «Device» Identifier «Device0» Driver «nvidia» VendorName «NVIDIA Corporation» Option «NoLogo» «true» Option «UseEDID» «false» Option «UseDisplayDevice» «none» Option «ConnectedMonitor» «CRT-0» BusID «PCI:1:0:0» EndSection

Bubmblebee.conf:

[bumblebeed] VirtualDisplay=:8 KeepUnusedXServer=false ServerGroup=programmeur TurnCardOffAtExit=true NoEcoModeOverride=false Driver=nvidia [optirun] VGLTransport=proxy AllowFallbackToIGC=false

[driver-nvidia] KernelDriver=nvidia PMMethod=bbswitch LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia XorgModulePath=/usr/lib/nvidia,/usr/lib/xorg/modules XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

[driver-nouveau] KernelDriver=nouveau PMMethod=auto XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

Ноут Asus P53S /Geforce GT520M/ Debian testing. Kernel 3.0.42-core-i5-with-pae.

Не понимаю в чем проблема.

PROgrammeur ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.