LINUX.ORG.RU

[debian-testing] 10-битное видео не работает


0

2

Доброго времени суток.

Собственно, ни один из установленных мною плееров (Smplayer (на mplayer2), vlc, Dragon Player, Kplayer, xine) не хочет воспроизводить 10-битное видео.

Smplayer выпадает в осадок так:

/usr/bin/mplayer -noquiet -nofs -nomouseinput -vc ffh264vdpau -sub-fuzziness 1 -identify -slave -vo vdpau -ao alsa:device=hw=1.0 -nokeepaspect -framedrop -hardframedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 83886536 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/zeekaa/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp enca:ru:UTF-8 -vid 0 -aid 0 -subpos 100 -volume 54 -nocache -osdlevel 0 -idx -slices -channels 2 -af volnorm=1,scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/zeekaa/Загрузки/Madoka_opening_10-bit_1080p.mkv

MPlayer2 UNKNOWN (C) 2000-2011 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Terminal type `unknown' is not defined.

Playing /home/zeekaa/Загрузки/Madoka_opening_10-bit_1080p.mkv.
ID_VIDEO_ID=0
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
ID_AUDIO_ID=0
ID_AID_0_LANG=jpn
[mkv] Track ID 2: audio (A_AAC), -aid 0, -alang jpn
[mkv] Will play video track 1.
Detected file format: Matroska
VIDEO:  [avc1]  1920x1080  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
Load subtitles in /home/zeekaa/Загрузки/
ID_FILENAME=/home/zeekaa/Загрузки/Madoka_opening_10-bit_1080p.mkv
ID_DEMUXER=mkv
ID_VIDEO_FORMAT=avc1
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1920
ID_VIDEO_HEIGHT=1080
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=1.7778
ID_AUDIO_FORMAT=MP4A
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_START_TIME=0.00
ID_LENGTH=90.15
ID_SEEKABLE=1
ID_CHAPTERS=0
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
ID_VIDEO_CODEC=ffh264vdpau
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
ID_AUDIO_BITRATE=128000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
[AO_ALSA] Format floatle is not supported by hardware, trying default.
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
ID_AUDIO_CODEC=ffaac
[Mixer] No hardware mixing, inserting volume filter.
Starting playback...
Unsupported PixelFormat 72
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.


MPlayer interrupted by signal 11 in module: check_framedrop
ID_SIGNAL=11
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Если убрать «Отключать видеофильтры при использовании vdpau» то:
/usr/bin/mplayer -noquiet -nofs -nomouseinput -vc ffh264vdpau -sub-fuzziness 1 -identify -slave -vo vdpau -ao alsa:device=hw=1.0 -nokeepaspect -framedrop -hardframedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 83886536 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/zeekaa/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp enca:ru:UTF-8 -vid 0 -aid 0 -subpos 100 -volume 54 -nocache -osdlevel 0 -idx -vf-add spp,scale -vf-add ass -vf-add screenshot -slices -channels 2 -af volnorm=1,scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/zeekaa/Загрузки/Madoka_opening_10-bit_1080p.mkv

Option vf-add: spp doesn't exist.
Error parsing option on the command line: -vf-add
MPlayer2 UNKNOWN (C) 2000-2011 MPlayer Team
ID_EXIT=NONE
VLC и xine воспроизводят только звук. Dragon Player, Smplayer (при устройстве вывода, отличном от vdpau) и Kplayer просто выпадают без объяснения причин.

Собственно, ЧЯДНТ?

Ответ на: комментарий от darkshvein
/usr/bin/mplayer -noquiet -nofs -nomouseinput -vc coreserve, -sub-fuzziness 1 -identify -slave -vo xv:adaptor=0 -ao alsa:device=hw=1.0 -nokeepaspect -framedrop -hardframedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 102760904 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/zeekaa/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp enca:ru:UTF-8 -vid 0 -aid 0 -subpos 100 -volume 54 -nocache -osdlevel 0 -idx -vf-add spp,scale -vf-add ass -vf-add screenshot -slices -channels 2 -af volnorm=1,scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/zeekaa/Загрузки/Madoka_opening_10-bit_1080p.mkv

Option vf-add: spp doesn't exist.
Error parsing option on the command line: -vf-add
MPlayer2 UNKNOWN (C) 2000-2011 MPlayer Team
ID_EXIT=NONE
zeekaa ()
Ответ на: комментарий от darkshvein

Как-то сам не понял, откуда их там столько. Это ставится автоматом у Smplayer, я тут не при чем. Да и с одним "-vo xv" mplayer всё равно не играет фаил:

zeekaa@zeekaaPC:~$ mplayer -vo xv /home/zeekaa/Загрузки/Madoka_opening_10-bit_1080p.mkv
MPlayer2 UNKNOWN (C) 2000-2011 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/zeekaa/Загрузки/Madoka_opening_10-bit_1080p.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AAC), -aid 0, -alang jpn
[mkv] Will play video track 1.
Detected file format: Matroska
VIDEO:  [avc1]  1920x1080  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
Load subtitles in /home/zeekaa/Загрузки/
[ass] auto-open
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Asking decoder to use 2 threads if supported.
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open '/dev/snd/pcmC0D0p' failed (-2): No such file or directory
[AO_ALSA] alsa-lib: pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa'
[AO SDL] Samplerate: 48000Hz Channels: Stereo Format s16le
[AO SDL] using aalib audio driver.
[AO SDL] Unable to open audio: No available audio device
Failed to initialize audio driver 'sdl:aalib'
Could not open/initialize audio device -> no sound.
Starting playback...
V:   0.0   0/  0 ??% ??% ??,?% 0 0 
Unsupported PixelFormat 72
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.

FATAL: Could not initialize video filters (-vf) or video output (-vo).


Exiting... (End of file)

zeekaa ()

тебе надо самый последний mplayer2 (из гита). у меня с ним все работатет, а так выкидывало точно такую же ошибку «Unsupported PixelFormat 72»

Rubbiroid ()
Ответ на: комментарий от Rubbiroid

Стянул с сайта (не из гита) последний (2.0). Видео есть. Звука нет.

Погуглив, нашел репозиторий http://debian-multimedia.org/ и поставил оттуда.

ВНЕЗАПНО заработало. Спасибо всем. Решено.

zeekaa ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.