LINUX.ORG.RU

Как объединить и синхронизировать 2 потока m3u8 (аудто и видео)

 , ,


0

2

Один выдавал которого было и видео. Теперь же он два разных засовывает и воспроизводит. Как мне одно нормальное синхронизировать


-i video.m3u8 -i audio.m3u8 -c copy адрес/выход

Вероятно придётся синхронизировать. Точно не скажу, -ss 4÷6 перед первым либо вторым входом.

*Как-то Rai1HD так смотрел, достаточно долго…

xradio ()
Ответ на: комментарий от xradio
Ответ на: комментарий от anonymous

если кликнуть по ссылкам этим скачается m3u8, но работать не будет. Нужно воткнуть ссылку в VLC тогда будет играть

Ну или создать тескстовый документ ,прописать первой строкой «#EXTM3U», второй вставить ссылку из поста, сохранить в UTF-8 как m3u8. Тогда будет рабочий m3u8 сразу

anonymous ()
Ответ на: комментарий от anonymous
Ответ на: комментарий от anonymous

Насколько я понял, команда «ffmpeg -i video.m3u8 -iaudio.m3u8 -c copy» просто проигрывает ссылки, но мне нужно не просто проиграть эти источники, а сохранять результат

anonymous ()
Ответ на: комментарий от xradio

Вам покажется смешным,но я лишь поверхностно в теме) Я прописываю «ffmpeg -i video.m3u8 -i audio.m3u8 -c copy Desktop/1.ts» для сохранения на рабочий стол (Windows 10). Но не хочет работать…

At least one output file must be specified «unique_id» не является внутренней или внешней командой, исполняемой программой или пакетным файлом. «unique_id» не является внутренней или внешней командой, исполняемой программой или пакетным файлом.

anonymous ()
Ответ на: комментарий от anonymous
Ответ на: комментарий от xradio

У тебя работает…не могу понять в чем дело. Попробовал на ноутбуке,тоже не играет звук. Можешь для особо умных показать полностью строчку кода ffmpegшного?

NowNo ()

может кто подскажет в какую сторону копать? ffmpeg на десятой винде. Аудио и видео по отдельности воспроизводятся командой «ffplay «поток»». Но как только ввожу «ffplay «поток видео» «поток аудио»» - играет только видео без звука. после экспериментов со сменой мест слагаемых выяснилось,что играется только тот поток,который идет первым. Если аудио поставить первым,то будет только звук… Пробовал перед потоком добавлять «-i» итог тот же

anonymous ()