LINUX.ORG.RU

Blender 2.80 блокирует воспроизведение аудио и видео

 , ,


1

2

Ubuntu 18.04 LTS. Запускаю Блендер 2.80 из образа snap. Сыпет ошибки, но запускается.

Received X11 Error:
        error code:   179
        request code: 155
        minor code:   34
        error text:   GLXBadFBConfig
Received X11 Error:
        error code:   179
        request code: 155
        minor code:   34
        error text:   GLXBadFBConfig
Received X11 Error:
        error code:   179
        request code: 155
        minor code:   34
        error text:   GLXBadFBConfig
Received X11 Error:
        error code:   8
        request code: 155
        minor code:   34
        error text:   BadMatch (invalid parameter attributes)
Received X11 Error:
        error code:   8
        request code: 155
        minor code:   34
        error text:   BadMatch (invalid parameter attributes)
Received X11 Error:
        error code:   8
        request code: 155
        minor code:   34
        error text:   BadMatch (invalid parameter attributes)
found bundled python: /snap/blender/33/2.80/python
Дополнение 1: эти ошибки относятся к отрисовке окна.

Запускаю в браузере Ютуб — видео стоит, как на паузе. Скачиваю ролик, запускаю в Mplayer-е и mpv — тоже стоит, как на паузе. Пробую звуковые файлы — то же. В консоли mplayer пишет «Audio device got stuck!», а mpv — «[ao/pulse] The stream is suspended. Bailing out.» Убил демона pulseaudio — видео вне браузера заработало.

Можно их как-то заставить работать вместе?

Ответ 1: можно отключить звук в Блендере. Edit ⇒ Preferences ⇒ System ⇒ Sound, сменить Audio Device на Null. Что удивительно, блокируется при SDL (по умолчанию) и OpenAL.

★★★★★

Ответ на: комментарий от question4

2.80 не собирается под 18.04

Хорошо, а последняя «собираемая» версия работает как положено, или «артачится», как «снап»?

или ещё какое извращение

Попробуйте тогда flatpak. Тоже извращение по-своему.

Korchevatel ★★★★★ ()
Ответ на: комментарий от question4

Скачай архив и распакуй. Или собери сам. Зачем тебе устанавливать какой-то собранный неизвестно кем пакет? Не надо никаких пакетов.

sid350 ★★★★★ ()
Ответ на: комментарий от Korchevatel

Хорошо, а последняя «собираемая» версия работает как положено, или «артачится», как «снап»?

2.79 звук не блокирует.

question4 ★★★★★ ()
Ответ на: комментарий от sid350

Скачай архив и распакуй. Или собери сам.

Затем, что требуется новая libc. И ещё что-то.

Зачем тебе устанавливать какой-то собранный неизвестно кем пакет?

Официальный сайт — это «неизвестно кто»?

question4 ★★★★★ ()

Можно попробовать зайти в настройки на вкладку System и выбрать там какой-нибудь другой Audio Device (например, Null).

zezic ★★★★ ()
Ответ на: комментарий от zezic

Можно попробовать зайти в настройки на вкладку System и выбрать там какой-нибудь другой Audio Device (например, Null).

Интересно. Доступны Null, JACK, SDL, OpenAL и OpenAL - Soft. По умолчанию было SDL. Для OpenAL и OpenAL - Soft тоже блокирует. JACK у меня не запущен, поэтому с JACK и Null не блокирует. Спасибо.

question4 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.