LINUX.ORG.RU

TVTime Отсутствие звука

 ,


0

1

Сообственно сабж, отсутсвует звук в TVTime. ОС: Linux Mint 18 TV-тюнер: AverTV Studio 505, подключен шнуром к звуковой карте Параметры saa7134.conf: card=170 tuner=51 Просматриваю с источника Composite2. К нему подключен спутниковый ресивер. Уровень Line в alsamixer поднял, Mute отключил. Но звука все равно нет. Готов предоставить инфу по требованию. Есть ли еще на форуме люди, использующие тюнеры? Хелп!

К нему подключен спутниковый ресивер.

оп-па, и тут в тред врываются космические технологии. автор, как удалось захватывать спутниковый сигнал с помощью AverTV Studio 505? Или за те 100500 лет, что прошли со времени его выпуска, он настоялся, забродил и теперь принимает? О_о
Или на вход тюнера подается сигнал с приёмника? Оригинальная конструкция
А так вся инфа в гугле. Поиграться с параметрами и авось заработает. Параметры card и tuner надо сначала посмотреть не автоопределяются ли. Плюс там еще полно рюшек.
В гугл короче, на форумах их хаотично перебирают, но это не значит что среди них нет рабочей комбинации.)
У меня были тюнеры, но так давно что не помню какие именно. 507ые вроде, потом Бехолдер(ы)...

mos ★★☆☆☆ ()
Последнее исправление: mos (всего исправлений: 1)
Ответ на: комментарий от mos

Пишу не просто так. Перебирал самые разные варианты, выданные гуглом. Не помогло. Видимо, методом тыка не получится. Есть те, кто может со знанием дела направить на путь истинный?

Dandula ()

использовал этт тюнер годы назад(5+- назад)

гугли как сконфигурировать aver под линукс....там несколько инструкций похожих одна из них правильная

там чтото с модулями в ядре,нужно править файл черного списка modprobe дулать....не помню толком

но да-по дефолту звука нет,это нормально надо настраивать

jsi36331 ()
Ответ на: комментарий от jsi36331

Сам раньше давненько юзал Убунту 10+-. Под нее нормально настраивалось согласно все тех же инструкций, хотя звука тоже изначально не было. А вот сейчас ни в какую(((

Dandula ()
Ответ на: комментарий от Dandula

может не просто инструкции выполнять (75% из которых шлак особенно в рунете) а таки понимать, что делаешь?

я уже сказал, ты хоть проверь может карта сама правильно определяется. убери параметры модуля, посмотри dmesg и от туда уже пляши. твоя задача скорее всего решается 15 минутами гуглинга. но в любом случае гуглинга.

хотя что я говорю, это ж лор. щас набегут васяны и надают советов.

mos ★★☆☆☆ ()

Вход Line In есть в двух вариантах: на захват и на воспроизведение. Плюс в совеременных звуковых картах есть возможность направлять на воспроизведение различные входы, поэтому:

  • убедись, что Line In размьючен на вкладке Playback alsamixer-а (F3): http://rgho.st/7NgyfzZb7/image.png ; по идее, это tvtime сделает без тебя — он управляет громкостью именно этого канала
  • убедись, что на вкладке захвата (F4) в качестве Input Source (любого из, как я понимаю) выбран «Line»: http://polariton.rghost.ru/8KtqgNYx7/image.png

Конечно, может быть случилось чудо и теперь tvtime умеет захватывать звук с тюнера через PCI-шину (в чем я в этом сильно сомневаюсь) — тогда Capture нужно будет перевести в «Line».

kawaii_neko ★★★★ ()
Ответ на: комментарий от kawaii_neko

А, ну и конечно, желательно убедиться, что ты действительно воткнул шнурок в Line In вход.

kawaii_neko ★★★★ ()
Ответ на: комментарий от kawaii_neko

Настройки alsamixer соответствуют указанным выше. Однако, на изменение громкости в tvtime не реагирует ни один из ползунков в alsamixer. Шнурок точно воткнут. Под виндой звук есть.
Убрал параметры saa7134.conf. Вот вывод dmesg:

[   12.858236] saa7134: saa7130/34: v4l2 driver version 0, 2, 17 loaded
[   12.858343] saa7134: saa7130[0]: found at 0000:05:01.0, rev: 1, irq: 17, latency: 64, mmio: 0xfebffc00
[   12.858347] saa7134: saa7134: <rant>
               saa7134:  Congratulations!  Your TV card vendor saved a few
               saa7134:  cents for a eeprom, thus your pci board has no
               saa7134:  subsystem ID and I can't identify it automatically
               saa7134: </rant>
               saa7134: I feel better now.  Ok, here are the good news:
               saa7134: You can use the card=<nr> insmod option to specify
               saa7134: which board do you have.  The list:
#тут был список доступных карт
[   12.858750] saa7134: saa7130[0]: subsystem: 1461:a11b, board: UNKNOWN/GENERIC [card=0,autodetected]
[   12.858762] saa7134: saa7130[0]: board init: gpio is 105c0
[   13.008010] saa7134: i2c eeprom 00: 61 14 1b a1 ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008014] saa7134: i2c eeprom 10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008016] saa7134: i2c eeprom 20: ff f1 ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008018] saa7134: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008020] saa7134: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008021] saa7134: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008023] saa7134: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008025] saa7134: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008026] saa7134: i2c eeprom 80: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008028] saa7134: i2c eeprom 90: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008030] saa7134: i2c eeprom a0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008031] saa7134: i2c eeprom b0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008033] saa7134: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008035] saa7134: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008036] saa7134: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.008038] saa7134: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   13.024009] saa7134: i2c scan: found device @ 0x86  [tda9887]
[   13.032007] saa7134: i2c scan: found device @ 0xa0  [eeprom]
[   13.040007] saa7134: i2c scan: found device @ 0xc2  [???]
[   13.045178] saa7134: saa7130[0]: registered device video0 [v4l2]
[   13.045212] saa7134: saa7130[0]: registered device vbi0
[   13.108211] saa7134_alsa: saa7134 ALSA driver for DMA sound loaded
[   13.108214] saa7134_alsa: saa7130[0]/alsa: UNKNOWN/GENERIC doesn't support digital audio

Dandula ()
Ответ на: комментарий от Dandula

как видим карта не определилась
Ставь card= и гляди что за карту выберешь
505 может и нету в драйвере
Если карта нужная или точно подходящая и каналы показывает/переключает то наверное дело в микшере или подключении шнурка
Больше нечему не работать

mos ★★☆☆☆ ()
Ответ на: комментарий от mos

Выбирал до этого card=170. Это как раз моя: AverTV Studio 505. Шнурок подключен. Картинка в таком варианте захватывается нормально. А вот что еще можно попробовать с микшером просто не знаю. Повторюсь, на более ранних версиях Убунту работало после манипуляций с alsamixer. Сейчас это не помогает.

Dandula ()
Ответ на: комментарий от Dandula

Давай фотку провода и скриншоты всего из alsamixer

и манипуляции с alsamixer ты ведь проводишь с включенным tvtime да?

mos ★★☆☆☆ ()
Последнее исправление: mos (всего исправлений: 1)

Попрбуйте для начала воткнуть наушники / колонки на прямую в TV тюнер. Если звук будет (хотябы тихий) то проблема в настройках звуковой (alsa). Если будет полная тишина - то нужно ковырять сам тюнер (возможно чтото с настройками аудио кадирования - можно будет в режиме FM приемника проверить).

zaz ★★★★ ()
Ответ на: комментарий от mos

Приемник выдает в стандарте PAL, но я пробовал с разными, в т.ч. и SECAM. Также менял стандарт аудио. Тоже безрезультатно. Звука на напрямую подключенных наушниках нет.

Dandula ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.