LINUX.ORG.RU

Alsa не выводит звук через HDMI выход на карте nvidia.

 , , , ,


1

0

Стоящая у меня видеокарта:
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)

Так вот,на убунте вполне себе получается с открытыми драйверами выводить через неё звук на монитор.
А вот в Debian,изначально wheezy,потом переподключённый для решения этого вопроса на testing миксер в mate так и остаётся не активным и звука нет.
Хотя я думаю что если поставить pulseaudio то звук выводится будет,
Но это я буду делать только если мне тут ничего путного не предложат.
В общем спрашиваю я о том,как заставить alsa работать?
Или может поменять её на OSS?

★★★★★

Вывод # aplay -l твою карту кажет? Если, скажем, через mplayer попробовать проиграть звук так:

$ mplayer -ao alsa:dev=hw:1 test.mp3
звук будет?

yars068 ★★★★ ()
Последнее исправление: yars068 (всего исправлений: 1)
Ответ на: комментарий от yars068

aplay -l

user@ggg:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
user@ggg:~$ 

mplayer -ao alsa:dev=hw:1 test.mp3 выводит сообщение и прекращает работу:

user@ggg:~$ mplayer -ao alsa:dev=hw:1 test.mp3
MPlayer2 2.0-728-g2c378c7-4+b1 (C) 2000-2012 MPlayer Team
Cannot open file '/home/user/.mplayer/input.conf': No such file or directory
Failed to open /home/user/.mplayer/input.conf.
Cannot open file '/etc/mplayer/input.conf': No such file or directory
Failed to open /etc/mplayer/input.conf.

Playing test.mp3.
Detected file format: MP2/3 (MPEG audio layer 2/3) (libavformat)
[mp3 @ 0xb627c040]max_analyze_duration 5000000 reached
[mp3 @ 0xb627c040]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: audio (mp3), -aid 0
Clip info:
 title: А чё чё  (zaycev.net)
 artist: Бьянка
Load subtitles in .
Selected audio codec: MPEG 1.0/2.0/2.5 layers I, II, III [mpg123]
AUDIO: 44100 Hz, 2 ch, s16le, 320.0 kbit/22.68% (ratio: 40000->176400)
Could not parse arguments at the position indicated below:
dev=hw:1
^

[AO_ALSA] -ao alsa commandline help:
[AO_ALSA] Example: mplayer -ao alsa:device=hw=0.3
[AO_ALSA]   Sets first card fourth hardware device.

[AO_ALSA] Options:
[AO_ALSA]   noblock
[AO_ALSA]     Opens device in non-blocking mode.
[AO_ALSA]   device=<device-name>
[AO_ALSA]     Sets device (change , to . and : to =)
Failed to initialize audio driver 'alsa:dev=hw:1'
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video


Exiting... (End of file)
user@ggg:~$ 

torvn77 ★★★★★ ()
Ответ на: комментарий от anonymous

Утащил из убунты ядро vmlinuz-3.19.0-10-generic
Это мне не помогло.
И сомневаюсь что могло помочь,так как ядра на Дебиане не сильно старше:
vmlinuz-3.16.0-4-686-pae
А с другой стороны ранее попытка перейти на als'у на Убунте так же закончилась неудачей.

Мне pulseaudio не нравится тем,что не позволяет назначить музыку,оповещения и речь на разные устройства,
так как скрывает их от приложения,что особо не приятно в мессенджерах,например в skype.

torvn77 ★★★★★ ()
Последнее исправление: torvn77 (всего исправлений: 5)
Ответ на: комментарий от torvn77

Я пользуюсь mplayer'ом из консоли от случая к случаю, и потому не запоминаю опции командной строки. Но на этот случай есть маны, верно? Правильная команда будет такой:

mplayer -ao alsa:device=hw=0.3
Это даже в выводе mplayer'а видно. Если звук пойдет, нужно будет сделать один из HDMI-выходов дефолтным.

yars068 ★★★★ ()
Последнее исправление: yars068 (всего исправлений: 1)
Ответ на: комментарий от anonymous

Всем спасибо,нашёл там следующее:
Создать файл /etc/asound.conf и набрать в нём
pcm.!default {
type hw
card 1
device 3
}

с той только разницей,что card у меня 0,а device почему то 7.

И теперь плееры работают нормально,но тем не менее браузер Iceweasel/firefox по прежнему воспроизводить музыку не хочет.
Поискал какой нибудь подходящий параметр в about:config,ничего подходящего найти не смог.
Через пулсу браузер работает.

torvn77 ★★★★★ ()
Ответ на: комментарий от torvn77

Если имеется ввиду воспроизведение средствами браузера, а не Flash, то работает это через GStreamer. Можно попробовать покрутить через gstreamer-properties.

pumbez ★★★ ()
Ответ на: комментарий от torvn77

title: А чё чё (zaycev.net)
artist: Бьянка

Тролль дофига, да?

CYB3R ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.