LINUX.ORG.RU
решено ФорумMobile

Qt5 Android, проблемы с настройками

 , , ,


0

1

Ошибки: Фото1, Фото2 Android Studio IDE последняя. SDK ставил оттуда. NDK последний распаковано отдельно Ant в новой QtCreator некуда вписать путь. Пишет ошибку:

Требуется java версии только 1.8.

GNU / Linux Mint 19. Что мне сделать?

Благодарю за ответы!

Android Studio IDE последняя.

2 звезды, 8 лет на ЛОРе, а формулировка как у кали-школьников. Ты заставляешь людей лезть неизвестно куда и смотреть, какая она там. Не говоря о том, что завтра же она может перестать последней (после первого же обновления). Указывай конкретные номера версий. Пожалуйста.

hobbit ★★★★★ ()
Ответ на: комментарий от anonymous

Да что вы все на ТС набросились? Не нравиться, проходите мимо…

Не уверен, что смогу помочь, но по-моему дело в java и её SDK

openjdk version «1.8.0_212» // это в моей системе

anonymous ()
Ответ на: комментарий от anonymous

openjdk version «1.8.0_212» // это в моей системе

Вот это кстати возможно. Я делал 2 попытки установки. В первый раз я уставил кучу всего с словом java. Возможно что-то конфликтует. Придётся сносить систему или снапшот из timeshift'а восстанавливать. Я до экспериментов сделал.

xwicked ★★ ()
Ответ на: комментарий от anonymous

я аж чаем подавился…

Когда новичок в чём-то, то куча цифр(jdk, sdk, ndk, sdk-tools, java) сбивает с толку и поэтому я сделал фото, где есть ВСЯ информация. Каждый возмёт нужную себе и будет анализировать.

xwicked ★★ ()
Ответ на: комментарий от xwicked

честно говоря, эти фото ясности не привносят – на мой взгляд, кривая русификация только запутывает. вот брат-анонимус выше предположил, что речь идёт о

java и её SDK

что там в действительности подразумевается под «SDK платформы» сразу и не сообразишь. особенно, если сам не сталкивался с подобными сложностями.

я вас не осуждаю, нужно быть терпимее к друг к другу. все мы люди, все ошибаемся…

anonymous ()

Я понял. JRE(или просто Java) - это как .net, а JDK - это как .net devel. Скачал JRE. Скопировал в /usr/local/. Создал симлинк в /usr/bin. команда

java --version

Показала 1.8, но в QtCreator ничего не изменилось. Вычитал ещё, что JDK содержит в себе JRE, может мне JDK поставить в систему и сконфигурировать?

xwicked ★★ ()
Ответ на: комментарий от xwicked

Проблема заключается в jdk 9 и выше. По какой-то странной причине он не показывает лицензионные соглашения и не продолжается после этого. Исправление залипает с jdk8
Java 8 в порядке, но JDK 9 и JDK 10 не работают с sdkmanager

ППц, похоже я нашёл проблему...

xwicked ★★ ()
Ответ на: комментарий от xwicked

Ну, да. Вопрос решён. JDK 8 версии требовала. Но легче не стало. Крашится теперь эмулятор.
P.S. Я чувствую, что ещё пара дней и я вернусь на тёплый ламповый оффтопик, где всё работает...

xwicked ★★ ()