LINUX.ORG.RU

Gnome 2 Gentoo

 ,


0

1

Пытаюсь поставить кошерный второгном, вместо третьего. удалил всё что было от третьегнома, замаскировал >gnome-base/gnome-light-2.32.1-r2 Emerge завершился, пытаюсь запустить через gdm... И тут оказывается что gdm и gnome panel от 3.8.5. Нихрена, соответственно, не работает. Глянул в ебилд - он тянет зависимостями самое новое, без ограничений. Соответственно, gnome-control-center-3.8.5 тоже вряд ли подходит. Замаскировал его, удалил, обновляю мир.. Ругается и хочет размаскировать его. Почему? ЧЯДНТ? Если есть, скиньте инструкцию по установке второгнома, актуальную сейчас.

он тянет зависимостями самое новое, без ограничений

Если нет указания обратного, то да, будут ставиться последние стабильные (размаскированные) версии.

Вот текущие стабильные версии gnome-base/gnome-panel:
http://packages.gentoo.org/package/gnome-base/gnome-panel

и gnome-base/gnome:
http://packages.gentoo.org/package/gnome-base/gnome

Зелёным выделены стабильные ветки. Жёлтым - тестовые, красным - не стабильные.

Так что если вы размаскировали тестовую версию пакета, то убирайте размаскирвоание. А если вы прописали ACCEPT_KEYWORDS=«~x86 ~amd64», то маскируйте версии пакетов, которые вы не хотите ставить. По другому ни как. Сами же размаскировали, сами и разбирайтесь.

Ну и если вы просто удалили пакет gnome-base/gnome версии 3.6 или 3.8, то все установленные зависимости этого пакета в основном остались. Вам теперь нужно удалить все зависимости.

Хотя бы так:

emerge -avc

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 2)

У тебя есть два варианта. Ставить мате или маскировать версии. Как это сделать, выше написали.

a1batross ★★★★★ ()

А?

eix gnome-panel
[I] gnome-base/gnome-panel
     Available versions:  2.32.1-r3 ~3.6.2-r1 ~3.8.0 ~3.8.0-r1 {+bonobo eds +introspection networkmanager}
     Installed versions:  2.32.1-r3(19:35:32 20.06.2013)(bonobo introspection -eds -networkmanager)
     Homepage:            https://git.gnome.org/browse/gnome-panel
     Description:         The GNOME panel

стабильная - gnome-base/gnome-panel-2.32.1-r3

См. свои package.keywords

record ★★★★ ()
Последнее исправление: record (всего исправлений: 5)

Если есть, скиньте инструкцию по установке второгнома, актуальную сейчас.


emerge -avt gnome-light

record ★★★★ ()
Ответ на: А? от record

То бишь, достаточно просто перейти на stable и будет ставиться только второгном, так что-ли? А что с package.keywords? что мне там надо увидеть? Извиняюсь за нубские вопросы - не так давно в gentoo

mersinvald ★★★★ ()
Ответ на: комментарий от mersinvald

То бишь, достаточно просто перейти на stable и будет ставиться только второгном, так что-ли?

да

А что с package.keywords?

Если тянется нестабильный пакет, значит, по идее, он тянется неким другим нестабильным пакетом.

record ★★★★ ()
Последнее исправление: record (всего исправлений: 1)
Ответ на: комментарий от record

Спасибо, так и сделаю) А можно будет выборочно размаскировывать пакеты ~amd64 после этого?

mersinvald ★★★★ ()
Ответ на: комментарий от mersinvald

Ещё раз. Если в пакете нет ограничений на максимальную версию пакета, то будет ставиться последняя стабильная (размаскированная) версия. Вот смотрите как обстоят дела с gnome-2.32.1-r2: http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/gnome-base/gnome/gnom...

# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome/gnome-2.32.1-r2.ebuild,v 1.12 2013/10/04 15:03:09 tetromino Exp $
...
RDEPEND="!<x11-libs/gtk+-3.2.4-r1:3
...
	>=gnome-base/gnome-applets-2.32.0
	>=gnome-base/gnome-panel-2.32.1
	>=gnome-base/gnome-menus-2.30.5
...

Если у вас размаскирована gnome-base/gnome-panel и прочие пакеты версий 3.*, являющиеся зависимостями для gnome-base/gnome, то они и будут ставиться.

Маскируйте их, если вы прописали ACCEPT_KEYWORDS=«~x86 ~amd64» или убирайте размаскировку.

kostik87 ★★★★★ ()
Ответ на: комментарий от mersinvald

Спасибо, так и сделаю)

Только у вас, если вы находитесь на тестовой ветке, сейчас вся система будет пересобираться, начиная от gcc, glibc, относительно glibc его нужно будет размаскировать той версии, которая сейчас стоит, и вообще все пакеты.

Так что вам проще установить Gentoo с нуля, оставаясь на стабильной ветке.

kostik87 ★★★★★ ()
Ответ на: комментарий от mersinvald

Молодец, ничего не понял из того, что написано в первом сообщении темы.

kostik87 ★★★★★ ()
Ответ на: А? от record

из какого пакета eix? Нет такой утилиты у меня

mersinvald ★★★★ ()
Ответ на: комментарий от kostik87

Дак маскировал же. Ругается и просит размаскировать обратно и не собирает

mersinvald ★★★★ ()
Ответ на: комментарий от mersinvald

Значит его тянет другая зависимость.

Запускай с ключом '-t' и смотри дерево зависимостей.

emerge -avt =gnome-base/gnome-2.32.1-r2

Надо маскировать не один пакет, а все которые прямо или косвенно могут «тянуть» зависимостью не нужную версию пакета.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от mersinvald

из какого пакета eix? Нет такой утилиты у меня

app-portage/eix

:-)

emerge -av eix

record ★★★★ ()
Ответ на: комментарий от mersinvald

То бишь, достаточно просто перейти на stable и будет ставиться только второгном, так что-ли? А что с package.keywords? что мне там надо увидеть? Извиняюсь за нубские вопросы - не так давно в gentoo


O_o
И кто тебе посаветовал ставить gentoo с unstable веткой?
Постав stable и облегчишь жизнь и себе и людям.

boyk0 ()
Ответ на: комментарий от mersinvald

Настольная книга Gentoo Linux x86

Если вы желаете использовать наиболее свежее ПО, подумайте над использованием тестовой ветви. Чтобы Portage начал использовать тестовую ветвь, добавьте «~» перед названием вашей архитектуры.
Однако будьте готовы к тому, что могут возникнуть проблемы со стабильностью, неудовлетворительной поддержкой пакетов (например неправильные/отсутствующие зависимости), слишком частыми обновлениями (а в результате — частыми сборками) или невозможностью собрать пакет. Если вы не знаете, как работает Gentoo и как разрешать возникающие проблемы, мы рекомендуем не отходить от стабильной и оттестированной ветви.


http://www.gentoo.org/doc/ru/handbook/handbook-x86.xml?full=1#book_part3_chap3

boyk0 ()
Ответ на: комментарий от boyk0

Мы легких путей не ищем! В stable всё слишком уж старо, с банальным разрешением зависимостей я вроде как справлялся, только тут такой вот камень предкновения. Теперь буду знать как такие решать. Собственно, для чего еще нужны форумы, если не для того чтобы учиться у более просвещенных людей тому что ты пока не умеешь?

mersinvald ★★★★ ()
Ответ на: комментарий от mersinvald

Нет проблем. Ставишь stable, а то что нужно поновее размаскировываешь (package.unmask). А так ИМХО, оновляться страшно )

boyk0 ()
Ответ на: комментарий от mersinvald

В стабильной ветке всё стабильно. Если вы считаете, что какой-то пакет стар и вам нужна новая версия и вы знаете почему, то размаскируйте только этот пакет и его зависимости.

Если вы просто считайте, что пакеты старые и вам нужны новые пакеты без понимания зачем, то лучше оставайтесь на стабильной ветке.

kostik87 ★★★★★ ()
Ответ на: комментарий от boyk0

Так, наверное и сделаю... Все равно точно знаю что мне нужно.

mersinvald ★★★★ ()

У меня в системе куча софта из 2го гнома (наутилус, панелька, менеджер архивов и просмотрщик пдф), где-то в инете находил список пакетов для packages.mask, чтобы не тянуло 3й гном

xorik ★★★★★ ()

А такой вариант не подойдёт sudo layman -a mate

Fist ()
Ответ на: комментарий от mersinvald

Это ты на физре скажешь что хендбук тебе посоветовал форму не брать. На лоре такое не работает.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.