LINUX.ORG.RU

Проблемы с драйверами

 , , , ,


0

1

Господа, помогите разобраться! Загружаюсь с Live USB Knoppix, смотрю lspci и наблюдаю работу видеокарты по драйверу ядра «radeon», работу wi-fi, соотв, по драйверу «ath5k». Захожу на свою систему (Gentoo 3.18.13), при сборке ядра нахожу требуемые драйвера, включаю их НЕ модулями, компилю все, перезагружаюсь, проверяю. lspci говорит, что моя видеокарта и мой wi-fi не работают, ибо нет драйверов в ядре. В чем моя ошибка? Подскажите пожалуйста! Ядро собираю make menuconfig.

lspci говорит, что моя видеокарта и мой wi-fi не работают

Да ладно, а я думал, она говорит какие устройства нашла на шине. Вот дела.

anonymous ()
Ответ на: комментарий от kostik87

«не работают» в смысле не написано какие драйвера в ядре использует => не работает, т.к. драйвера мы знаем и ожидаем там увидеть. Xorg рановато, иксы еще не поднимал, речь про консольную графику. Да и основная проблема в драйвере для wi-fi карты. Без него дальнейшая установка только с live usb, ибо интернета нет.

.config

Douglas ()
Ответ на: комментарий от Douglas

Покажите вывод 'lspci -k' на Knoppix и Gentoo.

К тому же вывод dmesg.

К тому же покажите вывод 'ifconfig -a'.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)

нахожу требуемые драйвера, включаю их НЕ модулями, компилю все

кто сказал, что этого достаточно? и что всё сделано верно. а в чем ошибка, подскажут как обычно телепаты. когда из отпуска вернутся.

mos ★★☆☆☆ ()

Knoppix:
lspci -k =
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV710 [Mobility Radeon HD 4300 Series]. Kernel driver in use: radeon
....
Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01). Kernel driver in use: ath5k
ifconfig -a =
eth0, lo, wlan0
****
Gentoo:
lspci -k =
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV710/M92 [Mobility Radeon HD 4330/4350/4550]
....
Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
ifconfig -a =
enp6s0, lo, sit0, tunl0
Последние два без MAC адреса, соотв не подходят. Первый:
dmesg | grep enp6s0 = systemd-udevd[1612]: renamed network interface eth0 to enp6s0
****
Где найти файл, с выводом dmesg? Нужен ли он?

Douglas ()
Ответ на: комментарий от Douglas

Покажите в Gentoo, лучше загрузитесь прямо в систему:

uname -a
find /lib/modules/`uname -r` -type f | grep "radeon\|ath" 

modprobe radeon
modprobe ath5k
dmesg | tail
kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

ноль эффекта... у меня есть идея, попробовать форматнуть все и все с нуля, заново. Если ситуация повторится - буду думать дальше. В любом случае, отпишусь о результатах.

Douglas ()
Ответ на: комментарий от Douglas

Что ноль эффекта ? Я вам указал эти команды, что бы вы поместили сюда их вывод.

kostik87 ★★★★★ ()
Ответ на: комментарий от Douglas

Ну что за резкие телодвижения. Для начала почисти реестр, для приличия.

anonymous ()

В общем, я не понял по каким причинам были эти проблемы, переустановка всего и вся помогла. Абсолютно те же шаги, что и в первый раз, но результат другой... Всем спасибо!

Douglas ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.