LINUX.ORG.RU

kde не запускается сразу после логина

 ,


0

1

Всем доброго времени суток.

Нуждаюсь в вашей помощи. Вчера поставил gentoo, все работает, кроме kde. При загрузке появляется стандартное кдешное окно для выбора пользователя и ввода пароля, однако при выборе оного больше ничего не происходит. Поле для ввода пропадает, остается лишь фон, на этом все заканчивается и рабочий стол не грузится. При попытке перейти в консоль через Ctrl-Alt-F1 выдается черный экран с надписью «This is localhost»; при попытке убить рабочий стол при помощи Ctrl-Alt-Backspace не происходит ничего. Папку ~/.kde удалил, пользователь состоит в группе video, нового пользователя пробовал создать — итог абсолютно такой же. Не сталкивались ли вы с такой проблемой? Подскажите, пожалуйста, где может быть собака зарыта. Заранее большое спасибо! Очень хотелось бы без перекомпиляции, если возможно, т.к. компиляция kde — это настоящая пытка.

Поставь какой-нибудь оконный менеджер и попробуй загрузить его.

А, и да, вывод Xorg.0.log бы не помешал - может у тебя там с видео проблема?

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Оконный менеджер стоит уже, kdm. По идее, не в видео проблема, иначе бы до графического логина дело бы не дошло. Графика intel i915 запускается с полупинка. Логи скину, как приеду домой и вооружусь liveusb с gentoo, т.к. в консоль даже не могу выйти из kde. Спасибо Вам большое за помощь!

ghostmansd ()
Ответ на: комментарий от Pinkbyte

Если есть еще какие-то файлы, которые имеет смысл показать, напишите, пожалуйста. Тоже скину.

ghostmansd ()
Ответ на: комментарий от ghostmansd

Логи скину, как приеду домой и вооружусь liveusb с gentoo, т.к. в консоль даже не могу выйти из kde.

Добавьте параметр «nox» к параметрам, передаваемым ядру.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

При попытке сделать это остаюсь в терминале, где лишь сиротливо мерцает строка «This is localhost». Ctrl+C, Ctrl+D против этой фигни не спасают. Вот паста с выводом /var/log/Xorg.0.log: http://pastebin.com/H6DcY7rR

Ранее использовался автосозданный файл xorg.conf. Только что удалил этот файл и снова попытался запусить, но тщетно бытие.

ghostmansd ()

Сейчас при перезагрузке обратил внимание на следующие строки: stopping kdm... [ok] start-stop-daemon: 1 process refused to stop Error stoping kdm [!!] ERROR: xdm failed to stop

Такого же быть не должно, верно? :-) Сейчас проверю конфиги на предмет запуска xdm.

ghostmansd ()
Ответ на: комментарий от ghostmansd

xdm там есть, должен грузиться.

xdm и kdm — это менеджеры ВХОДА в систему и выбора WM/DE. Должен только один работать, второго не нужно.

Попробуй удалить/отключить xdm.

drBatty ★★ ()
Ответ на: комментарий от ghostmansd

~/.xinitrc

kdm после логина должен включать иксы, и вот этот файл запускать.

drBatty ★★ ()
Ответ на: комментарий от unikum

Попробую чуть позже, сейчас пытаюсь сделать emerge всего, что входит в kde-meta. Но не думаю, что это поможет: KDE при запуске даже не доходит до генерации директории ~/.kde4, а ведь, по идее, с этого должно начинать.

ghostmansd ()
Ответ на: комментарий от ghostmansd

Мда, вы написали, что у вас проблема с запуском xorg-server`а и как следствие вы не можете переключиться на фиртуальные консоли. И вы хотите грузиться с LiveCD, затем делать chroot и прочее.

Я вам и написал как сделать так, что бы не запускался xorg-server (xdm), даже если он добавлен на уровень запуска.

Параметр «nox» обрабатывается стартовым сценарием /etc/init.d/xdm и в случае, если он присутствует xdm не запускается.

Он не устарнит проблемы в работе xorg-server`а, он устранит вашу проблему с не возможностью переключиться в виртуальную коносоль и избавит вас от необходимости загружаться с LiveCD.

Если вы этого не понялу, тогда я не знаю что ещё сказать.

kostik87 ★★★★★ ()
Ответ на: комментарий от drBatty

В Gentoo старторвый сценарий /etc/init.d/xdm является стартовым сценарием, который запускает xdm или другой Desktop Manager, который указан в конфигурационном файле /etc/conf.d/xdm .

kostik87 ★★★★★ ()
Ответ на: комментарий от ghostmansd
[    24.775] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    24.775] (WW) Disabling Mouse0
[    24.775] (WW) Disabling Keyboard0

Вы указали собирать драйверы xorg-server`а для устройств ввода как xf86-input-keyboard, xf86-input-mouse и xf86-input-evdev, оставьте только evdev или первые два, сейчас у вас используется evdev, но в этом случае первые два не нужны.

У вас Nvidia Optimus ?

kostik87 ★★★★★ ()
Ответ на: комментарий от ghostmansd

Когда /etc/init.d/xdm не запускается вы и так остаётесь в консоли.

Вы что не можете ввести ваш логин / root и пароль ?

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

При включенном xdm: есть графический логин, который все же не запускает KDE. При попытке переключиться в любом терминале выдается лишь строка «This is hostname». При выключенном xdm: логин не появляется, в любом терминале выдается лишь строка «This is hostname».

ghostmansd ()
Ответ на: комментарий от ghostmansd

Эта фигня не меняется при нажатии Ctrl-C или Ctrl-D; по этой причине я и не могу зайти из-под root и вынужден использовать liveusb.

use-флаги в разделе INPUT_DEVICES исправил, сейчас пересобираю xorg-x11.

Еще раз большое спасибо Вам за желание помочь и за терпение!

ghostmansd ()
Ответ на: комментарий от ghostmansd

Запустите ssh и подключитесь по ssh, затем смотрите вывод dmesg.

kostik87 ★★★★★ ()
Ответ на: комментарий от ghostmansd

сейчас пересобираю xorg-x11

Зачем ?

emerge -av1 x11-base/xorg-drivers
emerge -avc x11-drivers/xf86-input-keyboard x11-drivers/xf86-input-mouse
kostik87 ★★★★★ ()
Ответ на: комментарий от ghostmansd

Оконный менеджер стоит уже, kdm

KDM - это НЕ оконный менеджер. Оконный менеджер в KDE по умолчанию - kwin

Pinkbyte ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.