LINUX.ORG.RU

опять Debian


0

0

Привет всем! Попросили меня поставить Debian 3.0 Woody . Ну что ж, можно и поставить?... Поставился то он без проблем, да еще и обновился до 3.1 .. Все хорошо, единственное но - ядро 2.2.20... старовато. Дал я команды:
# apt-get install \
> kernel-headers-2.6.8-2-686 \
> kernel-image-2.6.8-2-686 \
> hostap-modules-2.6.8-2-686 \
> kernel-doc-2.6.8-2-686

Все пакеты были успешно загружены и установлены. Правлю lilo.conf:

boot=/dev/hda
prompt
timeout=50
lba32
vga=normal
read-only
map=/boot/System.map-2.6.8-2-686

image=/boot/vmlinuz-2.6.8-2-686
label=2.6.8
root=/dev/hda1

image=/boot/vmlinuz-2.2.20-idepci
label=2.2.20
root=/dev/hda1

В конце даю команду lilo и перекружаю комп.
И при загрузке ядра 2.6.8 получаю Kernel panic:

VFS: Cannot open root device "301" or unknown-block(3,1)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(3,1)

В чем проблема? Что я забыл поставить?

Как мне кажется ядро не может загрузить либо драйвера IDE контроллера, либо файловой системы (используется ext2)

Что мне сделать?

Re: опять Debian

initrd, бля! Ведь он БЫЛ в /etc/lilo.conf -- что ж ты правишь, не глядя на существующий конфиг?
Зто root= для каждого образ. Нафига?

Zulu ★★☆☆ ()

Re: опять Debian

Не помню, как в Woody, а в Sid (и в Sarge, наверно тоже уже) пакеты
kernel-image-* делают в / ссылки vmlinuz, initrd.img, vmlinuz.old и
initrd.img.old тогда lilo.conf выглядит примерно так:

...

image = /vmlinuz
root = /dev/hda1
initrd = /initrd.img
label = "New"
read-only

image = /vmlinuz.old
root = /dev/hda1
initrd = /initrd.img.old
label = "Old"
optional
read-only

...

Преимущество в том, что его не надо править при установке нового ядра.

watashiwa_daredeska ★★★★ ()

Re: опять Debian

>Все хорошо, единственное но - ядро 2.2.20...

Известная грабля (если ее можно так назвать) -- сам наступал ;)) Нужно было при установке ввести bf24 (если внимательно почитать, что он там пишет, а не жмякать <ENTER> вперед паровоза, то видно что там есть несколько вариантов установки, в т.ч. и с ядром из ветки 2.4, а именно 2.4.18)

php-coder ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.