LINUX.ORG.RU

Добавляешь репозитории сида и ставишь последнее ядро оттуда.

Debasher ★★★★★ ()

1. А репозитории wheezy прописаны?

2. Ядра 3.2-1, 3.2-2 - это разные ядра, их нужно устанавливать отдельно. Но в beta2 никаких изменений с веткой ядра не было. Что значит «всё равно 3.2.0»

feofil ()

но ядро почему-то все равно 3.2.0, а не 3.2.23-1

Это метапакет носит версию 3.2.0, а ты набери uname - увидишь реальную версию.

Zubok ★★★★★ ()
Ответ на: комментарий от feofil

У автора или у тебя? Вообще-то, новые ядра сами не обновляются, если имеют другое название пакета (а это именно так), их надо ставить вручную.

aptitude search linux-image покажет все доступные варианты.

Zubok ★★★★★ ()

Linux debian 3.2.0-3-686-pae #1 SMP Mon Jul 23 03:50:34 UTC 2012 i686 GNU/Linux

$ cat /etc/apt/sources.list #

# deb cdrom:[Debian GNU/Linux wheezy-DI-b2 _Wheezy_ - Official Snapshot i386 NETINST Binary-1 20120905-23:11]/ wheezy main

#deb cdrom:[Debian GNU/Linux wheezy-DI-b2 _Wheezy_ - Official Snapshot i386 NETINST Binary-1 20120905-23:11]/ wheezy main

deb http://ftp.ru.debian.org/debian/ wheezy main deb-src http://ftp.ru.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main deb-src http://security.debian.org/ wheezy/updates main

В то время как

linux kernel: Updated from 3.2.21-3 to 3.2.23-1.

Samu ()
Ответ на: комментарий от feofil

в beta2 уже 3.2.0-3, поэтому новых веток там нет.

Ребят, что такое бета2? НЕт никакого бета2 у Wheezy. Смотрите внимательно - это версия инсталлятора, а не Wheezy.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

И это я пробовал --

$ sudo aptitude search linux-image
v linux-image -
p linux-image-2.6-486 - Linux for older PCs (dummy package)
p linux-image-2.6-686 - Linux for modern PCs (dummy package)
p linux-image-2.6-686-bigmem - Linux for PCs with 4GB+ RAM (dummy package
p linux-image-2.6-686-pae - Linux for modern PCs (dummy package)
p linux-image-2.6-amd64 - Linux for 64-bit PCs (dummy package)
p linux-image-3.2.0-3-486 - Linux 3.2 for older PCs
i A linux-image-3.2.0-3-686-pae - Linux 3.2 for modern PCs
p linux-image-3.2.0-3-686-pae-dbg - Debugging infos for Linux 3.2.0-3-686-pae
p linux-image-3.2.0-3-amd64 - Linux 3.2 for 64-bit PCs
p linux-image-3.2.0-3-rt-686-pae - Linux 3.2 for modern PCs, PREEMPT_RT
p linux-image-3.2.0-3-rt-686-pae- - Debugging infos for Linux 3.2.0-3-rt-686-p
p linux-image-486 - Linux for older PCs (meta-package)
p linux-image-686 - Linux for modern PCs (dummy package)
p linux-image-686-bigmem - Linux for PCs with 4GB+ RAM (dummy package
i linux-image-686-pae - Linux for modern PCs (meta-package)
p linux-image-amd64 - Linux for 64-bit PCs (meta-package)
p linux-image-rt-686-pae - Linux for modern PCs (meta-package), PREEM

Samu ()

 Как обновить wheezy до beta 2 ?

Beta2 чего? У Debian нет альфа/бета-версий дистрибутива, только установщика.

Homura_Akemi ()
Ответ на: комментарий от Zubok

Я про образ и говорю. И про то, какая версия ядра в этом образе.

feofil ()

$ aptitude versions ~i~n^linux-image-3.2.0-
Пакет linux-image-3.2.0-2-686-pae:
i A 3.2.20-1 100

Пакет linux-image-3.2.0-3-686-pae:
i 3.2.23-1 testing,unstable 500

Перевожу на русский: смотрите на версии пакетов, а не на их названия.

AITap ★★★★★ ()
Ответ на: комментарий от Samu

А что тогда эти строки значат: linux kernel: Updated from 3.2.21-3 to 3.2.23-1. ?

Это значит, что установщик на диске (CD, DVD,...) содержит теперь ядро 3.2.23-1. Но в репозитории его нет, потому что репозиторий заморожен. Обновлений версий ядра там не будет уже. Если нужно более новое ядро, то можно взять из sid.

Zubok ★★★★★ ()

Короче, моя фраза про метапакет остается верной. 3.2.0 - это название пакеты.

Zubok ★★★★★ ()
Ответ на: комментарий от AITap

Разобрался, спасибо.

aptitude versions ~i~n^linux-image-3.2.0-
Пакет linux-image-3.2.0-3-686-pae: i A 3.2.23-1 testing 500

Samu ()
Ответ на: комментарий от Zubok

Это значит, что установщик на диске (CD, DVD,...) содержит теперь ядро 3.2.23-1. Но в репозитории его нет, потому что репозиторий заморожен. Обновлений версий ядра там не будет уже.

Такого быть не может. Особенно в релизе. В релизе версия ядра в системе и ядра в установщике ИДЕНТИЧНА. В тестинге установщик может чуть отставать, это непринципиально.

В sid сейчас, по-моему, ровно та же самая версия ядра.

feofil ()
Ответ на: комментарий от Zubok

uname -a делал:

$ uname -a
Linux debian 3.2.0-3-686-pae #1 SMP Mon Jul 23 03:50:34 UTC 2012 i686 GNU/Linux


Или Вы о чем-то другом ?

Samu ()
Ответ на: комментарий от feofil

Такого быть не может. Особенно в релизе. В релизе версия ядра в системе и ядра в установщике ИДЕНТИЧНА. В тестинге установщик может чуть отставать, это непринципиально.

Да, да, совершенно верно. Я признал, что не очень внимательно посмотрел на версии ядер в wheezy. Там же явно написано, что уже 3.2.23, а я не заметил.

Обновление debian (комментарий)

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Где? О_О

vr@lab ~ $ sudo apt-cache search linux-image
[sudo] password for vr:
linux-headers-3.2.0-3-amd64 - Header files for Linux 3.2.0-3-amd64
linux-headers-3.2.0-3-rt-amd64 - Header files for Linux 3.2.0-3-rt-amd64
linux-image-3.2.0-3-amd64 - Linux 3.2 for 64-bit PCs
linux-image-3.2.0-3-amd64-dbg - Debugging infos for Linux 3.2.0-3-amd64
linux-image-3.2.0-3-rt-amd64 - Linux 3.2 for 64-bit PCs, PREEMPT_RT
linux-image-3.2.0-3-rt-amd64-dbg - Debugging infos for Linux 3.2.0-3-rt-amd64
linux-image-amd64 - Linux for 64-bit PCs (meta-package)
linux-image-rt-amd64 - Linux for 64-bit PCs (meta-package), PREEMPT_RT
ololoid ★★★★ ()

Как обновить wheezy до beta 2 ?

Никак потому что такого нет в природе. Есть бета 2 инсталятора.

Polugnom ★★★★★ ()
Ответ на: комментарий от Zubok

Да, с «uname -a» в дебиане так же как и с «gcc -dumpversion» (начиная с 4.6). Но если у gcc я не видел столько patch-версий, сколько их у ядра, то «uname -a» становится просто бесполезной для пользователя.

gag ★★★★★ ()
Ответ на: комментарий от gag

Ну вот да. Я что-то, может быть не совсем еще понимаю. Вот в Debian Squeeze есть пакет linux-image-2.6-* и есть пакеты для конкретного ядра linux-image-2.6.32-5. А тут 3.2.0 обозначен, а ставит ядро 3.2.23. И удивительно, что пишет при этом в uname 3.2.0. Я, видимо, что-то не понимаю. Я могу пока только предположить, что так сделано, чтобы пакет с ядром обновлялся автоматически, поэтому его название с 3.2.0 не меняют. Больше идей нет.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

что-то не понимаю

+1

А есть где-нибудь об этом упоминания на сайте дебиана/где-нибудь еще? О том, что пишется не реальная версия ядра, а какая-то левая.

Samu ()
Ответ на: комментарий от Zubok

 Я могу пока только предположить, что так сделано, чтобы пакет с ядром обновлялся автоматически, поэтому его название с 3.2.0 не меняют.

Очевидно.

 И удивительно, что пишет при этом в uname 3.2.0.

Ну чтобы всякие заинтересованные сущности были в курсе, что ABI не изменился, скорее всего.

Homura_Akemi ()
Ответ на: комментарий от Samu

А есть где-нибудь об этом упоминания на сайте дебиана/где-нибудь еще? О том, что пишется не реальная версия ядра, а какая-то левая.

Ищу, но пока не могу найти. Нашел, что в Ubuntu такая же система. Насколько я понимаю, теперь принята собственная нумерация ядер. Но точно я еще не нашел об этом ничего. То есть оно всегда будет теперь ядром 3.2.0 и номер ревизии -1, -2, -3,... а реально может оказаться ядро 3.2.23, но uname об этом не скажет, так как показывает версию в системе Debian. Вот, например, нашел какую-то ссылочку про Ubuntu - соотсветствие Ubuntu Kernel Version и Mainline.

http://kernel.ubuntu.com/~kernel-ppa/info/kernel-version-map.html

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Нашел, что в Ubuntu такая же система.

Там меняется имя пакета при смене версии.

homura@gw:~> aptitude search ~ilinux-image
i   linux-image-3.2.0-32-generic-pa - Linux kernel image for version 3.2.0 on 32
i   linux-image-generic-pae         - Generic Linux kernel image

Homura_Akemi ()
Ответ на: комментарий от Homura_Akemi

Там меняется имя пакета при смене версии.

Не, меняется -32, -33, но при обновлениях учитывается только linux-image-3.2.0. В том-то и дело. И этот номер никак не соответсвует версии ядра из апстрима.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

 но при обновлениях учитывается только linux-image-3.2.0

Он всегда зависит от последней версии :)

 И этот номер никак не соответсвует версии ядра из апстрима.

Обычно да, но так ли это важно? %) Апстримная версия отражается в чейнджлоге же.

Homura_Akemi ()
Ответ на: комментарий от Homura_Akemi

Он всегда зависит от последней версии :)

Да, он будет увеличиваться но по какой-то своей системе. Не знаю точно как именно.

Обычно да, но так ли это важно? %)

Ну, если только скрипты какие-то что-то делают в зависимости от uname, а именно от конкретной апстримной версии ядра. Не думаю, что таких много, однако. Может, их и нет вообще.

Апстримная версия отражается в чейнджлоге же.

Только один момент. Я могу захотеть собрать свои ядра 3.2.x из sid или установить из бэкпортов. Если я соберу со спеками в исходниках Debian, то у меня соберется ядро 3.2.0-(какой-то больший номер). Мне, например, не хотелось бы, чтобы ядро из бэкпортов или testing/sid заменило ядро из stable. А если они будут иметь одинаковое название и если номер ревизии в backports больше, то заменит. Мне хотелось бы, чтобы рядом поставились, а потом я старое ядро удалю, если с новой все ок. С другой стороны, раньше при обновлениях оставались старые ядра, о которых пользователь даже и не знал, они мертвым грузом валялись. Теперь не будут, что в принципе хорошо, а то очень много у пользователей вопросов было, что с этим делать.

Zubok ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.