LINUX.ORG.RU

Ядро 2.6 - проблема с установкой


0

0

Собрал ядро 2.6.1
собирал так
make menuconfig
там добавил подключение драйвера для TV тюнера
make all
make install_modules
make install

для верности сделал еще /sbin/lilo
перезагрузился.
Если выбрать ядро 2.6.1, то появляется черный экран и все.

где грабли?

ядро 2.4.22 грузится нормально.

anonymous

Ответ на: Re: Ядро 2.6 - проблема с установкой от no-dashi

Re: Re: Ядро 2.6 - проблема с установкой

а почему поддержка консоли выключена?

какую доку по сборке/установке ядра посоветуете?

anonymous ()
Ответ на: Re: Re: Re: Ядро 2.6 - проблема с установкой от no-dashi

Re: Re: Re: Re: Ядро 2.6 - проблема с установкой

CONFIG_VT включено...

виснет так: после выбора ядра, появляется прогресс-бар. Он заполняется за 2-3 секунды. По его заполнению при старом ядре происходит переход в графический режим загрузки (там уже свой прогресс-бар).
Так вот первый прогресс-бар при ядре 2.6.1 заполняется, экран мигает, включается и остается черным, но монитор не выключается.

диск не шуршит.

anonymous ()
Ответ на: Re: Re: Re: Re: Ядро 2.6 - проблема с установкой от anonymous

Re: Re: Re: Re: Re: Ядро 2.6 - проблема с установкой

Понятно. Виснет твое ядро. Отключай нах поддержку фреймбуфера, глючит скорее всего именно это дело. Ты случаем jackill'овские или mcmcc-шные патчи не применял, для поддержки фирменных nvidia'шных драйверов?

no-dashi ★★★★★ ()

Re: Re: Re: Re: Re: Re: Re: Ядро 2.6 - проблема с установкой

не выходит каменный цветок... епть...

где точно находится этот фреймБуфер, который отключить нужно? а то я уже изкувыркался, да руки видать сильно корявые...

может мануал есть какой подробный, по 2.6 ядрышку?

anonymous ()

Re: Ядро 2.6 - проблема с установкой

если пользуешь лило, то в /etc/lilo.conf найди строку vga=xxx, где xxx какие - нидь циферки, и убери отттуда нах..это первый способ..второй - залазь в конфиг ядра и ищи в драйверах кажись поддержку framebuffer'a и уберай ее нах..:-)

dgeliko ★★ ()

Re: Re: Re: Re: Re: Re: Re: Re: Ядро 2.6 - проблема с установкой

http://www.surw.ru/~dalth/linux/config.gz - в принципе вполне рабочий конфиг для ядер 2.6. Только проверь поддержку своего специфического железа, типа IDE-контроллера.

no-dashi ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.