LINUX.ORG.RU

Не ставится RedHat9, проблема с aic7xxx?


0

0

Вобщем, решил приобщиться я к прекрасному и взял в ларьке эту шапку (три сидюка, вроде так и надо?). Тачка у меня - сервер 440GX, один ксеончик, все биосы пропатчены, под виндой жил припеваючи. Сказёвый контроллер на мамке AIC7896. Стоял, правда, ещё RAID - адаптековский ARO, но я его вынул от греха подальше, ибо дровишек к нему не сыщешь, как я понял. Винтов - три. Что там после рэйда на них осталось - смотреть в лом да и надо ли? Первый винт форматнул под досом чисто для проверки загрузки - всё пучком. Ну так вот, засунул я этот линукс в сидивод (IDEшный, кстати), загрузился, там энтер - ну он попёр ставиться значит. И тут же окошечко вылезло - гружу, дескать aic7xxx. И так это окошечко висело, висело, минут десять а то и больше, а потом - хрен тебе, говорит, - нету у тебя винтов и всё такое... Ат ты, зараза, думаю. Ладно, полез на редхат, нашёл там вот эту пагу: http://www.redhat.com/support/resources/tips/adaptec.html Линки там все дохлые кроме баг намбера, а вся тамошняя инструкция для тех, кто уже completed свою инсталляцию. Слазил я на адаптек, качнул драйвера что там были (для седьмого и восьмого) и пробовал их подсунуть на дискете. Не хавает оно их, а просит выбрать вручную. Выбираю aic7xxx, грузится вроде махом, но результат тот же - винтов не видит. Вычитал в доке волшебный ключик apic, что специально для 440GX должен помочь - без толку. Вобщем, пока я только в контрол-альт-ф2 приторчал. Исполнил, кстати, инструкцию, что с редхатовской паги, правда, только до mkinitrd. Кайф, конечно, но хочется большего. Помогите пожалуйста, не дайте умереть чайником.

anonymous

Re: Не ставится RedHat9, проблема с aic7xxx?

Есть у нас такая машинка. Проблема там в кривом APIC (вроде по слухам можно вылечить апдейтом биоса, но это та еще процедура).

Достоверно известно что UP кернела отлично работают. Таким образом сдеалй шапошный бутдиск, выкини из него кернел, собери руками кернел без SMP, воткни на бутдиск и грузись с этого бутдиска. И будет тебе счастье.

green ★★★★★ ()

Не ставится RedHat9, проблема с aic7xxx?

чё-то тут не так. Разве бутовое ядро с поддержкой SMP сделано? Вобщем, вот до чего я дошёл: скачал последнее бутовое ядро (2.4.20-18.9BOOT), взял оттуда vmlinuz и заменил им тот, что на бутдиске. Загрузился, потом взял оттуда же scsi_mod.o, aic7xxx.o и сделал insmod. Всё ништяк. Такая же процедура со старым ядром не канает - aic7xxx (и aic7xxx_old) при загрузке начинает мутить, как обычно. В /dev однако нет ничего нового покуда я не схожу в контрол-альт-ф1 и не продолжу инсталляцию. Но там возникает ошибка чтения с /dev/sda. Смотрю в /dev - там появились sda, sda1...sda14, sdb, sdb1...sdb14, sdc, sdc1...sdc14 (то есть я так понял sda, sdb и sdc - это три моих харда). Следующее, что я сделал - взял диск с драйверами (из drvblock.img) и заменил на нём modules.cgz. В свою cgzшку я засунул эти самые scsi_mod.o и aic7xxx.o. Проверил - распаковывается нормально. Гружусь с дискеты, пробую подсунуть эти драйвера - хрен тебе, говорит, обломись. Что не так? И вообще если бутовое ядро каким то чудом забутится дальше то что? На дистрибутив же ещё надо будет засунуть новое ядро. Растолкуйте пожалуйста ибо слаб я ещё...

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.