LINUX.ORG.RU

Нужна помощь с GRUB


0

0

Всем привет. Проблема такая - ставлю дебиан последний, всё проходит норм, никаких ошибок, инсталлером ставится граб, но после установки систему загрузить не может.

у меня 2 харда, первый (hd0) c виндой, второй (hd1) под линукс. пробовал ставить граб в MBR, в первый раздел, пробовал ставить его в раздел /boot, та же хрень

на stage 2 ошибка 17 - загрузчик не распознаёт файловую систему. никакую, даже ext2 в разделе boot он типа не распознаёт оО

читал доки по грабу, пытался вручную загрузить , не получилось.

Есть предположения ?

PS - мандрива вставала и работала на этом харде без запинок, с грабом.

anonymous

Re: Нужна помощь с GRUB

Где:
1) fdisk -l
2) конфиг граба.

Deleted ()
Ответ на: Re: Нужна помощь с GRUB от Deleted

Re: Нужна помощь с GRUB

fdisk -l не знаю как сделать и где где конфиг граба понятия не имею.

Вот маленькая зацепка - может пригодится когда в консоли граба пытаюсь посмотреть разделы, он на всех разделах (на всех которые видит, тоесть на 3х из 4) после unknown file system пишет партишн тайп 0х7.

anonymous ()
Ответ на: Re: Нужна помощь с GRUB от anonymous

Re: Нужна помощь с GRUB

Разделы небось только переформатировали под EXT3 или что у вас там, через cfdisk тип партиций не задавали?

marsijanin ★★ ()

Re: Нужна помощь с GRUB

Загрузись с LiveCD покажи таки вывод fdisk -l и конфигурацию GRUB-а.. С помощью него же можно и ситуацию поправить..

MiracleMan ★★★★★ ()
Ответ на: Re: Нужна помощь с GRUB от MiracleMan

Re: Нужна помощь с GRUB

Всё оказалось гениально и просто. и банально. 2 дня мучился но решил : ) подсказку нашёл случайно на каком то пендосском форуме... В общем всё было так на hd0 у меня стоит винда на hd1 линукс при установке линукса я ставил загрузчик в hd1,0 всё правильно но вот в чем фишка. дабы линукс не имел ничего общего с виндой , я загружаюсь со второго харда через биос. тоесть когда идёт POST банально нажимаю f12 и выбираю грузиться со второго физ. харда. так вот граб при таком раскладе считал что hd1 это ни что иное как первый хард, он же hd0. поставил root (hd0,0) и понеслось. Надеюсь это решение комунибудь ещё пригодится. Всем спасибо.

anonymous ()
Ответ на: Re: Нужна помощь с GRUB от anonymous

Re: Нужна помощь с GRUB

Вот текст с того форума.

The problem is Ubuntu's file menu.lst for grub is wrong.

My HDD configuration is : - Master HDD contains Windows Installation, - Slave HDD contains Ubuntu installation, - Grub is installed in Slave HDD boot sector, - My computer boots on Slave HDD.

Ubuntu installer generates these grub commands : [i]root(hd1,0) Filesystem type unknown, partition type 0x7 kernel /wmlinuz-2.6.12-9-386 root = /dev/mapper/Ubuntu-root ro quiet splash error 17 : cannot mount selected partition.

I modify theses commands : root(hd0,0) Filesystem type unknown, partition type 0x7 kernel /wmlinuz-2.6.12-9-386 root = /dev/mapper/Ubuntu-root ro quiet splash

It seems that for grub my slave HDD is referenced as hd0 because my computer boots on it.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.