LINUX.ORG.RU

Запарился.. Помогите!!.. lilo+initrd error


0

0

Достало.. Не знаю что делать, подскажите, очень надо: RedHat 7.2 текущее ядро 2.4.7-10 - дефолт с установки, ext3 Собираю ядро 2.4.18: make dep make bzImage make modules make modules_install Получил /lib/modules/2.4.18mykernel/ Далее все как учили: пишу system.map bzImage в /boot переименовываю их и т.д и т.п создаю mkinitrd ля ля ля .. всё есть Что нам осталось? исправить lilo.conf.. пожалуста.. правлю.. все.. остаёться набрать эту грёбаную комманду lilo.. Тут вылетает: Added.. Added.. (то что было раньше) Моё ядро - Fatal: Kernel doesn't supportinitial RAM disks.

Пилять.. З.Ы. Опция поддержки RAM, initrd включена в ядре. З.Ы.Ы. Пробовал не руками писать в бут а при помощи make install - та же фигня. З.Ы.Ы.Ы. Где то в тритысячеэнном факе прочитал что нужна поддержка SCSI - (хотя ИМХО она тут никаким боком) - включил - ИМХО сработало правильно :)

Помогите!! Что за невезуха?? :((( Может трабл в том что я поставил ext3? вместо обычного мне ext2? Всё больше моя ничего не понимает... жду Вашей помощи...

anonymous

Запарился.. Помогите!!.. lilo+initrd error

Ещё.. опция поддержки RAM и initrd была испробована как и в виде модуля (М), так и непосредственным включением в код (*). результат - тот же :((

anonymous ()

Re: Запарился.. Помогите!!.. lilo+initrd error

Ну я тут может ничего дельного не скажу, так на Шлаке работаю - но проблема похоже в lilo.conf-которое неплохо было бы показать. Еще что настораживает - отсутствие make install. Опять же с какого диска ставишь (scsi?), с какого интерфейса(hda, hdc)? Версия lilo?(может быть лучше сразу взять последнюю версию)
Шлаковар

anonymous ()

Re: Запарился.. Помогите!!.. lilo+initrd error

lilo.conf:

prompt timeout="50" default=DOS boot="/dev/hda" map=/boot/map install=/boot/boot.b message=/boot/message lba32

image="/boot/vmlinuz-2.4.7-10" label="linux" initrd="/boot/initrd-2.4.7-10.img" read-only root="/dev/hda7"

other=/dev/hda1 optional label="DOS"

image="/dev/hda1" root="/dev/hda7" initrd="/boot/initrd-2.4.7-10.img"

image="/boot/vmlinuz-2.4.7-18amber" label="amber" read-only root="/dev/hda7"

Ну, насколько я понял, make install требуеться для того, чтобы, поставить ядро не напрягая руки. Я пробовали и при помощи make installa так и при помощи рук.. ничего.. Ставлю с IDE Maxtor MX6L040J2 (UDMA-66 интерфейс - мато больше не тянет). Ставлю с hda7 (он у меня один). Версия лило.. во, попробую, большое спасибо за совет..

anonymous ()

Re: Запарился.. Помогите!!.. lilo+initrd error

> image="/dev/hda1"
>	root="/dev/hda7"
>	initrd="/boot/initrd-2.4.7-10.img"
> image="/boot/vmlinuz-2.4.7-18amber"
>	label="amber"
>	read-only
>	root="/dev/hda7"

Вот этого я не понимаю. Что хотите этим сказать? Не так ли надо?

image="/boot/vmlinuz-2.4.7-18amber"
	label="amber"
	initrd="/boot/initrd-2.4.7-18amber.img"
	read-only
	root="/dev/hda7"

initrd-2.4.7-10.img собрать самому. Там должна быть поддержка ext3.

Obidos ★★★★★ ()

Re: Запарился.. Помогите!!.. lilo+initrd error

А тебя вот эта надпись не смущает?

image="/dev/hda1" root="/dev/hda7" initrd="/boot/initrd-2.4.7-10.img"

Вроде как-то не принято ядро в /dev класть и обзывать его hda1

Шлаковар

anonymous ()

Re: Запарился.. Помогите!!.. lilo+initrd error

Не.. в смысле я привел все свои разделы, конкретно мой:
image="/boot/vmlinuz-2.4.7-18amber"
label="amber"
read-only
root="/dev/hda7"

anonymous ()

Re: Запарился.. Помогите!!.. lilo+initrd error

Не.. в смысле я привел все свои разделы, конкретно мой:
image="/boot/vmlinuz-2.4.7-18amber"
label="amber"
read-only
root="/dev/hda7"

anonymous ()

Re: Запарился.. Помогите!!.. lilo+initrd error

Все, разобрался.. Почему то lilo.conf yе хотел принимать ядро мое, если оно находилось в конфиге последним.. Когда поставил первым - захотело.

anonymous ()

Re: Запарился.. Помогите!!.. lilo+initrd error

Все, разобрался.. Почему то lilo.conf yе хотел принимать ядро мое, если оно находилось в конфиге последним.. Когда поставил первым - захотело.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.