LINUX.ORG.RU
ФорумAdmin

не могу поставить patch-o-matic


0

0

Никак не получается :(
Хочу поставить модуль connlimit на ядро 2.4.18-3 с iptables 1.2.5 от RedHat7.3
беру patch-o-matic 20031219
Далее делаю
make dep в каталоге ядра
потом ./runme base в каталоге патча.
Патч connlimit вроде нормально приделывается. (я его одного приделывать даже пытался)
Потом make menuconfig, выбираю все что надо
Далее делаю опять make dep
потом make bzImage и make modules
А когда делаю make modules_install, то доходит до компоновки System.map и
после пишет:
depmod: *** Unresolved symbols in /lib/modules/2.4.18-3custom/kernel/net/ipv4/netfilter/ipt_connlimit.o
depmod: ip_conntrack_find_get
make: *** [_modinst_post] Error 1
После перегрузки модуль не работает :(
В чем может быть дело?

anonymous

Ответ на: Re: не могу поставить patch-o-matic от fagot

Re: не могу поставить patch-o-matic

Пробовал еще такие варианты:
2.4.18-3 + pom20020825 - там этот модуль называется iplimit, выдает тоже самое
2.4.29 + pom20031219 - тоже самое
С 2.6 не пробовал, потому что машина, на которую буду ставить - P166 и не хочется Fedora Core ставить, а просто ядро думаю не удастся успешно заменить.

Мне кажется, что я что-то не так делаю, но вот что, понять не могу.

anonymous ()
Ответ на: Re: не могу поставить patch-o-matic от fagot

Re: не могу поставить patch-o-matic

Получилось вроде
Сработало только в такой связке:
ядро 2.4.18-3 + iptables 1.2.5 + patch-o-matic прямо из исходников iptables 1.2.5

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.