LINUX.ORG.RU

ОБНОВЛЕНИЕ rh4as (APAHE до 2.2.2, PHP до 5.1.4, MySQL до 5.0.22, POSTGRESQL до 8.1.4)


0

0

Люди добрые подскажите плиз как и с чего начать обновление? В наличии есть федора пятаяб rpm пакеты postgresql и mysql именно для redhat enterprise server 4 as

Нашол также апачу 2.2.2.1 в rpm , но ставиться поверх старой апачи не хочет, пишет конфликт

предупреждение: httpd-2.2.2-1.i386.rpm: подпись DSA V3: NOKEY, key ID 751d7f27 файл /etc/httpd/conf/httpd.conf из устанавливаемого пакета httpd-2.2.2-1 конфликтует с файлом из пакет= файл /etc/httpd/conf/magic из устанавливаемого пакета httpd-2.2.2-1 конфликтует с файлом из пакет= файл /etc/rc.d/init.d/httpd из устанавливаемого пакета httpd-2.2.2-1 конфликтует с файлом из пакет= и еще пара тысяч строк

anonymous

Re: ОБНОВЛЕНИЕ rh4as (APAHE до 2.2.2, PHP до 5.1.4, MySQL до 5.0.22, POSTGRESQL до 8.1.4)

Возьми в src.rpm и пересобери на конечной системе.

Deleted ()

Re: ОБНОВЛЕНИЕ rh4as (APAHE до 2.2.2, PHP до 5.1.4, MySQL до 5.0.22, POSTGRESQL до 8.1.4)

>предупреждение: httpd-2.2.2-1.i386.rpm: подпись DSA V3: NOKEY, key ID 751d7f27 файл /etc/httpd/conf/httpd.conf из устанавливаемого пакета httpd-2.2.2-1 конфликтует с файлом из пакет= файл /etc/httpd/conf/magic из устанавливаемого пакета httpd-2.2.2-1 конфликтует с файлом из пакет= файл /etc/rc.d/init.d/httpd из устанавливаемого пакета httpd-2.2.2-1 конфликтует с файлом из пакет= и еще пара тысяч строк

и неплохо еще раз прочитать man rpm

anonymous ()

Re: ОБНОВЛЕНИЕ rh4as (APAHE до 2.2.2, PHP до 5.1.4, MySQL до 5.0.22, POSTGRESQL до 8.1.4)

rpm -Uvh имя_пакета-xxx.rpm. Вы, наверное, через -i пытаетесь поставить?

Не факт, что юинарные пакеты из FC5 вообще заработают в RHAS - у последнего, по-моему, достаточно старая glibc.

Вообще rpmbuild --rebuild httpd-2.2.2-1.src.rpm

birdie ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.