LINUX.ORG.RU

Проблема при установке пакетов для Vpn, Pptp config & зависимости


0

0

Добрый день! Данная проблема, которую я описываю ниже надо сказать появлялась на ВСЕХ тестировавшихся мною дистрибутивах линукс (Red Hat 7, Fedora Core 4-5-6-7, Ubuntu, Mandriva 2007). Сейчас сижу на Fedora Core 7 - так что описываю все по ней.

Итак, для настройки VPN как известно требуется установка pptpconfig. Скачал следующие пакеты с официальных источников:[list] [*]php4-pcntl-4.4.1-2.fc6.i386 [*]php4-pcntl-devel-4.4.1-2.fc6.i386 [*]php4-pcntl-gtk-1.0.2-2.fc6.i386 [*]pptp-1.7.1-3.i386 [*]pptpconfig-20060821-1.fc7.noarch [*]pptp-release-4-1.devel.noarch [/list]Устанавливается все кроме пакета [b]php4-pcntl-4.4.1-2.fc6.i386.rpm[/b], от которого зависит возможность установки самого [b]pptpconfig-20060821-1.fc7.noarch[/b]

Далее лог: [code][XXX]$ rpm -ihv * предупреждение: php4-pcntl-4.4.1-2.fc6.i386.rpm: Заголовок V3 DSA signature: NOKEY, key ID 862acc42 ошибка: Неудовлетворенные зависимости: libglade.so.0 нужен для php4-pcntl-gtk-1.0.2-2.fc6.i386 libxml.so.1 нужен для php4-pcntl-gtk-1.0.2-2.fc6.i386 [/code]

Соответственно пытаюсь удовлетворить зависимости из /Fedora/RPMS/ Нахожу данные пакеты: libglade2-2.6.0-3.fc7 и libxml2-2.6.28-2 Пытаюсь установить - пишет, точ данные пакеты уже установлены! Проверяю: [code] [ХХХ]$ rpm -q libglade2 libglade2-2.6.0-3.fc7 [ХХХ]$ rpm -q libxml2 libxml2-2.6.28-2[/code] И правда установлены :D

[b]Возникает вопрос: почему выдаются данные неудовлетворенные зависимости?[/b]

Как бы не ясно, что именно требуется и что в этом случа означает [code] libglade.so.0 нужен для php4-pcntl-gtk-1.0.2-2.fc6.i386 libxml.so.1 нужен для php4-pcntl-gtk-1.0.2-2.fc6.i386 [/code]

Такая же ситуация наблюдается и в других дистрибутивах. Замечу, что везде не вышло установить пакет php4-pcntl-gtk именно из-за проблемы описанной выше. Пересмотрел множество форумов - нигде вразумительного ответа не нашел. В основном рассматриваются проблемы с самим VPN (но мне это еще предстоит).

Спасибо за внимание!

anonymous

Re: Проблема при установке пакетов для Vpn, Pptp config & зависимости

Ihmo дело в том, что у тебя установлены libxml2 и libglade2, а этому пакету нужны libxml и libglade. Т.е. этой либе нужны древние пакеты, которых уже может и не быть в репозитариях.

Afaik в седьмой федоре наиболее идеологически-верным методом настройки PPTP является NetworkManager и его GUI для kde и gnome.

YesSSS ★★★ ()

Re: Проблема при установке пакетов для Vpn, Pptp config & зависимости

>NetworkManager и его GUI для kde и gnome

Вот об этом подробнее - поставлюяется ли вместе с истрибутивом или где можно взять?

anonymous ()

Re: Проблема при установке пакетов для Vpn, Pptp config & зависимости

> This release provides a number of firmware packages for enhanced wireless networking. NetworkManager presents a graphical interface that allows user to quickly switch between wireless and wired networks for increased mobility. NetworkManager is installed by default in both GNOME and KDE Live CDs.

В репах есть, на дисках imho тоже должен быть. Смотри пакеты NetworkManager, NetworkManager-gnome, NetworkManager-openvpn, NetworkManager-vpnc, knetworkmanaget, knetworkmanaget-pptp, knetworkmanaget-vpnc, knetworkmanaget-openvpn.

P.S. У меня не vpn, про него ни чего не знаю.

YesSSS ★★★ ()

Re: Проблема при установке пакетов для Vpn, Pptp config & зависимости

Народ, кто знает про ВПН? Естесственно все эти пакеты испробовал как под гномом так и под КДЕ. Похоже на настройке ВПН, но западного образца. А мне нужно чтобы просто указать адрес впн-сервера, логин-пароль, отключить шифрование. А NetworkManager просит специальный CA файл, что-то вроде уникального ключа, который доожен формироваться провейдером. Имхо, у нас не так, мы не "за бугром".

anonymous ()

Re: Проблема при установке пакетов для Vpn, Pptp config & зависимости

А почему не используется yum?

annoynimous ★★★★★ ()

Re: Проблема при установке пакетов для Vpn, Pptp config & зависимости

для yum нужен интернет, который и пытаюсь я настроить! Подключать диск как репозитарий не имеет смысла - там нет нужных пакетов.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.