LINUX.ORG.RU

Установка ядра 2.6.14.2 поверх старого...


0

0

Здраствуйте,не могу установить ядро 2.6.14.2 поверх старого 2.6.8-2.

вот мой отрывок из menu.lst (grub) новый(неработающий) ///////////////////// title Debian GNU/Linux, kernel 2.6.14.2 root (hd0,1) kernel /boot/vmlinuz-2.6.14.2 root=/dev/hdb2 ro savedefault boot ///////////////////// старый(работающий) ///////////////////// title Debian GNU/Linux, kernel 2.6.8-2-386 root (hd0,1) kernel /boot/vmlinuz-2.6.8-2-386 root=/dev/hdb2 ro initrd /boot/initrd.img-2.6.8-2-386 savedefault boot /////////////////////

возможно это из-за строчки inird хотя там где я читал про установку ядра такого и не было

Спасибо.

Re: Установка ядра 2.6.14.2 поверх старого...

Извиняюсь за неправильный 1 пост.Ещё раз:

Здраствуйте,не могу установить ядро 2.6.14.2 поверх старого 2.6.8-2.Всё делал по сайту(неофициальному).

вот мой отрывок из menu.lst (grub)

новый(неработающий)

/////////////////////

title Debian GNU/Linux, kernel 2.6.14.2

root (hd0,1)

kernel /boot/vmlinuz-2.6.14.2 root=/dev/hdb2 ro

savedefault

boot

/////////////////////

старый(работающий)

/////////////////////

title Debian GNU/Linux, kernel 2.6.8-2-386

root (hd0,1)

kernel /boot/vmlinuz-2.6.8-2-386 root=/dev/hdb2 ro

initrd /boot/initrd.img-2.6.8-2-386

savedefault

boot

/////////////////////

возможно это из-за строчки inird хотя на сайте где я читал про установку ядра, такого и не было

на что linux ругается:

VFS:Cannot open root device "hdb2" or unknown-block (0,0)

Please append a correct "root=" boot option

Kernel panic - not syncing:VFS:Unable to mount root fs on unknown-block(0,0)

В чём ошибка? Спасибо.

AleXXandEr ()
Ответ на: Re: Установка ядра 2.6.14.2 поверх старого... от AleXXandEr

Re: Установка ядра 2.6.14.2 поверх старого...

Да, проблема именно в initrd, похоже, что драйвер корневой ФС скомпилирован в виде модуля. Почитайте про mkinitd либо пересоберите ядро с build-in поддержкой корневой ФС.

phoenix ★★★★ ()
Ответ на: Re: Установка ядра 2.6.14.2 поверх старого... от phoenix

Re: Установка ядра 2.6.14.2 поверх старого...

так...я всё испортил(не работает клава на usb) :((

Но ещё у мя осталось ядро 2.4.Х.Х(не помню точно т.к. щас в винде)слаборабочее :)

Я сделал mkinitrd -k -o initrd-2.6.14.2.img , почитал в tmp его логи, он там пишет что использует модули ядра 2.6.8-2, Как ему сказать чтобы он использовал модули от 2.6.14.2?

Если е от этого зависит то вот что он грит при загрузке

/////////////////////////////////

modprobe:FATAL:Could not load /lib/modules/2.6.14.2DebianGNU/Linux/modules.dep : no such file or directory

(хотя я посмотрел...там это есть)

mount : unknown filesystem type 'devfs'

//////////////////////////////////////

HELP!!!а то без линукса жизнь... :)

AleXXandEr ()

Re: Установка ядра 2.6.14.2 поверх старого...

Ничё не понял...

Зачем как модуль делать, ведь лучше когда она подключена не модулем (вроде бы включал(ext3,ext2,fat,ntfs,etc)...не подскажите ли как называется)

А зачем lilo ведь grub тож хороший

AleXXandEr ()
Ответ на: Re: Установка ядра 2.6.14.2 поверх старого... от AleXXandEr

Re: Установка ядра 2.6.14.2 поверх старого...

вообще, не понял, что за модули, но корень должен быть buil-in, иначе просто не загрузится.

а с lilo я бы мог помочь, и ядра добавлять там - 4 строчки добавить в конфиг. да и вообще, легче lilo.

тема должна была называться "помогите добавить запись о новом ядре в grub".

kornerr ()

Re: Установка ядра 2.6.14.2 поверх старого...

С GRUB'ом всё нормально... Скоро пересоберу(какие надо включать для определяния корневой ФС)

AleXXandEr ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.