LINUX.ORG.RU

Проблемы с видеокартой на Asus N550JK

 , , ,


0

1

Добрый день!

Купил ноутбук Asus N550JK. Купил специально чтобы иметь систему Linux. После установки последней на сегодняшний день версии Linux Mint 17.1 Rebecca возникли проблемы с изображением: экран мерцает, гаснет, потом включается, потом снова гаснет. Впечатление что плохой контакт или замыкание. Можно увидеть здесь: https://yadi.sk/i/OHkoR8f2gQZbN Проблемы появились сразу в процессе установки, когда загрузился с live usb, экран мерцал уже тогда.

Пробовал запускать Ubuntu и xUbuntu с флэшки. Та же самая проблема. Экран мерцает.

Чтобы убедиться что железо исправно, установил Windows 7 со всеми драйверами. Все нормально работает, экран не мерцает.

На ноутбуке установлены 2 видеокарты: Nvidia GeForce GTX 850M (4 ГБ DDR3) Intel HD Graphics 4600 Наверное в этом проблема.

Я пробовал устанавливать проприетарный драйвер с сайта nvidia, устанавливал bumblebee, пробовал крутить xorg.cnfg. Думал что это проблема с частотой обновления экрана. Оказалось что проблема глубже: на уровне драйверов.

Кто знает, в чем может быть проблема? Может нужно установить драйвера другие? Помогите пожалуйста! Очень хочется Linux!


Психодел какой-то.

У меня такой же ноут, запускал на нём Mint, сейчас Gentoo работает - ничего подобного не было.

Попробуй обновить BIOS для начала. Плюс можно добавить acpi_osi= (пусто) к параметрам ядра. Ну и логи смотри, конечно же, неужели там ничего нет?

Более того, ты используешь CSM, или в нормальном UEFI-окружении загружаешься?

tiandrey ★★★★★ ()

чтобы иметь систему Linux

а получилось наоборот

Экран мерцает

попробуй в GRUB_CMDLINE_LINUX добавить это

enable_rc6=1 enable_fbc=1 lvds_downclock=1 rcutree.rcu_idle_gp_delay=1 acpi_osi="!Windows 2012"'
Еще можно добавить это
i915.modeset=1 i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 pcie_aspm=force acpi_pme=native
но у меня итак норм работает

fang90 ★★★★★ ()
Последнее исправление: fang90 (всего исправлений: 1)
Ответ на: комментарий от tiandrey

Плюс можно добавить acpi_osi=(пусто) к параметрам ядра

А как это можно сделать? Если загружаешься с live usb?

Более того, ты используешь CSM, или в нормальном UEFI-окружении загружаешься?

Не понял что такое CSM и UEFI-окружение. Я вставляю загрузочную флэшку и загружается linux для установки. В этом режиме уже наблюдаются проблемы с видеокартой.

Дело в том что это мой первый linux на железе, до этого я пользовался виртуалками. Поэтому еще плохо разбираюсь в тонкостях.

Ну и логи смотри, конечно же, неужели там ничего нет?

Подскажите пожалуйста где смотреть?

silart ()
Ответ на: комментарий от fang90

Пробовал ваши исправления. Файл /etc/default/grub у меня такой. Но это не решило проблему. Моргания продолжаются. Может я не тот файл правил?

# If you change this file, run 'update-grub' afterwards to update # /boot/grub/grub.cfg. # For full documentation of the options in this file, see: # info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0 GRUB_HIDDEN_TIMEOUT=0 GRUB_HIDDEN_TIMEOUT_QUIET=true GRUB_TIMEOUT=10 GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian` GRUB_CMDLINE_LINUX_DEFAULT=«quiet splash» GRUB_CMDLINE_LINUX=«i915.modeset=1 i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 pcie_aspm=force acpi_pme=native»

# Uncomment to enable BadRAM filtering, modify to suit your needs # This works with Linux (no patch required) and with any kernel that obtains # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...) #GRUB_BADRAM=«0x01234567,0xfefefefe,0x89abcdef,0xefefefef»

# Uncomment to disable graphical terminal (grub-pc only) #GRUB_TERMINAL=console

# The resolution used on graphical terminal # note that you can use only modes which your graphic card supports via VBE # you can see them in real GRUB with the command `vbeinfo' #GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass «root=UUID=xxx» parameter to Linux #GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries #GRUB_DISABLE_RECOVERY=«true»

# Uncomment to get a beep at grub start #GRUB_INIT_TUNE=«480 440 1»

silart ()
Ответ на: комментарий от fang90

Пробовал варианты что вы сказали и acpi_osi=. Никак не повлияло.

silart ()
Ответ на: комментарий от silart

После исправления /etc/default/grub нужно запустить update-grub2, чтобы сгенерировался новый конфиг.

tiandrey ★★★★★ ()
Ответ на: комментарий от silart

А как это можно сделать? Если загружаешься с live usb?

Нажимать shift с начала загрузки до появления меню grub. На первой строчке нажать 'e', найти строчку которая начинается, примерно, так

linux /kernel-...
В конец этой строки добавить необходимые параметры.

fang90 ★★★★★ ()

Купил ноутбук Asus N550JK.

Кто ж тебе доктор?

Купил специально чтобы иметь систему Linux.

1. Интересно, а как ты ее иметь будешь?

2. А зачем тебе иметь линукс?

3. Полно продается ноутбуков уже с линуксом, которые проще иметь, наверное.

экран мерцает, гаснет, потом включается, потом снова гаснет

Теперь тебя будут иметь по гарантии, ибо специально купленный ноутбук оказался бракованным.

anonymous ()
Ответ на: комментарий от fang90

Не помогло исправления GRUB_CMDLINE_LINUX. Эффект мигания сохраняется. В первой строчке груб ругался на 2012, я оставил acpi_osi="!Windows". Может логи посмотрим? Подскажите где их посмотреть?

silart ()
Ответ на: комментарий от silart

1. Вывод dmesg > файл > pastebin.com

2. /var/log/Xorg.0.log > pastebin.com

Еще можно попробовать добавить в blacklist драйвер nvidia и nouveau, если он есть.

$ sudo -i
# echo "nvidia-current" > /etc/modprobe.d/blacklist-nvidia.conf
# echo "nouveau" >> /etc/modprobe.d/blacklist-nvidia.conf
Где nvidia-current - версия установленных дров nvidia. Т.е. может быть «nvidia-390» или просто «nvidia».

fang90 ★★★★★ ()
Последнее исправление: fang90 (всего исправлений: 1)

Чтобы убедиться что железо исправно, установил Windows 7 со всеми драйверами. Все нормально работает, экран не мерцает.

Это же божественная винда, виндушенька.

Помогите пожалуйста! Очень хочется Linux!

А я вот снова накатил винду и лэнэкс уже не хочется. Но ты можешь поставить линакс в виртуалбокс.

RedEyedMan4 ★★★★★ ()
Ответ на: комментарий от RedEyedMan4

А я вот снова накатил винду и лэнэкс уже не хочется

и, что ты тут забыл?

fang90 ★★★★★ ()
Ответ на: комментарий от fang90

То есть надо юзать его, что иметь право писать сюда? Я не обязан его юзать.

RedEyedMan4 ★★★★★ ()
Ответ на: комментарий от RedEyedMan4

То есть надо юзать его, что иметь право писать сюда?

Чем ты пользуешься, никого не волнует. Но, если человек спрашивает как ему настроить минт, то следует рассказать про минт. А не про то, как ты поставил винду. Твой совет покатит в толксах, но не в техническом разделе linux-install.

fang90 ★★★★★ ()
Последнее исправление: fang90 (всего исправлений: 1)
Ответ на: комментарий от fang90

$ sudo -i
# echo «nvidia-current» > /etc/modprobe.d/blacklist-nvidia.conf
# echo «nouveau» >> /etc/modprobe.d/blacklist-nvidia.conf

Не помогло. Экран начинает мерцать даже когда еще нет графики и логи выводятся на экран.

silart ()
Ответ на: комментарий от silart

dmesg показывает, что есть проблема с usb3 и оно трейсит:

usb 3-5: device not accepting address 5, error -71
Тут (http://forums.linuxmint.com/viewtopic.php?f=49&t=185071) народ советует обновится до ядра 3.16.

По части видео, не совсем понятно для чего нужно VGA switcheroo, если с nvida оно не работает. Но и мешать, по-идее, не должно.

VGA switcheroo: detected Optimus DSM method \_SB_.PCI0.PEG0.PEGP handle
Далее
nouveau E[  DEVICE][0000:01:00.0] unknown chipset, 0x117110a2
[    2.923041] nouveau E[     DRM] failed to create 0x80000080, -22
[    2.923322] nouveau: probe of 0000:01:00.0 failed with error -22
есть не нулевая вероятность, что во всей этой ереси виновато nouveau. Попробуй в GRUB_CMDLINE_LINUX добавить
nouveau.blacklist=1
Т.е. должно получится так
GRUB_CMDLINE_LINUX='i915.modeset=1 i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 nouveau.blacklist=1'

fang90 ★★★★★ ()
Последнее исправление: fang90 (всего исправлений: 3)
Ответ на: комментарий от fang90

Сделал все как вы сказали: grub

Потом посмотрел логи:

В файле dmesg.log есть такая строчка:

[ 0.947851] nouveau: unknown parameter 'blacklist' ignored

И все те же:


[ 3.069297] nouveau E[ DEVICE][0000:01:00.0] unknown chipset, 0x117110a2
[ 3.069298] nouveau E[ DRM] failed to create 0x80000080, -22
[ 3.069463] nouveau: probe of 0000:01:00.0 failed with error -22

Что-то не так с блэклистом.

silart ()
Ответ на: комментарий от fang90

1. Добавил в GRUB_CMDLINE_LINUX_DEFAULT строку «nomodeset», как было сказано в ссылке, что вы мне дали.
2. Запустил >> sudo update-initramfs -u

Результаты прилагаю:

  • grub
  • dmesg
  • xorg
  • initramfs

    Параметр blacklist по-прежнему почему-то игнорируется.

silart ()
Ответ на: комментарий от silart

initramfs

некорретно указаны параметры в /etc/modprobe.d/blacklist-nvidia.conf. Должно быть так

blacklist nvidia-current
blacklist nouveau
как изменишь, сделай снова sudo update-initramfs -u

fang90 ★★★★★ ()
Последнее исправление: fang90 (всего исправлений: 1)
Ответ на: комментарий от fang90

Сделал.

  • dmesg.log
  • Xorg.0.log

    Действительно упоминаний про nouveau в логах нет (кроме строки grub). Но проблема сохраняется. Я посмотрел там были упоминая про видеокарту Intel. Может это в ней проблема, а не в nvidia? Может nvidia даже не включается, а Intel при загрузке работает по умолчанию? Может с ней что-то можно сделать?

silart ()
Ответ на: комментарий от silart

Может это в ней проблема, а не в nvidia?

неа, драйвер подгрузился штатно, без ошибок. Во всяком случае, так считает Xorg

Может nvidia даже не включается, а Intel при загрузке работает по умолчанию?

Так и должно быть

Может с ней что-то можно сделать?

Не с ней, но рядом. У тебя многочисленные ошибки распределения памяти.

*BAD*gran_size: 128K     chunk_size: 16M         num_reg: 10     lose cover RAM: -8M
[    0.000000] *BAD*gran_size: 128K     chunk_size: 32M         num_reg: 10     lose cover RAM: -8M
[    0.000000] *BAD*gran_size: 128K     chunk_size: 64M         num_reg: 10     lose cover RAM: -8M
[    0.000000] *BAD*gran_size: 128K     chunk_size: 128M        num_reg: 10     lose cover RAM: -8M
[    0.000000] *BAD*gran_size: 128K     chunk_size: 256M        num_reg: 10     lose cover RAM: -8M
[    0.000000] *BAD*gran_size: 128K     chunk_size: 512M        num_reg: 10     lose cover RAM: -264M
ЕМНИП, mtrr как раз должен выделять память под видео для интеграшки. Т.е. надо:

fang90 ★★★★★ ()
Последнее исправление: fang90 (всего исправлений: 2)
Ответ на: комментарий от fang90

Ничего у меня не получилось! Груб у меня почему-то не выдает меню выбора загрузки. Крутил «GRUB_TIMEOUT» не помогло: сразу идет по экрану мерцающий лог. Параметр «GRUB_HIDDEN_TIMEOUT» уже больше не поддерживается. Как включить memtest в груб я не понял, везде в интернете его зачем-то отключают.

Вставил строку «enable_mtrr_cleanup mtrr_spare_reg_nr=1 mtrr_gran_size=32M mtrr_chunk_size=128M» в GRUB_CMDLINE_LINUX. Да, и в биосе тоже поставил 128Мб под видеокарту (до этого 64Мб стояло). Но это не помогло. Какие цифры поставить и как ими поиграть не понятно. Да еще экран может наглухо погаснуть и долго стоять погашенным, так чтобы что-то поправить нужно очень исхитриться...

Можно ли как-то отключить эту долбанную встроенную видеокарту, а включить nvidia и пользоваться ей всегда? Я вообще не понимаю зачем ставить две видеокарты, потом с ними такие проблемы...

silart ()
Ответ на: комментарий от silart

Груб у меня почему-то не выдает меню выбора загрузки

shift зажми при загрузке

Ford_Focus ★★★★★ ()
Ответ на: комментарий от fang90

memtest86 оказывается можно запустить с загрузочной флэшки. Что я и сделал. Тестирование заняло 7,5 часов, но ошибок найдено не было. Что интересно, во время работы мемтеста экран не моргал.

Не подскажете что можно сделать с параметрами ядра:

enable_mtrr_cleanup mtrr_spare_reg_nr=1 mtrr_gran_size=32M mtrr_chunk_size=128M

silart ()
Ответ на: комментарий от silart

Груб у меня почему-то не выдает меню выбора загрузки

Проблемы с видеокартой на Asus N550JK (комментарий)

зачем ставить две видеокарты

встроенная уменьшает энергопотребление и ноут меньше греется. Кроме того есть проблема с тирингом, о которой nvidia знает, но не фиксит.

Можно ли как-то отключить эту долбанную встроенную видеокарту

Можно http://tuxilero.blogspot.cz/2013/09/how-to-official-nvidia-drivers.html

fang90 ★★★★★ ()
Ответ на: комментарий от silart

во время работы мемтеста экран не моргал

ЕМНИП, он использует стандартный драйвер VESA. А убунта и пр. грузят интеловый i915. Попробуй

enable_mtrr_cleanup mtrr_spare_reg_nr=1 mtrr_gran_size=128M mtrr_chunk_size=128M
и покажи dmesg после этого. А так же вывод команды
cat /proc/mtrr 

fang90 ★★★★★ ()
Последнее исправление: fang90 (всего исправлений: 1)

чтобы иметь систему

in soviet russia...

vvviperrr ★★★★★ ()

уже практически очевидно, что с невидией пока не стоит связываться

Попробовать отключить и оставить только интэл.

anonymous ()
Ответ на: комментарий от silart

симптомы те же? Если да, то скажи на какой секунде после загрузки начинается мерцание.

fang90 ★★★★★ ()
Ответ на: комментарий от fang90

симптомы те же? Если да, то скажи на какой секунде после загрузки начинается мерцание.

Да, ничего не поменялось. Мерцание начинается сразу после появления лога загрузки на экране. Это примерно 10 секунда. То есть экран мерцает всегда, даже во время загрузки. Как только Linux начинает что-то выводить на экран, начинается мерцание. Но это даже не мерцание, а скорее черный экран с проблесками изображения. Бывает что несколько минут висит черный экран, и приходится ждать когда немного просветлеет чтобы стало видно мышку.

silart ()
Ответ на: комментарий от anonymous

Попробовать отключить и оставить только интэл

Тут походу с интел проблемы так как она встроенная и потребляет память системы. Nvidia еще не включалась

silart ()
Ответ на: комментарий от fang90

Решил попробовать отключить интел. Действую по ссылке, которую вы давали здесь.

Первые проблемы возникли при установки драйвера nvidia. Инсталятор ругнулся, что не удалось запустить какой-то скрипт. здесь После копирования файлов вылезло сообщение: здесь

После того как я дошел до 8-го пункта и запустил startx, x11 не запустился, а выдал такое сообщение: здесь

Не знаю что и делать...

Вообще принципиально в чем проблема? В железе, кривых драйверах? Существует ли надежда что в будущем исправят баг? Ведь ноутбук довольно популярный и его продают.

silart ()
Ответ на: комментарий от silart

у тебя не собрался модуль ядра. Драйвер инвидии лучше не ставить через бинарь, есть ppa xorg-edgers, там всегда все самое свежее.

принципиально в чем проблема

судя по dmesg сопутствующие проблемы решены. Почему происходит моргание - не знаю. Точно не железо, точно не драйвер ибо эта проблема воспроизводится не у всех. Можешь попробовать на другом дистре со свежим ядром, может решится.

fang90 ★★★★★ ()
Ответ на: комментарий от fang90

у тебя не собрался модуль ядра. Драйвер инвидии лучше не ставить через бинарь, есть ppa xorg-edgers, там всегда все самое свежее.

Пожалуйста здесь поподрбнее? Я делал строго по инструкции. Как нужно установить драйвер нвидии? Я прошлый раз тоже пробовал его устанавливать, была та же проблема.

silart ()
Ответ на: комментарий от silart

Как нужно установить драйвер нвидии?

0. Убедиться, что нет других установленных дров nvidia. Если ставил из *.run-файла, то

$ sudo sh ./NVIDIA-Linux*.run --uninstall
1. Добавляешь реп
sudo add-apt-repository ppa:xorg-edgers/ppa && sudo apt-get update
2. Затем выполняешь apt-cache search nvidia-graphics, увидишь список версий. Сейчас последняя «352». Т.е. выполняешь
sudo apt-get install nvidia-graphics-drivers-352 
3. sudo reboot

fang90 ★★★★★ ()
Ответ на: комментарий от fang90
  • 1. Все заново переустановил и обновил
  • 2. Добавил репозиторий
  • 3. Сделал sudo apt-get update
  • 4. Когда вызывал apt-cache search nvidia-graphics ничего не происходило. Списка версий не наблюдалось
  • 5. Вызов sudo apt-get install nvidia-graphics-drivers-352 не сработал. Говорит что нет такого пакета
  • Подскажите пожалуйста, что можно еще сделать?
silart ()

Чтобы убедиться что железо исправно, установил Windows 7 со всеми драйверами. Все нормально работает, экран не мерцает.

Это Windows-like железо, отдай мне, а сам купи такой

RedEyedMan4 ★★★★★ ()
Ответ на: комментарий от silart

Это не добавился репозиторий. Команда sudo add-apt-repository ppa:xorg-edgers/ppa и apt-get update нормально отработали?

fang90 ★★★★★ ()
Ответ на: комментарий от fang90

Да, действительно, репозиторий почему-то не добавился. На моргающем экране плохо видно. Вот вывод команды sudo add-apt-repository ppa:xorg-edgers/ppa: здесь

silart ()
Ответ на: комментарий от silart

Так. В mint 17.1(тот же, что указан в начале топика) все работает. Делал так:

$ sudo -i
# add-apt-repository ppa:xorg-edgers/ppa
Вы собираетесь добавить следующий PPA в систему:
....
[тут надо нажать enter]
# apt-get update
# apt-get install nvidia-352

fang90 ★★★★★ ()
Ответ на: комментарий от fang90

Драйвер NVidia установлен. Действительно нужно было нажать enter, а я нажимал Y. Однако команда apt-cache search nvidia-graphics почему-то по-прежнему ничего не выводит. Ну да ладно. Я установил 352 так: apt-get install nvidia-352.

После этого я в папку /etc/X11 положил файл xorg.conf отсюда. Содержимое здесь.

В результате при загрузке просто черный экран. Удалил файл, загрузилось с морганиями.

Читаю дальше мануал. Дошел до 8-го пункта. Там команда

xrandr -d :0 --listproviders

выдает всего один провайдер, с названием Intel. В примере было 2 провайдера: NVidia, Intel.

Отсюда вопрос: что делать дальше? Как заставить работать драйвер NVidia и загасить Intel?

silart ()
Ответ на: комментарий от silart

Как заставить работать драйвер NVidia и загасить Intel?

NVidia работает через Intel, настрой сначала интел.
Сколько памяти выделено под видеобуфер в BIOS (там может быть несколько параметров)? Попробуй опцию ядра nopat. Используй ядро посвежее.

arson ★★★★★ ()
Ответ на: комментарий от arson

Сколько памяти выделено под видеобуфер в BIOS

Да, там есть такой параметр, там кажется 128М, я крутил этот параметр, не помогло. Объясните пожалуйста что дает опция nopat? И как обновить ядро? Сейчас у меня 3.13.0-37-generic

silart ()
Ответ на: комментарий от silart

Да, там есть такой параметр

Сейчас их вроде несколько и один должен быть больше другого, точные названия не помню (они рядом в BIOS)

что дает опция nopat

То что ядро будет использовать mtrr

как обновить ядро

man apt-get, не?! У меня yum/rpm, я не знаю :)

arson ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.