LINUX.ORG.RU

Не получается обновить qtcore

 ,


0

1

Хочет qtchooser и сам же его блокирует.

emerge -avu qtcore

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] dev-qt/qtchooser-0_p20150102::gentoo  USE="-qt5 {-test}" 31 KiB
[ebuild     U ~] dev-qt/qtcore-4.8.6-r1:4::gentoo [4.8.5-r2:4::gentoo] USE="exceptions glib iconv icu qt3support ssl (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 235 961 KiB
[ebuild  N    ~] dev-qt/qttranslations-4.8.6-r1:4::gentoo  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtscript-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions iconv jit (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtgui-4.8.6-r2:4::gentoo [4.8.5-r4:4::gentoo] USE="accessibility cups exceptions glib mng qt3support tiff xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtsql-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions qt3support sqlite (-aqua) -debug -freetds -mysql -oci8 -odbc -pch -postgres (-firebird%)" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qt3support-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks B      ] <dev-qt/qtscript-4.8.6:4 ("<dev-qt/qtscript-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtdbus-4.8.6:4 ("<dev-qt/qtdbus-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qt3support-4.8.6:4 ("<dev-qt/qt3support-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtopengl-4.8.6:4 ("<dev-qt/qtopengl-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtcore-4.8.6:4 ("<dev-qt/qtcore-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtsql-4.8.6:4 ("<dev-qt/qtsql-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtgui-4.8.6:4 ("<dev-qt/qtgui-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
(dev-qt/qtchooser-0_p20150102:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtchooser required by (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtscript-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)

Вчера обновлялся, тоже были подобные конфиликты, решил тупо: emerge --unmerge "dev-qt/qt*" && emerge -av =dev-qt/qtcore-4.8.6-r1.

neversleep ★★ ()
Последнее исправление: neversleep (всего исправлений: 1)
Ответ на: комментарий от Archer73

Пропустил все веселье.

eselect news list

давно делал?

r3lgar ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.