LINUX.ORG.RU

Дистрибутив под asterisk

 ,


0

1

Подскажите, что лучше взять под asterisk, дистрибутив общего назначения или специализированный?

И если общего назначения, то какой, а то у них на сайте пакеты под CentOS только, а во всяких мануалах рекомендуется сборка из исходников (это вообще правильно)?

Я свои астериски только на CentOS гоняю.

во всяких мануалах рекомендуется сборка из исходников (это вообще правильно)?

Я сам asterisk собираю с нужными параметрами в rpm-пакеты и кладу в локальную репу, а пакеты для dahdi беру из репы Digium.

kernelpanic ★★★★★ ()

Подскажите, что лучше взять под asterisk, дистрибутив общего назначения

Тот, который ты(или тот, кто за него отвечать будет) умеешь готовить. Я например умею готовить слаку, вот и приготовил слаку со встроенным астриском(и ко), вычиситив при этом явно не нужны хлам(Х-ы и прочую десктопную часть).

или специализированный?

Не слышал о спец. дистрах для определенного софта, в котором этого софта нету из коробки. AsteriskNOW - CentOS базирующийся, содержит готовый астериск.

И если общего назначения, то какой,

Как уже выше сказано было, тот который умеешь готовить.

а то у них на сайте пакеты под CentOS только, а во всяких мануалах рекомендуется сборка из исходников

Забудь о предоставляемых пакетах под CentOS. Если у тебя этот вопрос встал(т.е. готовый дистр AsteriskNOW ты забраковал), то тебе явно того что у них там есть не хватает, и надо допиливать то естественно без сборки из исходников не обойтись.

(это вообще правильно)?

Правильно. Если хош выжать максимум, придется зарыться по самые уши.

FeyFre ★★★★ ()

Смотря какие цели.

Если планируешь плотно работать, расширять, интегрировать всякое стороннее - лучше общий.

Если нужно решение - поставил, не трогаем (конфигурируем только web интерфейсом), работает. То специализированный.

И если общего назначения, то какой, а то у них на сайте пакеты под CentOS только

Эээ. apt-get install asterisk (debian, ubuntu) отменили уже? Пусть у мейнтейнеров голова болит.

zgen ★★★★★ ()
Последнее исправление: zgen (всего исправлений: 1)
Ответ на: комментарий от zgen

apt-get install asterisk (debian, ubuntu)

В ubuntu пакеты тухловаты, а нормальный ppa я не нашёл, а в debian получается, что из unstable надо ставить.

Тут, правда, подсказали, что всё равно его правильно готовить из исходников.

Lothlorien ★★★ ()
Ответ на: комментарий от Lothlorien

В ubuntu пакеты тухловаты,

Уж поверьте мне, в пакете asterisk нужно чтобы в пакете серьезных багов не было, а не номер версии побольше.

А уж собирать из исходников надо ТОЧНО зная, что тебе нужно и чего в «тухлом пакете» нет. Я собирал, когда libpri были баги, собирал addons к тогда еще новому 1.4 с патчем - мне нужен был uniqueid в mysql-cdr. А еще поимел несколько ночей проблем, когда по собственному идиотизму был конфликт версий (это уже потом выяснилось) самосборных библиотек нужных для работы компонентов. А звонить надо каждый день, скидок никто не сделает.

В конце концов я собираю его часто, потому что часть продакн asterisk-серверов на фре.

Может быть советчики мудрее меня и я смогу у них поучиться?

P.S Ответил только потому, что аватарка твоя нравится.

zgen ★★★★★ ()
Последнее исправление: zgen (всего исправлений: 1)
Ответ на: комментарий от Lothlorien

Тут, правда, подсказали, что всё равно его правильно готовить из исходников.

тогда и дистрибутив собери из исходников епт. LFS в руки и погнал.

exception13 ★★★★★ ()
Ответ на: комментарий от zgen

В конце концов я собираю его часто, потому что часть продакн asterisk-серверов на фре.

О, кстати, поскольку фрю умею готовить лучше всего, там каких-то особенных граблей с asterisk нету?

Я так понял, что могут быть проблемы с вновь выпущенными картами (в частности, E1), из-за старых версий dahdi.

И да, получается, что если не нужны какие-то специальные фичи, то за 11 asterisk'ом можно и не гоняться?

В любом случае, спасибо за разъяснения.

Lothlorien ★★★ ()
Ответ на: комментарий от exception13

тогда и дистрибутив собери из исходников епт. LFS в руки и погнал.

Ну в общем я тоже так подумал.

Lothlorien ★★★ ()
Ответ на: комментарий от Lothlorien

О, кстати, поскольку фрю умею готовить лучше всего, там каких-то особенных граблей с asterisk нету?

Если sip/iax-only то нет. Есть проблемы (dahdi) с некоторыми аналоговыми платами на разных платформах.

Я так понял, что могут быть проблемы с вновь выпущенными картами (в частности, E1), из-за старых версий dahdi.

FreeBSD официально не поддерживается. За наличие драйверов dahdi надо сказать спасибо Max Khon, но они не идеальны в некоторых случаях.

И да, получается, что если не нужны какие-то специальные фичи, то за 11 asterisk'ом можно и не гоняться?

Как и в любом другом ПО. А в таком важном, как телефония - тем более.

zgen ★★★★★ ()
Ответ на: комментарий от zgen

Есть проблемы (dahdi) с некоторыми аналоговыми платами на разных платформах.

А с цифровыми (E1)? Или в этом случае лучше вообще на E1-SIP шлюз смотреть?

Lothlorien ★★★ ()
Ответ на: комментарий от Lothlorien

А с цифровыми (E1)?

Работал с 2/4-портовыми, правда старые - еще pci (могу продать)))
С ними нормально, вообще drivers-related проблем не было, после того как Max Khon выпустил dahdi на фре. За pci-ex не скажу, уже не успел - в цифре мы ушли на digium'овский шлюз e1-sip.

zgen ★★★★★ ()
Последнее исправление: zgen (всего исправлений: 2)
Ответ на: комментарий от zgen

в цифре мы ушли на digium'овский шлюз e1-sip.

А причины такого решения, если не секрет?

Честно говоря, я тоже склоняюсь к отдельному шлюзу, нежели к плате, в основном, потому, что их количество можно наращивать по мере возникновения потребностей.

P.S. Спасибо за ответы.

Lothlorien ★★★ ()
Ответ на: комментарий от Lothlorien

А причины такого решения, если не секрет?

1. Как я уже сказал, платы pci - стало сложно найти серверы, в которые их можно воткнуть.
2. Возможность виртуализовать и безгеморно перебрасывать виртуалку с asterisk на другой хост в случае проблем с хост-машиной.

zgen ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.