LINUX.ORG.RU

После сборки ядра не выключается питание компьютера по команде halt


0

0

Доброго времени суток всем ! Может кто сталкивался с такой проблемой ?

Дистрибутив - Debian 3.1 Sarge, ядро 2.4.27 После ввода в коноли halt (или poweroff), все корректно завершается, файловые ситемы размонтируются, выводится сообщение Power down, но компьютер остается включенным. Перебробовал различные комбинации настроек в пунктах Power Management support и ACPI Support, без особого эффекта, вернее в одних случаях питание после halt'а можно выключить кнопкой но корпусе, в других нет. Пробовал выставить настройки в этих пунктах аналогично настройкам в другом дистрибутиве, установленном на том-же компьютере (ALT Linux 2.3 Master) - в ALT Linux выключается, в Debian с теми-же настройками, нет.

anonymous

Re: После сборки ядра не выключается питание компьютера по команде halt

$ grep "ACPI" /usr/src/linux/.config
# Power management options (ACPI, APM)
# ACPI (Advanced Configuration and Power Interface) Support
CONFIG_ACPI=y
CONFIG_ACPI_BOOT=y
CONFIG_ACPI_INTERPRETER=y
# CONFIG_ACPI_SLEEP is not set
# CONFIG_ACPI_AC is not set
# CONFIG_ACPI_BATTERY is not set
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_VIDEO=y
CONFIG_ACPI_FAN=y
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_IBM is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_BUS=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_PCI=y
CONFIG_ACPI_SYSTEM=y
CONFIG_ACPI_CONTAINER=y
CONFIG_PNPACPI=y
# CONFIG_SERIAL_8250_ACPI is not set

$ uname -r
2.6.12

Много лишнего, но зато ps/2 клавиатура на-горячую подцепляется :)

Deleted ()

Re: После сборки ядра не выключается питание компьютера по команде halt

Dimez, большое спасибо, будет теперь чем на выходных заняться. Правда, я смотрю у тебя ядро 2.6, а я все никак на него перейти не решусь. Теперь вот и стимул дополнительный появится на новое ядро перейти :-)

anonymous ()

Re: После сборки ядра не выключается питание компьютера по команде halt

Такое и у меня было - просто не включаешь первый пункт (вроде называется off by default) - точно не помню

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.