LINUX.ORG.RU

Не могу запустить Xubuntu 12.04 c RAID1 Degraded

 ,


0

1

Здравствуйте. Проблемка возникла.

На системе 4 винта: / - на SSD /home - на новом Seagate (совсем недавно переносил с SSD). И ещё 2 старых винта WD Caviar Blue объединены в программный RAID1. Оба винта имеют бэды (90 и 3). Перекачивал данные на RAID и посматривал за состоянием на RAID, как увидел в статусе рэйда Degraded. Копирование останавливаю. Делаю перезагрузку - чёрный экран, командная строка такого вида «BusyBox ... built-in shell ... (initramfs)» Ещё раз перезагружаю - чёрный экран без признаков жизни. Пробую загрузить recovery mode - сообщает, что с RAID-ом совсем всё плохо. Спрашивает: «Всё равно подключить?» Говорю «нет». Загружается командная строка. Ничего здесь не делаю. Выключаю. Выключаю физически RAID-диски (отключением проводов от них). Загружаю. Появляется командная строка на tty1 с просьбой ввода логина-пароля. Ввожу - заходит, но иксы не запускаются. Говорю startx - запустилась графика.. Снова делаю reboot - автоматом появляется графика, приветствие, ввожу пароль - появляется белый экран с песочными часами на минут 10 - что-то пытается загрузить. И так теперь каждый раз при загрузке.

RAID включаю - опять «BusyBox .. built-in shell .. »

GRUB каждый раз проходит ровно. Мама Asus P867 LE.

Собственно 3 вопроса: 1. Что произошло и как убрать белый экран? 2. Как запустить RAID? 3. И что с ним делать? Как восстановить?

RAID1 до этого был частью системы или всё работало без него?

Если у вас в RAID'е оба диска битые, то как его восстановить? И зачем надо было делать презагрузку при Degraded RAID'е не докопировав данные?

А так, вроде если из того «BusyBox ... built-in shell ... (initramfs)» сделать exit, загрузка должна продолжится. И загрузившись можно пытаться собрать RAID с помощью mdadm.

mky ★★★★★ ()
Ответ на: комментарий от mky

на рэйде не было никаких системных вещей. Однако не проверял, работало без него или нет, физически не выключал.

Да, бэды были, однако дисковая утилита показывала, что здоровы.

Уже что-то вообще не хочет грузить с рэйдом, чёрный экран после GRUB-а длительное время, терпения не хватает - выключаю.

maskaral ()
Ответ на: комментарий от maskaral

Подключил один диск из рэйда - запускаю. Чёрный экран недолго. Далее вываливается в BusyBox - говорю «exit» - проходит нормальная загрузка. После логина белого экрана нет. Данные с пациента читаются нормально.

maskaral ()
Ответ на: комментарий от maskaral

Удалось включить с 2 дисками и пересобрать raid. Всё работает. mky, спасибо за помощь.

maskaral ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.