LINUX.ORG.RU

Lexmark Z645 + Calculate 10.4


0

0

Доброго дня, камрады!
Только похвалил Калькулятор, и тут на тебе, проблема.
Вобщем, имеется сабжевый принтер (печатаю крайне редко). Всегда меня спасали (сначала на сусе, позже на калькулят 9.6) дровишки от Z600, установленные примерно по такой инструкции: http://www.zhvlug.org.ua/index.cgi?m-1202209944/

Теперь сделал то же самое. Сначала не нашёлся фильтр и я пробросил соответствующие симлинки из /usr/lib в /usr/libexec

Теперь имеем следующее:
----------
I [26/Apr/2010:17:25:43 +0300] [Job 13] File of type application/postscript queued by «steplton».
I [26/Apr/2010:17:25:43 +0300] [Job 13] Queued on «Z600-v1.0-1» by «steplton».
I [26/Apr/2010:17:25:43 +0300] [Job 13] Started filter /usr/libexec/cups/filter/pstops (PID 4587)
I [26/Apr/2010:17:25:43 +0300] [Job 13] Started filter /usr/libexec/cups/filter/pstoraster (PID 4588)
I [26/Apr/2010:17:25:43 +0300] [Job 13] Started filter /usr/libexec/cups/filter/rastertoz600 (PID 4589)
I [26/Apr/2010:17:25:43 +0300] [Job 13] Started backend /usr/libexec/cups/backend/usb (PID 4591)
E [26/Apr/2010:17:25:43 +0300] PID 4589 (/usr/libexec/cups/filter/rastertoz600) stopped with status 127!
I [26/Apr/2010:17:25:43 +0300] Hint: Try setting the LogLevel to «debug» to find out more.
E [26/Apr/2010:17:25:43 +0300] PID 4588 (/usr/libexec/cups/filter/pstoraster) stopped with status 1!
---------

Непонятно почему запускается бэкэнд usb, хотя проброшен линк на бэкэнд z600 из состава драйвера (заменить симлинк usb->z600 пробовал, получил failed)
С прошлой версии кардинальные изменения произошли в ядре: вместо обычного 2.6.28 имеем рилтайм, если я всё правильно понимаю:
-----------
Linux calculate 2.6.32.11-calculate #1 SMP PREEMPT Sat Apr 3 06:41:42 Local time zone must be set--s i686 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ AuthenticAMD GNU/Linux
-----------
Заранее благодарен за любые соображения.

★★★★★

Видать, невнятно я изложил свою проблему, раз никто не отвечает...
Или таким гуаном никто не пользуется?

Steplton ★★★★★ ()

Bump же!!!
Помогите слаборазвитым, кто может!

Steplton ★★★★★ ()

Проблема наконец решена.
С помощью
emerge sys-libs/libstdc++-v3 && /etc/init.d/cupsd restart

Steplton ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.