LINUX.ORG.RU

Проблема со звуком ACL 660


0

0

Имеется ноутбук ASUS A6M со встроенным звуком HDA NVIDIA Realtek ACL 660.

Debian Sid, ядро 2.6.30, Alsa 1.0.21.

Поблема следующая:

Весь звук по какой-то причине вместо канала PCM идёт через Headphone. Громкость на данном канале не регулируется. Есть только вкл/выкл. Регулировка громкости на PCM вообще ни на что не влияет. Данная проблема иногда решалась регулировкой громкости на канале Line. В результате это всё вставало на свои места. Но сейчас не помогает. При регулировке громкости в районе 50% появляются сильные щелчки и дребежащий звук.

Ну и ещё проблема. При многоканальном звуке (например, фильм) в наушниках всегда канал от задних колонок, в результате чего ничего не слышно. Да и нет у меня такого обилия колонок, только наушники и встроенные колонки в ноуте.

Помогите починить :)

Проблема со звуком ACL 660

первую проблему решил. в консольном алсамиксере на канале line поставил 48%.

vithak ()
Ответ на: Проблема со звуком ACL 660 от vithak

Проблема со звуком ACL 660

если через модпроб делаешь(во время тестов), то
modprobe snd-hda-intel model=3stack

когда найдешь нужную модель прописываем ее в системе(/etc/modprobe.d/sound)
после
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
пишем
options snd-hda-intel model=3stack

smalcom ()

Проблема со звуком ACL 660

При многоканальном звуке (например, фильм) в наушниках всегда канал от задних колонок, в результате чего ничего не слышно. Да и нет у меня такого обилия колонок, только наушники и встроенные колонки в ноуте.


Фильм с 5.1 звуком. Естественно так смотреть нельзя, даже если бы голос шел на фронтальные колонки, потому что все равно теряешь остальные 3 канала. В плеерах на базе xine-lib есть опция downmixing, которая микширует каналы: 5.1 => 2.0. Или можно через ~/.asoundrc настроить микширование, хотя сейчас модно это делать через пульс, вообще он по умолчанию микширует любое количество каналов до двух. А в новом гноме для этого даже gui сделали.

Для ~/.asoundrc надо гуглить конфиг...

Для пульса - /etc/pulse/daemon.conf:
;default-sample-channels = 2
(по умолчанию закомментировано и равно двум)

Lucky1 ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.