LINUX.ORG.RU

Не работает 802.11ac на Raspberry Pi 4B, Linux 5.8.9 (mainline)

 , , , ,


1

1

Привет.

Как вообще обстоят дела с 802.11ac на последней ежевике? А с драйверами?

Суть проблемы: на википедии и raspberrypi.org написано, что в железе 802.11ac есть, но я не могу подключиться ни к одной из своих 802.11ac точек (Xiaomi R3P @ openwrt, Synology RT2600ac @ штатная прошивка).

Если AP в режиме «только 802.11ac», то подключение не проходит:

ноя 08 01:43:09 iot-0 NetworkManager[1145]: <info>  [1604788989.9384] device (wlan0): supplicant interface state: disconnected -> scanning
ноя 08 01:43:09 iot-0 NetworkManager[1145]: <info>  [1604788989.9385] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> scanning
ноя 08 01:43:12 iot-0 wpa_supplicant[1156]: wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="Nexus"
ноя 08 01:43:12 iot-0 wpa_supplicant[1156]: wlan0: Trying to associate with SSID 'Nexus'
ноя 08 01:43:12 iot-0 NetworkManager[1145]: <info>  [1604788992.2774] device (wlan0): supplicant interface state: scanning -> associating
ноя 08 01:43:12 iot-0 NetworkManager[1145]: <info>  [1604788992.2775] device (p2p-dev-wlan0): supplicant management interface state: scanning -> associating
ноя 08 01:43:14 iot-0 wpa_supplicant[1156]: wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16
ноя 08 01:43:14 iot-0 wpa_supplicant[1156]: wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Nexus" auth_failures=2 duration=20 reason=CONN_FAILED
ноя 08 01:43:14 iot-0 NetworkManager[1145]: <info>  [1604788994.5964] device (wlan0): supplicant interface state: associating -> disconnected
ноя 08 01:43:14 iot-0 NetworkManager[1145]: <info>  [1604788994.5965] device (p2p-dev-wlan0): supplicant management interface state: associating -> disconnected

Ширину канала в 20MHz форсировать пробовал, сам канал тоже заведомо подходящий, пробовал 36 и 64 (т. е. не регуляторные проблемы). Если включить на точке 802.11n, то подключается в соответствующем режиме:

# iw dev
phy#0
        Unnamed/non-netdev interface
                wdev 0x3
                addr 92:6f:9b:55:49:bf
                type P2P-device
                txpower 31.00 dBm
        Interface wlan0
                ifindex 3
                wdev 0x1
                addr dc:a6:32:cf:4e:fc
                ssid Nexus
                type managed
                channel 64 (5320 MHz), width: 40 MHz, center1: 5310 MHz
                txpower 31.00 dBm

# iw dev wlan0 link
Connected to 00:11:32:ad:75:e5 (on wlan0)
        SSID: Nexus
        freq: 5320
        RX: 157315041 bytes (189212 packets)
        TX: 2215381 bytes (21260 packets)
        signal: -51 dBm
        rx bitrate: 150.0 MBit/s
        tx bitrate: 200.0 MBit/s

        bss flags:      short-slot-time
        dtim period:    4
        beacon int:     100

(кстати, забавно, что MCS в выводе нет — ни HT, ни VHT, хотя это совершенно точно 802.11n)

Ядро ванильное из Arch Linux ARM (5.8.9-2-ARCH), aarch64, драйвер brcmfmac.

Куда копать?

★★★★★

Так всегда WiFi на RPBI через попу работал. На RPI3 вон от штатного минорного обновления ядра отваливался на Raspbian – надо было петрушиться. А ты тут про рач…

Проще от него отказаться, или если прям таки надо, то внешний взять.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 3)
Ответ на: комментарий от fornlr

Извини, но твои комментарии о том, как всё всегда работает через попу, неконструктивны и меня не интересуют, как и твоё ценное мнение об отдельных дистрибутивах и платформе GNU/Linux в целом.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
Ответ на: комментарий от fornlr

The router has an option to only allow known devices to connect which is just another name for MAC filter. The Pi was of course not in the list. I started from scratch and have successfully setup everything and WiFi is working perfectly.

Вообще не в тему.

Ты прежде чем вкатываться со своим экспертным мнением в конструктивные технические треды, хотя бы читать научись 🤣

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
cat /etc/hostapd/hostapd.conf
ssid=PI4AC
wpa_passphrase=password

country_code=US

interface=wlan0
driver=nl80211

wpa=2
wpa_key_mgmt=WPA-PSK
rsn_pairwise=CCMP

macaddr_acl=0

logger_syslog=0

logger_syslog_level=4

logger_stdout=-1

logger_stdout_level=0

hw_mode=a
wmm_enabled=1

# N
ieee80211n=1
require_ht=1
ht_capab=[MAX-AMSDU-3839][HT40+][SHORT-GI-20][SHORT-GI-40][DSSS_CCK-40]

# AC
ieee80211ac=1
require_vht=1
ieee80211d=1
ieee80211h=0
vht_capab=[MAX-AMSDU-3839][SHORT-GI-80]
vht_oper_chwidth=1
channel=36
vht_oper_centr_freq_seg0_idx=42

Вот рабочий вариант для режима ap, в режиме клиента тоже работает без проблем.

Linux pi4 5.9.1-1-MANJARO-ARM #1 SMP PREEMPT Mon Oct 19 11:53:29 CDT 2020 aarch64 GNU/Linux

ukr_unix_user ★★★★ ()
Ответ на: комментарий от fornlr

Говорю, ты прежде чем что-то от кого-то ожидать, сначала читать научись.

Там дальше обсуждают помехи, мощность сигнала, плохое питание, наводки на 5 ГГц от HDMI — всё что угодно, кроме того, что я здесь спросил.

intelfx ★★★★★ ()
Ответ на: комментарий от ukr_unix_user

Вот рабочий вариант для режима ap, в режиме клиента тоже работает без проблем

Ну, а у меня не работает. Заюзать твой hostapd-конфиг для станции я, очевидно, не могу :)

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
Ответ на: комментарий от intelfx

wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16

Ошибка, как в цитате у меня была на openSUSE (тоже ядро обычное, не васянское от малиноклепателей). Но у меня была она даже на 2.4 ГГц. Я даже думал, что это железная проблема уже.

Как завелось - хз: фару протирал, по колесу стучал. Обновил полностью малину из распбиана и притащил их фирмвари. Но в итоге все равно забил на набортный wifi и взял точку доступа микротик. (уж очень он слабенький на малине без антенн внешних)

UPD: Countrycode тоже крутил, да. Но он все же иную ошибку вызывает вроде.

gutaper ★★★★ ()
Последнее исправление: gutaper (всего исправлений: 2)

А у тебя, часом, в usb-портах ничего не торчит?

JaM ()
Ответ на: комментарий от anonymous

Да, у меня точка доступа US-locked, это автоматически происходит. (Я проверял.)

intelfx ★★★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.