LINUX.ORG.RU

Debian 10, Wayland и touchpad на Lenovo X1

 , , ,


0

1

Приветствую. После обновления до buster'а и перехода на wayland пропала возможность отключить touchpad через xinput (раньше выручала команда xinput disable "PS/2 Synaptics TouchPad").

Есть ли возможность вырубить touchpad, оставаясь под wayland'ом?


Ответ на: комментарий от aquadon

Как я понимаю, из всего вывода интерес могут представлять вот эти 2 устройства:

Device:           Raydium Corporation Raydium Touch System
Kernel:           /dev/input/event9
Group:            6
Seat:             seat0, default
Size:             320x180mm
Capabilities:     touch 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      identity matrix
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

...

Device:           PS/2 Synaptics TouchPad
Kernel:           /dev/input/event5
Group:            12
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *button
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   flat *adaptive
Rotation:         n/a

К слову про /etc/modprobe.d/psmouse.conf: когда решал ту же задачу под X.org, записал туда следующее:

blacklist i2c-i801
options psmouse synaptics_intertouch=1 proto=exps
С тех пор оно там так и остаётся. Наверное, blacklist psmouse могло бы решить задачу, но хочется найти оптимальное решение.

Возможно, стоит сказать, откуда вообще возникла задача отключить touchpad. Дело в том, что debian, в отличие от той же пресловутой винды, крайне чувствителен к прикосновению к touchpad'у. И работая на клавиатуре регулярно задеваешь её краем ладони, из-за чего регулярно кликаешь, куда не просят. Это жутко бесит и в голову не пришло ничего умнее, чем отключить touchpad, и в идеале иметь возможность при необходимости включить его обратно на время.

Zmey ()
Ответ на: комментарий от Zmey

ело в том, что debian, в отличие от той же пресловутой винды, крайне чувствителен к прикосновению к touchpad’у. И работая на клавиатуре регулярно задеваешь её краем ладони, из-за чего регулярно кликаешь, куда не просят.

У меня Debian Buster, libinput. Тачпад работает превосходно, в том числе никогда не срабатывает от ладони.

У тебя Disable-w-typing: n/a. Нужно искать в чем проблема в твоем случае.

aquadon ★★★★★ ()
Ответ на: комментарий от aquadon

Нужно в quirks разбираться, настроить разок и забыть. С обновой всё слетит, вероятно.

  1. https://wayland.freedesktop.org/libinput/doc/latest/touchpad-pressure-debugging.html#touchpad-pressure-hwdb
  2. https://wayland.freedesktop.org/libinput/doc/latest/device-quirks.html

Я, к сожалению, не могу у себя всё это протестировать.

kostyarin_ ()
Последнее исправление: kostyarin_ (всего исправлений: 1)
Ответ на: комментарий от kostyarin_

При выполнении sudo libinput measure touchpad-pressure получаю

Unable to find a touchpad device.

При выполнении sudo libinput measure touchpad-pressure /dev/input/event4 получаю

Using PS/2 Synaptics TouchPad: /dev/input/event4

Error: device does not have ABS_PRESSURE/ABS_MT_PRESSURE

Не могу понять, куда рыть. =\

При запуске libinput debug-events вижу, что чувствительность тачпада запредельная, но из-за проблем с measure не могу её отрегулировать.

Zmey ()
Ответ на: комментарий от Zmey

Так «чувствительность запредельная» это курсор летает или как?

P.S.: В смысле, может там разрешение тачпада в драйверах неправильное. Или именно чувствительность как она есть.

P.P.S: Есть вариант фиксить в дровах разрешение, или ковырять libinput.

P.P.P.S: И одинаково ли себя ведёт с одним пальцем и двумя.

kostyarin_ ()
Последнее исправление: kostyarin_ (всего исправлений: 3)
Ответ на: комментарий от Zmey

Error: device does not have ABS_PRESSURE/ABS_MT_PRESSURE

Это значит, что проблема не решаема средствами libinput. Т.к. багованная. Был какой-то баг по поводу Syanptic TouchPad и вроде бы после libinput 1.10 всё уже решили. А в libinput 1.9 его не было. Но видимо опять что-то притащили не то.

А какая версия libinput? Может есть вариант откатиться?


А вот как, вроде бы, чинить всё это, если с ABS_PRESSURE/ABS_MT_PRESSURE всё будет решено.

Ref.: https://unix.stackexchange.com/a/432139/83844

kostyarin_ ()
Ответ на: комментарий от kostyarin_

Под запредельной чувствительностью я имею в виду, что он реагирует на самое молейшее прикосновение (считает это за tap). На 2 пальца не реагирует (в смысле не считает это за tap).

Zmey ()
Ответ на: комментарий от anonymous

С gsettings всё вообще хорошо:

$ gsettings list-recursively org.gnome.desktop.peripherals.touchpad
org.gnome.desktop.peripherals.touchpad send-events 'disabled'
org.gnome.desktop.peripherals.touchpad natural-scroll true
org.gnome.desktop.peripherals.touchpad tap-to-click false
org.gnome.desktop.peripherals.touchpad two-finger-scrolling-enabled true
org.gnome.desktop.peripherals.touchpad left-handed 'mouse'
org.gnome.desktop.peripherals.touchpad click-method 'fingers'
org.gnome.desktop.peripherals.touchpad speed 0.0
org.gnome.desktop.peripherals.touchpad tap-and-drag true
org.gnome.desktop.peripherals.touchpad edge-scrolling-enabled true
org.gnome.desktop.peripherals.touchpad disable-while-typing true

То есть, если верить этому выводу, тачпад у меня вовсе не должен работать. Есть стойкое ощущение, что эти настройки работают под иксами, но не под wayland'ом. Но подробно этот вопрос не исследовал.

Zmey ()
Ответ на: комментарий от Zmey

Каким-то совершенно непонятным образом (не припомню, чтобы делал что-то особое, кроме установки Tomcat'а, IntelliJ IDEA, Java 8 и обновления Хрома) PS/2 Synaptics Touchpad испарился, а заместо него появилось такое:

Device:           Synaptics TM3288-011
Kernel:           /dev/input/event10
Group:            11
Seat:             seat0, default
Size:             97x53mm
Capabilities:     pointer gesture
Tap-to-click:     enabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

И тачпад внезапро начал работать, как положено (тапы во время набора текста не срабатывают, появился скролл 2мя пальцами, и настройки тачпада тоже на месте).

Вопрос: это может быть связано с java 8 (из коробки шла 11)?

Zmey ()
Ответ на: комментарий от Zmey

имхо: прилетело какое-то обновление которое и починило поддержку устройства. если очень надо: можно поискать в логах когда появилось новое устройство, какие были установлены пакеты, какие обновились и т.д. но это всего лишь «теория». а java как бы не должна влиять на идентификацию «железячек»...

anymouze ★★ ()
Ответ на: комментарий от Zmey

Вопрос: это может быть связано с java 8 (из коробки шла 11)?

Нет.

Это может быть связано с тем, что ядро стало работать с тачпадом по RMI4 вместо PS/2.

Другими словами, «поддержку тачпада починили».

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
Ответ на: комментарий от intelfx

За последнюю неделю ни одного обновления не ставилось, кроме как на хром. Я это знаю наверняка, потому что вынужден был откатывать php и слежу за тем, чтобы ничего сейчас не ставилось.

Судя по логам, тачпад проявился в системе только вчера, примерно в 22:30 (загрузился за 1.5 часа до моего сообщения). Кроме Java 8 ещё на ноут был поставлен Selenium средствами pip'а (python 3), но он ставился из-под виртуальной среды и не верится, что оно могло повлиять на систему.

В общем, в магию пока не верю.

Zmey ()
Ответ на: комментарий от intelfx

/etc/modprobe.d/psmouse.conf уже удалён вместе с этим параметром, но это произошло не 2 дня назад, а несколько раньше. Но на всякий случай позже верну и посмотрю, что это даст.

Zmey ()