LINUX.ORG.RU

Проблема с частотами на GTX 970

 ,


0

1

Оговорюсь сразу, проблема имеет место в всех дистрибутивах что я ставил(Solus, Arch, Manjaro, Debian, Ubuntu, openSUSE, Mint, Deepin) и всех DE( Gnome, Kde, XFCE, LXQT, DDE, i3), на ядрах с 4.0( Собственно раньше не пробовал). Драйвера проприетарные ( с 35? какой-то там серии)
Проблема заключается в некорректной работе частот на видеокарте GTX 970 которая почти все время работает на макс частотах( хотя и стоит режим адаптивный), при запуске программ макс частота может держаться минут 5, но потом спадает до минимальных и с окном можно делать все что угодно, частота не повышается. Но при запуске нового приложения все по новой.
Из-за этого разница с виндой ~ 15-18 градусов при простое. Вопрос в том куда копать и понять где проблема? Хотелось бы что бы видеокарта запускалась на максимум только в тяжелых приложениях, где это требуется, а в остальное время на минимуме. Если нужны логи с радостью предоставлю.
По железу AsRock Z97 Extreme3 + i5-4670K + MSI GeForce GTX 970 1140Mhz
NvidiaXServerMax
NvidiaXServerMin
Проблема похожа на эту, которая уже была на лоре

В качестве костыля можно вручную фиксировать частоты на мин/макс в зависимости от потребности.

anonymous ()
Ответ на: комментарий от anonymous

А как это сделать ТСу? application profiles задействовать?
Какие параметры и куда передавать?

sehellion ★★★★★ ()
Ответ на: комментарий от sehellion

Там даже разгон(и соответственно андерклок) прямо в nvidia-settings есть, как в гуе, так и консольными параметами. Только чтоб всё работало надо опцию в конфиг иксов прописать.

anonymous ()
Ответ на: комментарий от sehellion
nvidia-settings -a [gpu:$GPU]/GPUGraphicsClockOffset[$MIZ]=$CLK"

где: GPU - номер карты (0,1,2 итд) MIZ - PerformanceLevel который корректируем CLK - дельта к частоте. «+» разгоняем "-" тормозим. например -1000 - понизить частоту на гигагерц. увлекаться не стоит - ниже какого-то минимума работа будет неустойчивой

что бы это работало (разлочить доступ к этим настройкам), нужно в xorg.conf в разделе Screen прописать

    Option         "Coolbits" "31" 

и рестартануть иксы. после - параметры PowerMizer и кулера будут доступны и через cli (как я выше написал), и в гуе

только - тебе не пофиг ли на эти градусы? ну разгони кулер побыстрее. или в гуе или

nvidia-settings -a [fan:$GPU]/GPUTargetFanSpeed=$FAN"

anonymous ()
Ответ на: комментарий от anonymous

забыл добавить. еще параметр нужен "-с :0" (или какой там у тебя $DISPLAY)

и кулер надо с автомата на ручник перевести, что бы скорость регулировалась - "-a [gpu:$GPU]/GPUFanControlState=1"

anonymous ()
Ответ на: комментарий от anonymous

Спасибо, анон.
ps лично у меня с моей картой все работает отлично, но мало ли

sehellion ★★★★★ ()
Ответ на: комментарий от anonymous

Спасибо, судя по всему это единственный вариант. Просто хотелось разобраться с какого у всех все работает нормально а у меня через одно место

Romert ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.