LINUX.ORG.RU

AMD Radeon HD6250 ищу дистрибутив и нормальный драйвер

 


0

1

Господа и дамы (ежели таковые есть на ЛОРе), в наличии старенький ноутбук. С ужасной видеокартой от АМД. Все попытки использовать на нем GNU/Linux с треском проваливаются, ибо графика просто ужасная. В режиме 2Д вроде бы нормально работает, но как дело касается красивостей или пары слабеньких игр, то наступает армагедон. Тормозит и завистает даже супертукс и опенарена. Посоветуйте пожалуйста дистрибутив (желательно дебиан или производные от оного, но это не принципиально), где можно заставить эту видеокарту работать как надо.

Ну так дебиан тестинг и используй.Все красивости отключи, окружение полегче поставь.

sehellion ★★★★★ ()

AMD Radeon HD6250
ужасная графика

Мда, мда. Мне с бейтрейлом на ноуте и hd3200 на пк стало обидно.

Так вот,

Что за DE? Что за дистр? Экстрасенсов нету, в отпуске

Release ()

если на jessie проприетарщина не взлетит дело плохо, ниже только дистры без поддержки, а чего иксы вообще не тянут? я наоборот полностью перешел на иксы - в тестах до 300 fps выжимает...

amd_amd ★★★★ ()
Ответ на: комментарий от sehellion

У меня на одном ноуте вообще HD 2600 и все норм, стоит там какая-то стоковая убунта, вроде, с юнити

sehellion ★★★★★ ()

хз что ты ожидал от этого огрызка. для 6250 отрисовать рабочий стол уже достижение

меняй DE на легковеский WM типа openbox/icewm и надейся на лучшее

Ford_Focus ★★★★★ ()

Для игр такая вещь не годится, а так HD6250 это чип с кодовым именем CEDAR, относится к семейству Evergreen, ядерная часть - radeon, в месе драйвер - r600g. Для десктопа никаких проблем, никаких черных экранов, зависаний и тиринга (привет nvidia) не должно быть, все должно работать из коробки.

и завистает

Вот этого не должно быть. Ядро >= 4.х? Самое последнее ядро не требуется, развитие драйверов для старых графических карт уже почти прекратилось, главное не старое ядро.

Aber ★★★★ ()

Ты что HD6250 - это достаточно хорошая видео карта.

Ну а проблемы твои с 2D, 3D и прочим, скорее всего, из-за видеодрайвера.

Давая логи xorg-server`а, какой дистрибутив сейчас используешь?

kostik87 ★★★★★ ()

да нормально все работает на r600g, и 3 года назад работало нормально. если ставили fglrx, наслушавшись фанатов зеленого анального зонда - ССЗБ.

может, пора бы кулер бучку почистить да термопасту сменить? ему лет 5 минимум же.

ну и да, С-50 - таки слабый проц для игр/красивостей. ну где-то уровня пня 3 по производительности на ядро...

NiTr0 ★★★★★ ()

6250 это мобильная графика уровня атомов, о каких играх идет речь? Как юзер немного более продвинутой 6310 в составе e350 могу сказать, что о чем-то более серьезном чем warcraft 3 лучше не думать. Под виндой получше, я Portal 2 запускал (пусть и с малым fps), нопремер.

aegi ★★★ ()
Последнее исправление: aegi (всего исправлений: 1)

супертукс

SuperTuxKart вполне нормально игрался в ветке 0.8, потом слишком потяжелел.

aegi ★★★ ()

Я тут мимо пробегаю, просто спрошу: А чем это отличается от HD4200 (ATI/AMD встройка в южный мост) ???

Вроде эта мелюзга сносно работала под 26 федорой в вяленном. Насквозь поддерживается открытым драйвером. неужели кардинально всё изменилось в 6000й серии?

Deleted ()
Ответ на: комментарий от Deleted

почти ничем, примерно одного уровня затычки (хоть для своего времени очень даже ничего были как для нетбука, надирая что нвидию с ее ионом, что интел с ее GMOA) - но это было 6 лет назад).

NiTr0 ★★★★★ ()
Ответ на: комментарий от bormant

ну и накой этот онанизм с тухлым софтом и блобом? опенсорс дрова вполне себе неплохо работают, не сказал бы что хуже блоба. не нвидия же.

NiTr0 ★★★★★ ()
Ответ на: комментарий от NiTr0

Нафейхоа тогда эта тема, если опенсорс драйвер действительно работает и любой первый дистрибутив должон доставлять?

bormant ★★★★★ ()

в наличии старенький ноутбук

Я не понимаю прелести трахать дохлятину. Прекращайте сношать труп.

anonymous ()

Лучше один раз более-менее нормальную пеку собрать, потом на ней «за минуту долететь».

anonymous ()
Ответ на: комментарий от bormant

да потому что ТС накрутил свитоперделок в гуе, и удивляется чего же его нетбук с чахлым бобкэтом (да-да, производительность ядер ЦП - уровня конца 90-х, встроенное видео - ну где-то тоже на уровне дискреток тех времен +-, разве что более свежие стандарты умеет) тормозит при прорисовке рюшек.

NiTr0 ★★★★★ ()
Ответ на: комментарий от NiTr0

ТС не накручивал свистоперделок. ТС в диком ужасе от того, что при старом ядре и старом ксорге все работает как надо, а новые ядра и версии ксорга заствляют делать ему больно.

save_data ()

Вообщем накатил на этот калькулятор старую убунту 12.04. Заморозил ксорг и ядро (на всякий случай). В качестве печатной машинки и написания скриптов на питоне пока хватает. Надо будет написать «историю успеха» об этом фекалийном калькуляторе и моих мучениях с ним.

save_data ()
Ответ на: комментарий от save_data

точно новые ядра/иксы, а не новые кеды/гномик да новые релизы супертукса с более лучшей графикой?

когда у меня был такой нетбучек (года 2-3 назад), проблем с ним не было никаких, ну кроме нехватки памяти (2 гига распаяных) да общей неторопливости камня. даже в 3д, да, warzone2100 вполне себе шустро бегала, пробовал даже penumbra пускать - шла нормально. открытые дрова, свежая на то время меса/иксы. последнее ядро что было - то ли 3.18 то ли что.

NiTr0 ★★★★★ ()
Последнее исправление: NiTr0 (всего исправлений: 1)
Ответ на: комментарий от NiTr0

Точно. ЛОР и Гугл солидарны, что в новых ксоргах убрали нормальную поддержку старых серий радеонов. Ну а на новых ядрах старый ксорг или не поставить или это будет такой геморой, что проще иметь старое ядро и старый ксорг, но при этом сносно работающую пишущию машинку. Представь себе, что когда на этой же машине стоял свежий дебиан 9 нетинстал, то там даже при минимуме всего тормозили иксы с флукбоксом в качестве wm. А сейчас даже эффекты перделок и свистелок с прозрачностями спокойно можно запускать при de xfce.

save_data ()
Ответ на: комментарий от save_data

Вот и считайте свежесть софта, апрель 2012 vs. июль 2016 (релиз Slackware 14.2) при одинаковом драйвере.

Назло маме отморожу уши ;)

bormant ★★★★★ ()
Последнее исправление: bormant (всего исправлений: 1)
Ответ на: комментарий от bormant

Ну о каком свежем софте можно говорить в печатной машинке? Емакс он и в африке емакс. Firefox 52 версии норм работает. мпд+соната поют мне песни, влц редко будет крутить какой-либо фильм. Торенты трансмиссия качает. Пиджин чатики читает. А что-то более значимое на этом железе делать нельзя.

save_data ()
Ответ на: комментарий от save_data

В целом понятно. Если б еще срок поддержки у 12.04 не закончился в апреле 2017, вообще б отлично было.

bormant ★★★★★ ()
Ответ на: комментарий от save_data

Можно еще NetSurf добавить для большинства несложных случаев.

bormant ★★★★★ ()
Ответ на: комментарий от save_data

ЛОР и Гугл солидарны, что в новых ксоргах убрали нормальную поддержку старых серий радеонов

да никто ничего не убирал, hd3000/3200 из то ли 760g, то ли 780g вполне себе прекрасно без тормозов работает под gentoo stable (вот только не помню когда апдейтил софт - сейчас то ли 4.9 ядро там, то ли 4.14). и даже гуглоземля работает без тормозов, да. и ютупчик играет.

Представь себе, что когда на этой же машине стоял свежий дебиан 9 нетинстал, то там даже при минимуме всего тормозили иксы с флукбоксом в качестве wm

уж не потому ли что vesafb использовался в качестве видеодрайвера?

NiTr0 ★★★★★ ()
Ответ на: комментарий от save_data

влц редко будет крутить какой-либо фильм

подумаешь, без аппаратного ускорения (которое завезли эдак в 2014-2015 годах в ядро, ближе к 4.0 версии ЕМНИП), делов-то...

NiTr0 ★★★★★ ()
Ответ на: комментарий от NiTr0

Обычный HD(720) вполне себе годно крутилось. Ну а смотреть что-то нормальное в нормальном качестве я могу и на телевизоре в 40 инчей.

save_data ()
Ответ на: комментарий от save_data

ну если с битрейтом 2-3 мбита (какой-то крепко пожатый рип) - возможно.

NiTr0 ★★★★★ ()

на недобук с e-350 и hd6310 успешно воткнул ubuntu xenial и fglrx по этому рецепту с использованием trusty вместо wily. там же кстати есть и ссылка на подобный финт в федоре, если в остальном нужен апстримный дистр.

redby ()
Ответ на: комментарий от amd_amd

> если на jessie проприетарщина не взлетит - дело плохо

«Взлетит». Там ядро 3.16, а Catalyst 15.12 поддерживает 2.6.27 - 3.19

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Ответ на: комментарий от OpenMind

А Radeon free драйвер из убунты что разве не работает? Летать же должно.

ТС походу, всё переломал в дистре

darkenshvein ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.