LINUX.ORG.RU

Поддержка 3D ускорения

 , ,


0

1

Здравствуйте.

Дистрибутив Slackware 14.1, возникла проблема с поддержкой с 3D-ускорения видеокарты Intel.

    00:02.0 VGA compatible controller: Intel Corporation ValleyView Gen7 (rev 0e)

    # glxinfo | grep 'renderer string'
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)

Ядро 3.8.13 Версия MESA 11.2.2

При этом, если устанавливать Slackware-current с ядром 4.4, 3D-ускорение работает.

Но нужно включить его на ядре 3.8.

Я не понял, а в чём конкретно проблема с 3d-ускорением? glxgears плохие результаты даёт? Композитинг тормозит? Ты уж уточни, а то телепаты из отпуска не вернулись ещё

XMs ★★★★★ ()
Ответ на: комментарий от XMs

Llvmpipe это софтовый рендер, который не использует видеокарту.

anonymous ()
Ответ на: комментарий от XMs

llvmpipe - софтверный. У чувака аппаратное ускорение ны робит.

timdorohin ★★★ ()

Но нужно включить его на ядре 3.8.

No way. Если только сам не портируешь drm.

steemandlinux ★★★★★ ()
Ответ на: комментарий от steemandlinux

+1. ИЧСХ, портировать не особо сложно, интерфейс там ломают редко - он в userspace светит...

timdorohin ★★★ ()

Модуль ядра насмльно подгрузить? Лог иксов?

Zampolit ()
Ответ на: комментарий от Sergey_Kostin

Да, правда проще исправить причину требования ядра 3.8

steemandlinux ★★★★★ ()
Ответ на: комментарий от Zampolit

Насильно загрузить модуль не получилось.

# insmod /mnt/memory/lib/modules/4.4.13-smp/kernel/drivers/gpu/drm/i915/i915.ko 
insmod: ERROR: could not insert module /mnt/memory/lib/modules/4.4.13-smp/kernel/drivers/gpu/drm/i915/i915.ko: Invalid module format

Sergey_Kostin ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.