LINUX.ORG.RU

Отключилась сетевая карта.

 , ,


0

2

Доброго времени суток!

Сетевая карта (Qualcomm Atheros AR9485) на ноуте (Lenovo G510) внезапно (а точнее после обновления свежепоставленного Debian 8) и без объяснения причин «ушла» из системы - видится, модуль (ath9k) подгружен, но не работает.

(следующие операции выполняю под LiveCD Mint 17, на котором точно работал wifi)

Когда ifconfig wlan0 up послал с формулировкой SIOCSIFFLAGS: Operation not possible due to RFKILL, пошел его смотреть. Собственно:

# rfkill list

0: ideapad_wlan: Wireless LAN
  Soft blocked: no
  Hard blocked: no
1: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: yes

(остальная часть, про BT, опущена, т.к. роли не играет).

# cat /sys/class/rfkill/rfkill1/state
2

Гугл подсказал что эта цифра означает ничто иное как аппаратное отключение. Итак, действия (перечислено в произвольном порядке):

Попытки засунуть 0 в данный файл, естественно, успехом не увенчались.

Режим полета по Fn+F7 делает soft block для ideapad_wlan и phy0.

Ноут вскрыл, посмотрел на карточку, вынул/вставил. Паленым не пахло, провода, вроде, на месте, без видимых повреждений (да и опознается же она в системе).

Залез в BIOS, посмотрел на Wireless LAN: [ Enabled ], отключил, перегрузился - wifi вообще пропал. Вернул взад. Карточка в системе опозналась, но проблема не решилась.

Что еще выполнял:

# rmmod ath9k
# rfkill unblock all
# modprobe ath9k
# rfkill block all
# rmmod ath9k
# rfkill unblock all
# modprobe ath9k

(и прочий брутфорс с данными командами)

Также пробовал восстановить схему действий (т.к. обновление шло в ночь, без моего участия): усыплял/суспендил машину, будил через Fn+F7; перезагружал, стараясь дожать эту же комбинацию, в момент запуска ноута (когда все обычно стараются попасть в BIOS)

Долго, с фонариком, лупой и такой-то матерью искал на корпусе хоть какое-то подобие тумблера для управления wifi (вдруг за пару лет работы с данной машиной я его не замечал)

Также, вывод dmesg при загрузке ath9k:

ath: phy1: Set BT/WLAN RX diversity capability
ath: phy1: ASPM enabled: 0x42
ath: EEPROM: regdomain: 0x65
ath: EEPROM indicates we should expect a direct regpair map
ath: Country alpha2 being used: 00
ath: Regpair used: 0x65
ieee80211 phy1: Selected rate control algorithm 'ministrel_ht'
ieee80211 phy1: Atheros AR9485 Rev:1 mem=0xffffc90022300000, irq=17
IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Помогите, пожалуйста: что еще можно предпринять для решения данной проблемы?

Заранее благодарен за помощь.


Ответ на: комментарий от onlybugs

Да, я из-под LiveCD все и делал, о чем указано в начале поста:

(следующие операции выполняю под LiveCD Mint 17, на котором точно работал wifi)

Lan4X ()

Хардварный переключатель на ноуте есть? (вообще у членово не должно быть). Тогда линуксопроблемы.

Yossarian ()
Ответ на: комментарий от Yossarian

Долго, с фонариком, лупой и такой-то матерью искал на корпусе хоть какое-то подобие тумблера для управления wifi (вдруг за пару лет работы с данной машиной я его не замечал)

На старом G555 такое есть, на этом нет.

Lan4X ()
Ответ на: комментарий от Lan4X

Уже минут на 5 вытаскивал

Достаточно

а точнее после обновления свежепоставленного Debian 8
LiveCD Mint 17

Винду давно снес? Может виндовый драйвер разлочил карту и пока debian ее не сресетил, она работала.

arson ★★★★★ ()
Ответ на: комментарий от Yossarian

Попробовал 3 livecd (Mint, Fedora, даже Elementary нашел) - нигде не работает.

Также: сбрасывал BIOS и пересоздавал(удалял) /dev/rfkill (не знаю зачем, но терять нечего было).

Нет реакции. Под виндой не тестировал, т.к. нет её у меня. Придется качать, видимо.

Lan4X ()
Ответ на: комментарий от arson

Винду снес примерно года полтора назад

Все нормально работало на генте (пока по дурости не умудрился недавно снести её), в качестве варианта «чтобы быстрее» - был и поставлен Debian.

Lan4X ()
Ответ на: комментарий от Yossarian

Винда не помогла. Скачал лайв, поставил драйвера, потыркался - ноль эмоций.

Нашел W8 SL, доставил. Поставил _все_ драйвера - не помогло.

Вынул карточку, почистил спиртом / ластиком контакты - тоже не возымело действия. Видимо к ней пришел песец.

Благодарю всех за помощь, пойду искать замену.

Lan4X ()
19 февраля 2016 г.

Решение проблемы

В общем. После долгих (хоть и несколько ленивых) поисков купил я AR5B225 (FRU p/n: 20200224). Она также не завелась, с теми же ошибками выпадала.

На форуме леновы мне предложили следующее решение: установить 7ую винду (я так понял - это критично, т.к. на 8рке у меня не прокатило), все драйвера и Lenovo Energy Management. Передернуть режим полета.

Мне хватило драйвера на wlan и LEM. При нажатии на хоткей появилось окно LEM, где было указано, что wlan отключен. Переключил во «ВКЛ» - и проблема решилась.

А как на линупсах хардблок снять я так и не понял.

Lan4X ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.