LINUX.ORG.RU

Проблема: не работает ath9k


0

1

Ядро 2.6.36, дистрибутив Gentoo, в альте и в openSuSE работает. Лампочка Wi-Fi ноутбука не горит. Набираю rfkill и получаю:

athlon_neo zenitur # rfkill list
0: acer-wireless: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
athlon_neo zenitur # rfkill unblock 0
athlon_neo zenitur # rfkill list
0: acer-wireless: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
athlon_neo zenitur #

Лампочка на секунду загорается, и что-то снова блокирует Wi-Fi! Если отключен демон NetworkManager, лампочка не загорается. GUI в ту секунду, пока она горит, заменяет надпись «поддержка беспроводных сетей отключена» в графе «Беспроводные сети» на «соединение разорвано». Смена драйвера на madwifi помогает, но это проприетарный.

Зачем

NetworkManager

вместо демона управления сетевыми соединениями?
cat /etc/conf.d/net && ls -lh /etc/init.d/net* && ls /usr/share/doc/openrc-*/net.example
А пока могу посоветовать разве что wicd.

Deleted ()

Конечно, неработабщее, но Open Source - это лучше, чем работающее, но проприетарное. Однозначно.

Axon ★★★★★ ()

Если по теме, то какие ядра были в альте и сусе?

Axon ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Стоит посмотреть и откатиться до такой же версии, если она отличается.

Axon ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Или, наоборот, поставить свежую. Может, в ней уже починили.

Axon ★★★★★ ()
Ответ на: комментарий от AITap

/var/log/messages:

сразу после rfkill unblock 0 ничего. После ifconfig wlan0 up лампочка загорается, но ничего не работает (в NetworkManager и в других средствах настройки), а в логе:

Jun  7 18:31:52 athlon_neo NetworkManager[15974]: <info> WiFi now enabled by radio killswitch
Jun  7 18:31:52 athlon_neo NetworkManager[15974]: <info> (wlan0): bringing up device.
Jun  7 18:31:52 athlon_neo kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jun  7 18:31:52 athlon_neo NetworkManager[15974]: <info> (wlan0): supplicant interface state:  starting -> ready
Jun  7 18:31:52 athlon_neo NetworkManager[15974]: <info> (wlan0): device state change: 2 -> 3 (reason 42)
Jun  7 18:31:53 athlon_neo NetworkManager[15974]: <info> WiFi now disabled by radio killswitch
Jun  7 18:31:53 athlon_neo NetworkManager[15974]: <info> (wlan0): device state change: 3 -> 2 (reason 0)
Jun  7 18:31:53 athlon_neo NetworkManager[15974]: <info> (wlan0): deactivating device (reason: 0).
Jun  7 18:31:53 athlon_neo NetworkManager[15974]: <info> Policy set 'Auto eth0' (eth0) as default for IPv4 routing and DNS.
Jun  7 18:31:53 athlon_neo NetworkManager[15974]: <info> Policy set 'Auto eth0' (eth0) as default for IPv4 routing and DNS.
Jun  7 18:31:53 athlon_neo NetworkManager[15974]: <info> (wlan0): taking down device.
Jun  7 18:31:59 athlon_neo kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jun  7 18:33:07 athlon_neo NetworkManager[15974]:    keyfile: updating /etc/NetworkManager/system-connections/Auto eth0

dmesg: http://paste.org.ru/?tdyb65.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от Deleted

Я уже заводил такую тему. NetworkManager у меня не было. Тогда мне никто не помог.

ZenitharChampion ★★★★★ ()

Решено. Очередным гуглингом нашёл на gentoo.ru эту проблему у человека, который обновил ядро 2.6.31 до 2.6.32. Ему помогло отключения rfkill из ядра. Я с радостью перекомпилировал ядро и всё заработало. Оказалось, можно было просто добавить модуль rfkill в /etc/modprobe.d/blacklist.conf, или стереть его физически. Единственный минус - кнопка отключения Wi-Fi его не отключает! И всё равно я удалил проприетарный модуль и установил свободный.

ZenitharChampion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.