LINUX.ORG.RU

Как убрать воспроизведение звука с HDMI

 ,


0

1

Здравия! Помогите пожалуйста с решением проблемы, который день не могу её решить. Установил Linux Mint 17.3 Cinnamon. В системе нет звука через звуковую карту (карта подключаемая, стандартную в БИОСе отключил), а звук идёт на HDMI выход видеокарты. Установил уже Pulsaeaudio, отключил там HDMI, проблему это не решило. Покопался с alsamixer, там по дефолту стоит NVidia, создал .conf файл, и задал там дефолтное значение нужной аудиокарты... не помогло, звук всё-равно идёт на HDMI. Перерыл всё, но нигде нет ответа как отключить вывод звука на HDMI, может кто знает решение?

Ответ на: комментарий от Faust5000

настроить устройством по-умолчанию свою звуковуху в нем

после этого пульса должна подхватить.

если не подхватит была какая-то гуевина для пульсы которая позволяла править настройки, возможно pactl, но могу путать - сижу с температурой.

когда обе звуковухи есть это хорошо) хуже когда на дефолном HDMI звука нет потому что дрова не допилили.

Slackware_user ★★★★★ ()

Если у тебя дефолтная конфигурация с пульсаудио, то достаточно поставить pavucontrol и в девайсах отключить все лишние.

Или задать sink (выход) по умолчанию, через «pacmd set-default-sink номер (или по имени)». Это можно затем прописать в список команд, которые исполняет пульсаудио при запуске.

altwazar ★★ ()
Последнее исправление: altwazar (всего исправлений: 1)

В системе нет звука через звуковую карту (карта подключаемая, стандартную в БИОСе отключил), а звук идёт на HDMI выход видеокарты.

Так же через pavucontrol можно убедиться, что подключаемая карта вообще работает и на неё выводится звук.

Ни какие связанные с alsa конфиг файлы с pulseaudio в системе трогать не надо, только сложнее будет разобраться потом в настройках.

altwazar ★★ ()
Ответ на: комментарий от altwazar

altwazar, карта работает, потому как в pavucontrol при отключении HDMI, остаётся только она и при воспроизведении звука полоска индикации дёргается, но звука нет. И ещё, у HDMI во вкладке Advanced постоянно отмечен PCM, будет ли этот показатель у карты при «pacmd set-default-sink номер (или по имени)» этой настройке?

Faust5000 ()
Ответ на: комментарий от Faust5000

остаётся только она и при воспроизведении звука полоска индикации дёргается, но звука нет.

Полоска дергается в pavucontrol на нужном выходе (на вкладке с устройствами вывода)? Звук в этом случае должен быть. Если звука при этом нет, то другие звуковушки тут не причем.

Похоже на то, что или у карточки профиль стоит не тот (в pavucontrol на вкладке конфигурация), или в alsamixer выход замьючен или громкость в ноль убрана.

Номер/имя для set-default-sink можно посмотреть через «pacmd list-sinks».

altwazar ★★ ()
Ответ на: комментарий от altwazar

Да, полоска дёргается на нужном выходе, звук не замьючен, профили пробовал все, ни один не даёт звука. Выбрал профиль - Цифровое стерео (IEC958)Выход. Вкладка Advanced теперь как и у HDMI, PCM отмечен. Ползунок активности бегает, звука нет. Вот показания sink: Welcome to PulseAudio! Use «help» for usage information.

2 sink(s) available.

index: 0 name: <alsa_output.pci-0000_01_00.1.hdmi-stereo> driver: <module-alsa-card.c> flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY state: SUSPENDED suspend cause: IDLE priority: 9050 volume: 0: 100% 1: 100% 0: 0,00 dB 1: 0,00 dB balance 0,00 base volume: 100% 0,00 dB volume steps: 65537 muted: no current latency: 0,00 ms max request: 0 KiB max rewind: 0 KiB monitor source: 0 sample spec: s16le 2ch 44100Гц channel map: front-left,front-right Стерео used by: 0 linked by: 0 configured latency: 0,00 ms; range is 0,50 .. 371,52 ms card: 0 <alsa_card.pci-0000_01_00.1> module: 4 properties: alsa.resolution_bits = «16» device.api = «alsa» device.class = «sound» alsa.class = «generic» alsa.subclass = «generic-mix» alsa.name = «HDMI 0» alsa.id = «HDMI 0» alsa.subdevice = «0» alsa.subdevice_name = «subdevice #0» alsa.device = «3» alsa.card = «0» alsa.card_name = «HDA NVidia» alsa.long_card_name = «HDA NVidia at 0xf7080000 irq 17» alsa.driver_name = «snd_hda_intel» device.bus_path = «pci-0000:01:00.1» sysfs.path = «/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0» device.bus = «pci» device.vendor.id = «10de» device.vendor.name = «NVIDIA Corporation» device.product.id = «0bea» device.product.name = «GF108 High Definition Audio Controller» device.string = «hdmi:0» device.buffering.buffer_size = «65536» device.buffering.fragment_size = «32768» device.access_mode = «mmap+timer» device.profile.name = «hdmi-stereo» device.profile.description = «Digital Stereo (HDMI)» device.description = «GF108 High Definition Audio Controller Digital Stereo (HDMI)» alsa.mixer_name = «Nvidia GPU 14 HDMI/DP» alsa.components = «HDA:10de0014,10de0101,00100100» module-udev-detect.discovered = «1» device.icon_name = «audio-card-pci» ports: hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no) properties: device.icon_name = «video-display» active port: <hdmi-output-0> * index: 1 name: <alsa_output.pci-0000_04_03.0.analog-stereo> driver: <module-alsa-card.c> flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY state: SUSPENDED suspend cause: IDLE priority: 9059 volume: 0: 100% 1: 100% 0: 0,00 dB 1: 0,00 dB balance 0,00 base volume: 63% -12,00 dB volume steps: 65537 muted: no current latency: 0,00 ms max request: 0 KiB max rewind: 0 KiB monitor source: 2 sample spec: s32le 2ch 48000Гц channel map: front-left,front-right Стерео used by: 0 linked by: 0 configured latency: 0,00 ms; range is 0,50 .. 682,67 ms card: 2 <alsa_card.pci-0000_04_03.0> module: 6 properties: alsa.resolution_bits = «24» device.api = «alsa» device.class = «sound» alsa.class = «generic» alsa.subclass = «generic-mix» alsa.name = «ICE1724» alsa.id = «ICE1724» alsa.subdevice = «0» alsa.subdevice_name = «subdevice #0» alsa.device = «0» alsa.card = «2» alsa.card_name = «ICEnsemble ICE1724» alsa.long_card_name = «ICEnsemble ICE1724 at 0xc080, irq 16» alsa.driver_name = «snd_ice1724» device.bus_path = «pci-0000:04:03.0» sysfs.path = «/devices/pci0000:00/0000:00:1e.0/0000:04:03.0/sound/card2» device.bus = «pci» device.vendor.id = «1412» device.vendor.name = «VIA Technologies Inc.» device.product.id = «1724» device.product.name = «VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller» device.string = «front:2» device.buffering.buffer_size = «262144» device.buffering.fragment_size = «131072» device.access_mode = «mmap+timer» device.profile.name = «analog-stereo» device.profile.description = «Аналоговое стерео» device.description = «VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller Аналоговое стерео» alsa.mixer_name = «VIA Technologies id 83» alsa.components = «AC97a:56494183» module-udev-detect.discovered = «1» device.icon_name = «audio-card-pci» ports: analog-output;output-amplifier-on: Аналоговый выход / Усилитель (priority 9910, latency offset 0 usec, available: unknown) properties: analog-output;output-amplifier-off: Аналоговый выход / Нет усилителя (priority 9900, latency offset 0 usec, available: unknown) properties: active port: <analog-output;output-amplifier-on>

Faust5000 ()
Ответ на: комментарий от Faust5000

Номер и имя синка тут:

index: 1

name: <alsa_output.pci-0000_04_03.0.analog-stereo> (без <>)

Но если нет звука, то дело явно не в звуковой карте по умолчанию. Я бы погуглил на предмет отсутствия звука с этой карточкой под линуксом, так как похоже специфичная именно для этой карты (VT1720/24 [Envy24PT/HT]).

altwazar ★★ ()
Ответ на: комментарий от altwazar

Ой, гуглил, ничего полезного. И ещё, в чём прикол, бывает загружается и звук есть, а бывает звук появляется после проигрывания MP3, а бывает его вообще нет. Может попробовать установить дрова с Винды? Так можно сделать?

Faust5000 ()
Ответ на: комментарий от altwazar

Может быть добавить HDMI звук в чёрный список, чтобы при старте системы этот модуль не загружался?

Faust5000 ()
Ответ на: комментарий от Faust5000

Можно добавить в черный список модуль snd_hda_intel, тогда система вообще не обнаружит hmdi карточку.

Но будет странно, если это решит проблему. Больше похоже на проблему с замьючиванием, на что-то такое (та же карточка и решение подобной проблемы):

http://www.linuxquestions.org/questions/linux-hardware-18/no-sound-after-rand... (предпоследний пост в теме)

altwazar ★★ ()
Последнее исправление: altwazar (всего исправлений: 1)
Ответ на: комментарий от altwazar

Я правильно понял? Нужно пройти по пути /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common или же в моём случае sudo gedit /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common и в этом файле найти строку [Element] PCM и выставить значение ON?

Faust5000 ()
Ответ на: комментарий от Faust5000

Найти раздел [Element] PCM, там параметр switch = mute заменить на switch = on.

Потом в двух разделах [Option Analog Output:Headphones] и [Option Analog Output:Speakers] добавить строчку switch = on под существующими параметрами (там изначально только name и priority строчки). Потом перезапустить систему. Не знаю, сработает или нет.

altwazar ★★ ()
Последнее исправление: altwazar (всего исправлений: 2)
Ответ на: комментарий от Faust5000

Ну, испробовал оба способа и... результат практически нулевой. Вот как вела себя система. Сначала установил нужные значения в файле конфига, перезагрузился, и звук появился! НО, уже после следующей перезагрузки снова пропал и уже не появлялся. Думал, может внесённые мной изменения исчезли из файла, нет, всё на месте. Пошёл дальше, внёс нужный модуль в чёрный список, перезагрузка, звук есть и модуль HDMI пропал из выбора устройств вывода. Снова перезагрузился и... звука снова нет. Получается, что применил оба способа, но от проблемы они не избавили. Но ведь изменения приводили к положительному результату оба раза, до второй перезагрузки, значит всё-таки есть способ побороть эту напасть. P.S.: Может ли ТВ-тюнер способствовать этой проблеме? Он хоть и работает только на вход, но вдруг?

Faust5000 ()
Ответ на: комментарий от Faust5000

Была подобная проблема, связанная с тем, что HDMI определялся как дефолтная звуковуха. Решилось перенумерацией звуковых карт вручную в /etc/modprobe.d/alsa.conf

options snd cards_limit=4
alias snd-card-0 snd-ca0106 # AudigySE
options snd-ca0106 index=0

alias snd-card-1 snd-hda-intel
options snd-hda-intel index=1 # HDMI
Лимит 4, чтобы другие возможные звуковухи тоже подхватывались - встроенная (когда включаю) и usb-приблуда.

Может ли ТВ-тюнер способствовать этой проблеме? Он хоть и работает только на вход, но вдруг?

Если он учитывается как звуковуха, то после отключения HDMI модуля оно также могло запрыгнуть на нулевой индекс.

бывает звук появляется после проигрывания MP3, а бывает его вообще нет

Звук должен работать, если в проигрывателе указать конкретную звуковую карту.

no-such-file ★★★★★ ()
Ответ на: комментарий от no-such-file

У меня файла alsa.conf нет, его нужно создать, как я понял? И какое имя звуковухи вписать в параметр?

Faust5000 ()
Ответ на: комментарий от Faust5000

его нужно создать, как я понял?

Да. Но если его нет, то можно просто дописать в любой другой в этом каталоге.

какое имя звуковухи вписать в параметр
alsa.driver_name = «snd_ice1724»

Видимо snd_ice1724, ваш К.О.

no-such-file ★★★★★ ()
Ответ на: комментарий от Faust5000

Гугл рассказывает, что с этой картой вообще у всех похожие проблемы, причём давно.

no-such-file ★★★★★ ()
Последнее исправление: no-such-file (всего исправлений: 1)
Ответ на: комментарий от Faust5000

Может ли ТВ-тюнер способствовать этой проблеме?

Нет. Проблема в этой карточке и поддержке её линуксом. Другие карточки можно не трогать. Так как звука нет при явном выводе его на нужную карточку в pavuctonrol и при этом он иногда появляется, то что-то на карточке мьютится или переключается не в тот режим.

Тут надо бы смотреть в сторону alsamixer-а, выбрать эту карточку и крутить на ней всё подряд. Может звук появится даже при переключении какой-нибудь функции сначала на другое значение, потом на изначальное. Если получится это обнаружить, то можно соорудить костыль для обхода этой проблемы.

Скинь на всякий случай содержимое analog-output.conf.common на pastebin.com, вдруг там ошибка.

altwazar ★★ ()
~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC3263 Analog [ALC3263 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
~$ cat .asoundrc
defaults.pcm.!card "PCH";
defaults.ctl.!card "PCH";
defaults.pcm.!device 0;

В твоем выхлопе aplay -l будет не "card 1: PCH" а что-то другое, вот это другое и подставь в прилагаемый .asoundrc.

A1 ()
Ответ на: комментарий от A1

Вот что вышло у меня:

**** Список PLAYBACK устройств ****
карта 0: ICE1724 [ICEnsemble ICE1724], устройство 0: ICE1724 [ICE1724]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 0: ICE1724 [ICEnsemble ICE1724], устройство 1: ICE1724 IEC958 [ICE1724 IEC958]
  Подустройства: 1/1
  Подустройство №0: subdevice #0

Faust5000 ()
Ответ на: комментарий от Faust5000

Тогда попробуй следующие .asoundrc

defaults.pcm.!card "ICE1724";
defaults.ctl.!card "ICE1724";
defaults.pcm.!device 0;
defaults.pcm.!card "ICE1724";
defaults.ctl.!card "ICE1724";
defaults.pcm.!device 1;

Отличаются номером device.

A1 ()
Ответ на: комментарий от A1

Попробовал оба варианта. Первый не помог, второй вообще убрал карту из системных настроек звука.

Faust5000 ()
Ответ на: комментарий от Faust5000

UPD. Естественно, после удаления PA ничего не изменилось, т.к. проблема была ещё до его установки.

Faust5000 ()
Ответ на: комментарий от Faust5000

alsa громкость везде включена

Я бы убедился в pavucontrol, что звук идет на нужную карточку. Затем подергал бы переключатели в алсамиксер. Multi Tr бы повключал, повыключал (особенно там где 44100), S/PDIFы и т.п. Вполне может быть, что переключив что-нибудь из этого звук появится.

p.s.: ну или без пульсы, если нет желания её ставить. Тогда выбрать нужную карточку в проигрывателе и тогда уже дергать за рычаги.

altwazar ★★ ()
Последнее исправление: altwazar (всего исправлений: 1)
Ответ на: комментарий от Faust5000

может быть связано с особенностями управления питанием звуковухи.

она вообще всегда видна в линуксе?

Slackware_user ★★★★★ ()
Ответ на: комментарий от A1

проблема не в пульсе а в звуковухе. скорее всего в ее кривой архитектуре и недопиленности линуксового драйвера.

Slackware_user ★★★★★ ()
Ответ на: комментарий от Faust5000

скорее всего этим заблочится не только звук через hdmi.

я бы посоветовал пока спокойно юзать наушники/колонки в моник периодически проверяя не исправили ли эту.

Slackware_user ★★★★★ ()
Ответ на: комментарий от altwazar

Поигрался с ползунками в alsa - никакого эффекта. Решил убрать карточку из материнки, включить встроенные динамики. Но на материнке есть ещё выход под HD звук, туда и подключил фронтальные динамики с микрофоном. Перезагрузился, получил три устройства вывода: Аналоговые наушники, Аналоговый выход, Цифровой выход (S/PDIF). Звук при выборе Аналогового выхода идёт и из стандартного разъёма на материнке, и из HD выхода, только получше.А при выборе цифрового выхода, та же ситуация, что и с карточкой, ползунок бегает - звука нет. Кстати в alsa нельзя с нуля поднять ползунок S/PDIF ни в карточке, ни в стандартном выходе. Остановлюсь на подключённом HD выходе, всё же лучше, чем стандартный выход. Только качество звука меня всё-равно не совсем устраивает. Может есть какой-то программный улучшайзер звука? На Винде, я например использовал DFX. Слышал, что в Линуксе можно поправить какие-то конфиги и улучшить звук.

Faust5000 ()
Ответ на: комментарий от Faust5000

а что гугл говорит про переключение количества каналов данной звуковухи в линуксе?

оно пходу вместо стерео пытается 5.1 или 7.1 вещать.

Slackware_user ★★★★★ ()
Ответ на: комментарий от Faust5000

вопрос 1й: есть ли на машине сетевой фильтр?

вопрос 2й: по HDMI монитора звук лучше или хуже чем через стандартный выход?

Slackware_user ★★★★★ ()
Ответ на: комментарий от Faust5000

А при выборе цифрового выхода, та же ситуация, что и с карточкой, ползунок бегает - звука нет.

Может просто колонки были не подключены к s/pdif или на колонках только аналоговый вход?

Про улучшайзеры не знаю. Для получения качественного звука наоборот стараются убрать все прослойки между программой и карточкой.

Качество звука оценить можно только в живую, ну и встроенные карточки им не блещут.

altwazar ★★ ()
Ответ на: комментарий от altwazar

иногда бывает что из-за кривого драйвера внешние тоже работают хреново.

я лично для себя сделал выбор в сторону HDMI выхода видеокарты и хороших наушников в моник. лучше может быть только конвертер hdmi в hdmi с аудио. правда они дорогие до черта.

Slackware_user ★★★★★ ()
Ответ на: комментарий от Slackware_user

а что гугл говорит про переключение количества каналов данной звуковухи в линуксе?

насчёт этого не знаю, даже ещё не смотрел в эту сторону.

вопрос 1й: есть ли на машине сетевой фильтр?

что за фильтр?

вопрос 2й: по HDMI монитора звук лучше или хуже чем через стандартный выход?

Вы меня не поняли немного. Ни видюхе три разъёма: HDMI, DVI, и обычный, уж не помню его название. Монитор подключен через обычный, т.е. на него идёт просто видеосигнал. Через DVI подключён телевизор через кабель DVI>HDMI. А звук выводился на домашний кинотеатр через карточку посредством обычного кабеля jack 3.5. И теперь, лишившись отличного звука с карточки, нужно искать пути улучшения звука программно. Похоже я немного ошибся насчёт s/pdif, и видимо он вообще ранее не использовался, просто рядом с ним в менеджере звука была надпись Цифровой, и я отнёс его к HD. Но это не отменяет того факта, что звука с карточки не было ни с одного из режимов: Стерео, Дуплекс. Что скажете насчёт этого способа улучшения звука (с другого форума):

под Cinnamon (Корицу)

в корице не нужно устанавливать pavcontrol

улучшение звука: 1) открыть терминал (Ctrl+Alt+T) 2) вставить команду: sudo gedit /etc/pulse/daemon.conf 3) ввести пароль своей учетки (root'a)

в открывшемся текстовом файле:

4) найти там строчку «resample-method =» и заменить «speex-float-1» на «src-sinc-best-quality» пример: resample-method = src-sinc-best-quality

5) важно, не снимать комментарии ";" и уже в имеющихся строчках внести свои коррективы 5.1) в «default-sample-format =» заменить «s16le» на «floatXle» (где Х - 32 или 64 в зависимости от разрядности ОС) 5.2) в «default-sample-rate =» заменить «44100» на «88200», если позволяет звуковуха можно и поиграться выше 5.3) в «alternate-sample-rate» заменить «48000» на «96000», аналогом можно выше, если возможно пример: ;default-sample-format = float64le ;default-sample-rate = 88200 ;alternate-sample-rate = 96000

сохранить изменения в текстовом файле и закрыть его...

6) pulseaudio -k 6.1) pulseaudio --start

без каких либо танцев и перезагрузок можно играться с частотами (используя пункт «6» с подпунктом), если ваша звуковуха позволяет...

если ваш слух хочет эквалайзера, тогда вам в синаптик за ним...

Faust5000 ()

У меня на ноутбуке была такая же проблема, решил вот таким /etc/asound.conf (ну или ~/.asoundrc):

pcm.mydmix {
        type dmix
        ipc_key 1024
        slave {
                pcm "hw:1,0"
                period_time 0
                period_size 1024
                buffer_size 4096
        }
}

pcm.mydsnoop {
        type dsnoop
        ipc_key 1024
        slave {
                pcm "hw:1,0"
        }
}

pcm.myasym {
        type asym
        playback.pcm "mydmix"
        capture.pcm "mydsnoop"
}

pcm.!default {
        type plug
        slave.pcm "myasym"
        hint {
                show on
                description "myasym"
        }
}

ctl.!default {
        type hw
        card 1
}
Нулевое звуковое устройство - HDMI, первое - обычная звуковуха.

Ну или менять номера карт через /etc/modprobe.d, как было предложено выше.

anonymous ()
Ответ на: комментарий от anonymous

Я же уже ответил, что перемена карт местами в конфиге ничего не даёт.

Faust5000 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.