LINUX.ORG.RU

Linux не ставится на Celeron-M из-за ядра

 


1

1

Ноут на Celeron-M. Вполне живучий и отлично сохранившийся, ему еще пахать и пахать. До этого на нем стояла Вендовс-ИксПи.

Ставлю на него Linux с ядром 2.6.32-504.i686 - и малость ох..аю:

This kernel requires the following featers not present on the CPU: pae
Unable boot - please use a kernel appropriate fir your CPU

Это ж блин, с каких пор из 2.6 выкинули поддержку Celeron-M ???
И как теперь обойти эту пакость??

★★★★

Ответ на: комментарий от shooter93

Толку даже если соберу, засунуть в CD все равно не смогу.
И не бубунта, а CentOS 6

64-битное - с него и начал, тоже ядро заругалось, что проц только на 32.

chukcha ★★★★ ()
Последнее исправление: chukcha (всего исправлений: 1)
Ответ на: комментарий от chukcha

А ты с LiveCD чрутнись и установи custom-ядро. Ну, или дистрибутив меняй.

shooter93 ★★ ()
Ответ на: комментарий от chukcha

CentOS 6

http://wiki.centos.org/FAQ/CentOS6#head-d31388203ee81d3a47cb97bfc1c8206c3de85095

4. Why does CentOS-6 refuse to install on my i686 CPU?

Upstream has made the decision not to support non-PAE capable CPUs. If your CPU does not support PAE then when running the installer you will see the error:

This kernel requires the following features present on the CPU pae cx8

You can still install CentOS-5 but will not be able to run CentOS-6.

i-rinat ★★★★★ ()

Это ж блин, с каких пор из 2.6 выкинули поддержку Celeron-M ???

Никто не выкидывал из ядра. Это вопрос к мэнтейнерам твоего дистрибутива, которые собрали ядро, выкинув поддержку процов без PAE.

anonymous ()
Ответ на: комментарий от i-rinat

Т.е. эти красножопые педрилы приняли решение в шестом Центосе не поддерживать PAE??
Что они на этом сэкономили - несколько вшивых строк?!
Мля, ну уж точно: ((c) Клава, я ху.ю :((((

chukcha ★★★★ ()
Последнее исправление: chukcha (всего исправлений: 1)

Фигасебе заява! Я на 633 целерон накатывал дебиан стейбл. Ладно целерон, на via c3 он тоже ставился... при том что в виавском поделии набор инструкций даже не 586 (зато TDP 3w!)... Из софта только игрушка DF не взлетела - инструкции нет, остальное - работало. Такчто, думаю, что и CeleronM (эпохи pentium3) и celeronM (эпохи pentium4) должны поддерживать современные дистры с ядрами 486. Сам год назад ставил и успешно пользовал на celeronM 370 (если правильно запомнил модель).

Ubuntu пробовать не стоит - там 686 и pae - обязательны.

nekosargot ★★★ ()
Ответ на: комментарий от NiTr0

Наоборот, это ваш процессор решил не поддерживать PAE.

Хм. Интересный вброс для срача, типа что первично - яйцо или курица?
То есть процессор, или ось/ядро?
Думаю, тут двух мнений быть не может :))

chukcha ★★★★ ()
Ответ на: комментарий от NiTr0

Странно, что такие процессоры существуют. Получается, Celeron-M не совсем x86-совместимый. Эта фича ж вроде в Pentium 3 появилась, если не раньше, зачем надо было её выкидывать?

Harald ★★★★★ ()
Ответ на: комментарий от NiTr0

процессор решил не поддерживать PAE

Надо принудить его в судебном порядке снизить тактовую частоту передней шины и отобрать часть кеша до тех пор, пока он не изменит своего решения о поддержке PAE.

i-rinat ★★★★★ ()
Ответ на: комментарий от Polugnom

Скачал «пятерку», 5.11, пошел ставить.
Интересно, она будет быстрей «шестерки» работать, или наоборот?

Если что - ноут Samsung P28 Celeron-M.

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

у меня на таком celeron (1.7) debian семёрочка летала. Хотя ессно, никто не мешает скомпилять кастомное ведро. Из тогоже поколения (если не изменяет память ессноже! - был проц в винрарном EEE PC 701 4G... был и такой у меня... продал... жалею...)

Я правда этим страдал только при выходе 3.10/3.11/3.12 чисто из-за вкусностей в драйвере radeon... Для десктопа и новенького нетбука. Ничего страшного там нет. Сейчас в новых убунтовских вёдрах не работают USB порты - как бы тоже не пришлось компилять. Что странно: ноут новый, на haswell.

nekosargot ★★★ ()
Ответ на: комментарий от slyjoeh

загружается гораздо дольше, работает гораздо быстрее

Из-за ext3?

SystemRescueCD + Gentoo тебя спасет ;-)

И каким же образом оно спасет? :)

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

Из-за ext3?

Дольше из-за последовательной загрузки демонов. Работать быстрее из-за более старого софта. И не страдай херней, если нужна centos 6, то накати не pae ядро от федоры через chroot.

steemandlinux ★★★★★ ()

Celeron-M

Блин, как же так-то, поддержка PAE появилась aж в Pentium Pro, за несколько лет до того, как появился первый мобильный Селерон. Как они ухитрились?

Khnazile ★★★★★ ()
Ответ на: комментарий от steemandlinux

если нужна centos 6, то накати не pae ядро от федоры через chroot.

Знать бы, как это делается - научи! :)

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

И каким же образом оно спасет? :)

Это вопрос к мэнтейнерам твоего дистрибутива, которые собрали ядро, выкинув поддержку процов без PAE.

Придется ставить пятый. Но там обвеска наверное древняя как г.м....

Сам себе мэнтейнер. Ядро с нужными тебе фишками, обвес актуальной свежести. Если оно тебе реально надо - дерзай.

Waldo-de-Kard ★★ ()
Ответ на: комментарий от steemandlinux

Поставил «пятерку». Но что-то тут не в ладах - выдает при загрузке примерно такое:

1023MB HIGHMEM available.
896MB LOWMEM available.
found SMP MP-table at 000f7730
Memory for crash kernel (0x0 to 0x0) notwithin permissible range
SMP mptable: bad signature [0x0]!
BIOS bug, MP table errors detected!...
... disabling SMP support. (tell your hw vendor)


- к чему бы это? :-O

chukcha ★★★★ ()
Ответ на: комментарий от Deleted

Поставил «пятерку». Но что-то тут не в ладах - выдает при загрузке примерно такое:

1023MB HIGHMEM available.
896MB LOWMEM available.
found SMP MP-table at 000f7730
Memory for crash kernel (0x0 to 0x0) notwithin permissible range
SMP mptable: bad signature [0x0]!
BIOS bug, MP table errors detected!...
... disabling SMP support. (tell your hw vendor)



- к чему бы это? :-O

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

Железо первично. Banias - не поддерживают PAE (вернее, вроде как поддерживают, но в CPUID об этом молчат). А значит, с PAE ядром работать не будут. О чем ядро и говорит вам английским по черному.

А вот не-PAE ядро на PAE железке будет работать на ура.

NiTr0 ★★★★★ ()
Ответ на: комментарий от Harald

А зачем PAE на машине, где никогда 4 гига не будет? :)

NiTr0 ★★★★★ ()
Ответ на: комментарий от chukcha

Ну написано же - MP table не нравится ему. Биос осьминоги писали. Может в каких-то ядрах это обходится костылями.

Если камень однодерный - забить.

NiTr0 ★★★★★ ()
Ответ на: комментарий от Harald

Странно, что такие процессоры существуют. Получается, Celeron-M не совсем x86-совместимый. Эта фича ж вроде в Pentium 3 появилась, если не раньше, зачем надо было её выкидывать?

не совсем x86-совместимый

Что ты несешь? Ты хоть понимаешь, что такое «x86-совместимый»?

anonymous ()
Ответ на: комментарий от NiTr0

Забавно, кстати, я как-то на таком ноуте проц ставил новый, вместо старого целерона м - пентиум м, так вот после замены целерона на пень начало ругаться на отсуствие пае, хоть проци мощней и новей.

miXel ()
Ответ на: комментарий от NiTr0

Если камень однодерный - забить.

Ну оно так где-то и получается: после выдачи этого краша система долго думает, а потом грузится как ни в чем не бывало ;)

chukcha ★★★★ ()

Боже, да купи уже виндоус. Как не зайду на форум — у тебя постоянно что-то не работает, что-то отламалось, что-то тебя возбуждает.

Зачем себя так мучать?

anonymous ()
Ответ на: комментарий от chukcha

М-да. С Центосом-5 получилась полная жжопа:
он хоть стал и кае-как запускается, но Skype на него никак не стает, Firefox сходу заверещал чисто по-английски и никакие известные припарки ему не помогли.
И если представить, сколько еще предстоит долботни с установкой нового софта, то становится ясно, что с «пятеркой» номер не прошел.

То, что раньше так любезно предложили - http://www.digitage.co.uk/digitage/library/linux/installing-centos-6-4-on-non...
содержит столько утомительных фрикций, что не тянет, наоборот, в дремоту вганяет -я столько не вкуриваю.

Блин, мерзкие краснозадые со своими гнусными фичами - всю обедню сорвали - я надеялся за один вечер систему поставить! :evil

Уж лучше Дебиана поставить, что ли...
Или поискать не-PAE ядро, всунуть его в эту систему, а потом попробовать обновить ее до «шестерки»?
Чуствую, гемор будет еще тот.
Короче, весь в раздумиях: налево пойдешь - ...

Как не зайду на форум — у тебя постоянно что-то не работает, что-то отламалось, что-то тебя возбуждает.

Так на то и форум! Я же не пишу, сколько мне удается успешно сделать, не обращаясь на форум :) Посмотри на других на форуме - то же самое.

chukcha ★★★★ ()
Последнее исправление: chukcha (всего исправлений: 1)
Ответ на: комментарий от chukcha

Давай еще раз проясним:

--forcepae собщает инсталлятору, чтобы он не пользвался pae
- установка соответственно проходит без него, т.е. у богим процом
- затем нужно в систему закинуть ядро с поддержкой pae

- так?

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

Нет, не так. Найди способ внимательно прочитать статью. forcepae означает ложить болт на то, что процессор сообщает, что у него PAE нет, хотя в действительности есть (особенность пентиум-м и селерон-м).

Или можешь поставить 12.04. Там проще поставить без PAE. Например, так:

http://www.webupd8.org/2012/05/how-to-install-ubuntu-1204-on-non-pae.html

Или можешь поставить Lubuntu:

https://help.ubuntu.com/community/Lubuntu-fake-PAE

Короче, учи английский или меняй линукс на виндоус.

Да, и в любом случае подвязывай в сентос — в убунту или дебиане все на порядок проще, без пафосности, большое сообщество и огромные репозитории.

anonymous ()
Ответ на: комментарий от anonymous

Да понимаешь, все никак не перейду на дебиан, привычки красной шляпы пока сильно довлеют.
Особенно привычка к yum, который оказывается в некоторых случаях получше, чем хваленый apt-get ( Как удалить связанную группу пакетов в Debian ? )

А сейчас мне нужно этот ноут побыстрее отдать, не до сантиментов.
Ладно, подскажи еще: с Центосом-6, в котором прекратили поддержку PAE, такой трюк с ключом --forcepae не пройдет?

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

Понятия не имею.

Я бы тебе советовал не дебиан (знаний у тебя мало), а убунту. Именно для этого бука - лубунту (или xubuntu — но в ней немного ковырнуть надо будет). И лучше 12.04.

Успехов!

Да, и меньше слушай троллей на лоре — yum — прибацнутое дерьмо в сравнении с apt-get, а там еще и aptitude, а в графическом режиме synaptic.

anonymous ()
Ответ на: комментарий от anonymous

Извини, но эту шатлвортовскую выскочку - убунту - да никогда!
Возненавидел ее так же, как винду, уж очень много гадостей она миру линукс принесла.
Только чисто расовый Дебиан, и не на копейку меньше!

Что касается yum - тут не троли, тут мой собственный опыт сказывается.
Ты видимо, не прочел ссылку, которую я тебя скинул.
Меня yum устраивает на все 100%. И ничего больше к нему не требуется.
Тогда зачем мне всякие апты, «которые лучше»? Мне и с yum неплохо живется ;)

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

Ну тогда и решай свои проблемы сам, раз совет спрашиваешь, а потом не слушаешь. Yum в помощь.

Извини, но эту шатлвортовскую выскочку - убунту - да никогда!
Возненавидел ее так же, как винду, уж очень много гадостей она миру линукс принесла.
Только чисто расовый Дебиан, и не на копейку меньше!

Да — мне кажется, что у тебя мозги напрочь засраны лоровской бредятиной. И разговариваешь ты дурацкими лоровскими лозунгами.

Успехов!

anonymous ()
Ответ на: комментарий от anonymous

Никто мне ничего не засирал, я сам кому угодно их засру :))
Наоборот, мои точки зрения чаще всего идут вразрез с тем, что навязывают, в том числе и на ЛОРе.
Много чем мне не нравится Убунта, но это длинная тема, и никто никого не убедит, проверено же.

А за советы, конечно - спасибо!

chukcha ★★★★ ()
Последнее исправление: chukcha (всего исправлений: 1)
Ответ на: комментарий от Polugnom

Суровый красношапочный ынтерпрайз.

PAE появился в 1995, RHEL6 появился в 2010. Ещё пожалуйся, что он на PDP-11 не работает. Кто ж виноват, что у какого-то инженегра в интеле крышу сорвало —

The Banias family processors internally support PAE but do not show the PAE support flag in their CPUID information;

redgremlin ★★★★★ ()
Ответ на: комментарий от chukcha

Да понимаешь, все никак не перейду на дебиан, привычки красной шляпы пока сильно довлеют.

А причём тут дебиан/убунту/rhel, когда forcepae - параметр для ядра?

с Центосом-6, в котором прекратили поддержку PAE

Ты реально идиот или так шутишь до сих пор?

Deleted ()
Последнее исправление: Deleted (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.