LINUX.ORG.RU

Нет доступа к роутеру после сброса через OpenWrt Failsafe

 


0

1

Имеется роутер TP-Link TL-WR841ND с прошивкой OpenWRT и неизвестными настройками.

Произвожу сброс по инструкции: http://wiki.openwrt.org/doc/howto/generic.failsafe
1) Включаю кабель от коммутатора локальной сети в WAN-порт роутера.
2) Настраиваю на компьютере IP 192.168.1.X.
3) При включении жду начала мерцания индикатора SYS и нажимаю кнопку WPS/RESET, после чего индикатор SYS начинает мерцать очень быстро.
4) Логинюсь по telnet на 192.168.1.1.

root@(none):/# mount_root
switching to jffs2
root@(none):/# passwd
Changing password for root
New password:
Bad password: too weak
Retype password:
Password for root changed by root
root@(none):/# uci get network.lan.ipaddr
192.168.1.1
root@(none):/# firstboot
firstboot has already been run
jffs2 partition is mounted, only resetting files
root@(none):/# mtd -r erase rootfs_data
Unlocking rootfs_data ...
Erasing rootfs_data ...
Rebooting ...

После перезагрузки 192.168.1.1 не пингуется ни с LAN, ни c WAN-интерфейса. Еще раз пробую загрузиться в failsafe-режиме и пробую другой способ сброса:

root@(none):/# mount_root
switching to jffs2
root@(none):/# rm -rf /overlay/*
root@(none):/# reboot -f

Но это тоже не дает результата. Что еще можно проверить для восстановления работы роутера?

usb2ttl и вперед.

если нету, залей на него свежий транк через sysupgrade.

ktk ★★★★ ()

Штатный телепат в отпуске. ip a - что говорит?

NiTr0 ★★★★★ ()

Было как-то такое, что делал уже не помню. Попробуй последовательность бубнов:
1. проверь версию wrt (и перекачай), номер аппаратной версии, перечитай раздел по этой железке внимательно и вдумчиво не менее 10 раз, на всех языках.
2. вынеси железку на холод и дай остыть минут 10, после включения смотри - сразу отвалится или через некоторое время, может быть и перегрев с зависанием
3. Загрузится фейлсейф, ставь люську и перешей по новой
4. может быть непрошивабельной, мне попадались такие экземпляры (может в них флешь местами битый - это мой домысел, хз, что на самом деле), не шьются, работают только с родной прошивкой.

handbrake ★★★ ()

Убери коммутатор, подключи напрямую, по идеи роутер сам должен дать dhcp, попробуй разные порты (так-то тебе нужен lan1 по хорошему), проверь кабель. (хотя кабель нужно проверять сначала.). Ну и попробуй сбросить через нормальный ресет.

anonymous_sama ★★★★★ ()
Последнее исправление: anonymous_sama (всего исправлений: 2)

Всем спасибо за ответы. Роутер стал окликаться после того, как некоторое время полежал выключенным.

alxdon-rs ()

Ошибочка. Роутеру вылеживаться не требуется.
Провел серию экспериментов со сбросом через OpenWrt Failsafe.
В некоторых случаях после перезагрузки роутер откликается по 192.168.1.1, но чаще всего - нет.
Лечится так: подключаем компьютер напрямую в LAN1 роутера, пинг тут же появляется, даже без DHCP на компьютере. После чего можно переподключить роутер и компьютер уже через коммутатор, пинг сохраняется.

У кого-нибудь есть объяснение этому?

alxdon-rs ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.