LINUX.ORG.RU
ФорумAdmin

OpenWRT - не работает интернет

 , , , ,


0

1

Установил openwrt v21.02.2 на роутер asus rt-n56u (a1). Прошивка встала сразу, а вот интернет работать не хочет. Провайдер мой работает по PPPoE. Что самое странное, так это то, что роутер к нему подключился, получил ip и успешно выполняет ping 8.8.8.8, а вот в браузере выполнять запросы не получается.

На пк (windows 10), который подключен по lan к роутеру, индикатор сети в трее показывает, что сеть подключена к интернету. IPv4 адрес пк установлен статично 192.168.1.2, маска 255.255.255.0, gateway 192.168.1.1

На роутере горит только лампа напротив питания. WAN, LAN, wi-fi не горят.

Не знал что прикреплять, в настройках сетей я ноль, поэтому говорите что нужно, если я этого не предоставил.

Выполнил ifconfig через putty по ssh:

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 32:85:A9:6A:B7:01
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: 2a02:2698:5022:9921::1/64 Scope:Global
          inet6 addr: 2a02:2698:5022:990d::1/64 Scope:Global
          inet6 addr: fe80::3085:a9ff:fe6a:b701/64 Scope:Link
          inet6 addr: fd32:58a0:3cad::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10206 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4863 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:927154 (905.4 KiB)  TX bytes:4303693 (4.1 MiB)

eth0      Link encap:Ethernet  HWaddr 30:85:A9:6A:B7:01
          inet6 addr: fe80::3285:a9ff:fe6a:b701/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13174 errors:0 dropped:2 overruns:0 frame:0
          TX packets:7207 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1856882 (1.7 MiB)  TX bytes:4592118 (4.3 MiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr 32:85:A9:6A:B7:01
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10207 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4863 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:927200 (905.4 KiB)  TX bytes:4303693 (4.1 MiB)

eth0.2    Link encap:Ethernet  HWaddr 30:85:A9:6A:B7:00
          inet6 addr: fe80::3285:a9ff:fe6a:b700/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2806 errors:0 dropped:69 overruns:0 frame:0
          TX packets:1218 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:672060 (656.3 KiB)  TX bytes:135689 (132.5 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1095 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1095 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:97480 (95.1 KiB)  TX bytes:97480 (95.1 KiB)

pppoe-pppoe Link encap:Point-to-Point Protocol
          inet addr:100.67.39.198  P-t-P:10.85.255.126  Mask:255.255.255.255
          inet6 addr: fe80::f12d:49d2:cfa6:b89a/128 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:202 errors:0 dropped:0 overruns:0 frame:0
          TX packets:266 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:44766 (43.7 KiB)  TX bytes:24105 (23.5 KiB)

route:

root@OpenWrt:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.85.255.126   0.0.0.0         UG    0      0        0 pppoe-pppoe
10.85.255.126   *               255.255.255.255 UH    0      0        0 pppoe-pppoe
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan

Содержимое файла /etc/config/network:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd32:58a0:3cad::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config device
        option name 'eth0.1'
        option macaddr '32:85:a9:6a:b7:01'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr '30:85:a9:6a:b7:00'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 8t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 8t'

config interface 'pppoe'
        option proto 'pppoe'
        option device 'eth0.2'
        option username 'login'
        option password 'pass'
        option ipv6 'auto'

ping:

root@OpenWrt:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=109 time=53.670 ms
64 bytes from 8.8.8.8: seq=1 ttl=109 time=53.699 ms
64 bytes from 8.8.8.8: seq=2 ttl=109 time=53.556 ms
64 bytes from 8.8.8.8: seq=3 ttl=109 time=53.531 ms
64 bytes from 8.8.8.8: seq=4 ttl=109 time=53.754 ms
64 bytes from 8.8.8.8: seq=5 ttl=109 time=53.566 ms
64 bytes from 8.8.8.8: seq=6 ttl=109 time=53.594 ms
64 bytes from 8.8.8.8: seq=7 ttl=109 time=53.573 ms
64 bytes from 8.8.8.8: seq=8 ttl=109 time=53.660 ms
^C
--- 8.8.8.8 ping statistics ---
9 packets transmitted, 9 packets received, 0% packet loss
round-trip min/avg/max = 53.531/53.622/53.754 ms

Ну, Интернет на роутере у тебя очевидно есть.

вот в браузере выполнять запросы не получается.

Что с DNS на роутере? Что выдает ping google.com через SSH с самого роутера?

На роутере горит только лампа напротив питания. WAN, LAN, wi-fi не горят.

Могут отсутствовать или быть не настроены драйвера для LED. Проблема больше косметическая, но неприятная - иногда статус линков желательно видеть наглядно.

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 2)
Ответ на: комментарий от Pinkbyte

Я в настройках сетевого адаптера на пк поставил галочку напротив автоматической настройки. Интернет на пк по lan заработал. Не понимаю чем его не устраивает свободный адрес 192.168.1.2 (в сети нет других устройств с таким адресом).

Что выдает ping google.com через SSH с самого роутера?

Я пробовал так тоже (когда еще запросы в браузере не работали) и это работало, но только с роутера. Так же я пробовал с винды пинговать: 8.8.8.8 тоже работало, а вот google.com нет. До сих пор не понимаю в чем проблема и что не устраивало.

Могут отсутствовать или быть не настроены драйвера для LED.

Это нужно на офф сайте openwrt искать к моему роутеру?

kennydzzze ()
Ответ на: комментарий от AlexVR

Я симулировал свою проблему снова.

Вот tracert из под винды:

tracert -d 8.8.8.8

Tracing route to 8.8.8.8 over a maximum of 30 hops

  1    <1 ms    <1 ms    <1 ms  192.168.1.1
  2     1 ms     1 ms     1 ms  10.85.255.126
  3     1 ms     1 ms     1 ms  109.194.88.18
  4    61 ms    46 ms    46 ms  72.14.215.165
  5    47 ms    47 ms    46 ms  72.14.215.166
  6    46 ms    46 ms    46 ms  142.251.53.67
  7    45 ms    45 ms    44 ms  108.170.250.66
  8    54 ms    54 ms    54 ms  142.250.238.214
  9    53 ms    53 ms    53 ms  142.250.233.0
 10    53 ms    53 ms    53 ms  216.239.57.229
 11     *        *        *     Request timed out.
 12     *        *        *     Request timed out.
 13     *        *        *     Request timed out.

Вот firewall:

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'pppoe'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'REJECT'
        option enabled 'false'

config include
        option path '/etc/firewall.user'

kennydzzze ()
Ответ на: комментарий от kennydzzze

Я в настройках сетевого адаптера на пк поставил галочку напротив автоматической настройки. Так же я пробовал с винды пинговать: 8.8.8.8 тоже работало, а вот google.com нет.

При ручной настройке надо не только адрес прописывать, то и ip dns серверов - те же 8.8.8.8, 1.1.1.1 или ip самого роутера.

zent ()
Ответ на: комментарий от zent

Вы правы. Я их не вписывал. Думал это необходимо только тогда, когда dns на роутере установлен вручную и он отличается от «дефолтных». Сейчас поставил 8.8.8.8 и 8.8.4.4 - заработало…

Осталось заставить работать wifi… Почему-то из четырех устройств ее видит только iphone, но не может подключиться. Остальные 2 (андроид) и ноут (линукс) не видят вообще. Погуглю пока, т.к. еще не вникал в проблему особо.

kennydzzze ()
Ответ на: комментарий от kennydzzze

В общем, из-за того, что у меня на роутере 2 режима (2.4ghz и 5ghz), по отдельности они почему-то не хотят работать, а только вместе. Т.е. если включен только 2.4, то wifi нигде не видно, кроме яблока (но подключится так же нельзя). Но если запустить оба режима, то на всех устройствах они сразу обнаруживаются и работают. Странно…

kennydzzze ()
Ответ на: комментарий от kennydzzze

Сейчас поставил 8.8.8.8 и 8.8.4.4 - заработало…

Достаточно было поставить 192.168.1.1

AlexVR ★★★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.