LINUX.ORG.RU
решено ФорумAdmin

OpenWRT и провайдерская локальная сеть


0

1

Здрастуйте. Имеется роутер ТL-741 и Linux OpenWrt 2.6.39.4 #1 Wed Dec 28 06:55:37 MST 2011 mips GNU/Linux

Провайдер предоставляет соединение по L2TP, локальная сеть - 10.х.х.х. Проблема в том, что не открываются локальные сайты, которые пингуются и открываются по ip.

/etc/config/network

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth0'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.1'
        option 'netmask' '255.255.255.0'

config 'interface' 'wan'
        option 'ifname' 'eth1'
        option 'proto' 'dhcp'
        option reqopts 'staticroutes'

config 'switch'
        option 'name' 'eth0'
        option 'reset' '1'
        option 'enable_vlan' '1'

config 'switch_vlan'
        option 'device' 'eth0'
        option 'vlan' '1'
        option 'ports' '0 1 2 3 4'

config 'interface' 'l2tp'
        option 'ifname' 'ppp0'

/etc/config/firewall

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        option network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name             wan
        option network          'wan'
        option network          'wan l2tp'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1


config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option network          'wan'
        option network          'wan l2tp'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1


config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

ifconfig

 
br-lan    Link encap:Ethernet  HWaddr F8:D1:11:5C:BA:93  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1392210 errors:0 dropped:125 overruns:0 frame:0
          TX packets:1948526 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:82428131 (78.6 MiB)  TX bytes:2435105445 (2.2 GiB)

eth0      Link encap:Ethernet  HWaddr F8:D1:11:5C:BA:93  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:5 

eth1      Link encap:Ethernet  HWaddr F8:D1:11:5C:BA:95  
          inet addr:10.99.53.98  Bcast:10.99.53.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1986026 errors:0 dropped:11963 overruns:0 frame:0
          TX packets:1401941 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2519253018 (2.3 GiB)  TX bytes:156274850 (149.0 MiB)
          Interrupt:4 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:22 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:4018 (3.9 KiB)  TX bytes:4018 (3.9 KiB)

mon.wlan0 Link encap:UNSPEC  HWaddr F8-D1-11-5C-BA-94-00-47-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17060 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32 
          RX bytes:1062307 (1.0 MiB)  TX bytes:0 (0.0 B)

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:188.163.79.19  P-t-P:94.27.124.12  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1460  Metric:1
          RX packets:1953028 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1395820 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:2408400297 (2.2 GiB)  TX bytes:83225614 (79.3 MiB)

wlan0     Link encap:Ethernet  HWaddr F8:D1:11:5C:BA:94  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1392459 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1949039 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32 
          RX bytes:101946747 (97.2 MiB)  TX bytes:2474132129 (2.3 GiB)

Маршрутизация

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         94.27.124.12    0.0.0.0         UG    0      0        0 ppp0
10.0.0.0        10.99.53.1      255.0.0.0       UG    0      0        0 eth1
10.99.53.0      0.0.0.0         255.255.255.0   U     0      0        0 eth1
94.27.124.12    0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

Проблема в том, что не открываются локальные сайты, которые пингуются и открываются по ip.

Локальные где? У тебя дома или в локалке провайдера? А по какому имени ты их хочешь открывать? По доменному? Почему тогда мы не видим /etc/resolv.conf? И какой DNS-сервер обслуживает имена в этой локальной сети?

anonymous ()
Ответ на: комментарий от anonymous

В локалке провайдера, DNS там тоже 10.x.x.x. Открывать по доменному имени конечно.

В роутере такой resolv.conf:

search lan
nameserver 127.0.0.1

resolv.conf.auto:

nameserver 10.10.13.2
nameserver 10.10.10.2
search beeline.ua

В машинах, которым он раздает инет:

domain lan
search lan
nameserver 192.168.1.1

Gunnerua ()
Ответ на: комментарий от Gunnerua

resolv.conf.auto:

nameserver 10.10.13.2 nameserver 10.10.10.2

10.10.13.2 это твой 10.x.x.x? Так впиши его в /etc/resolv.conf средствами веб-интерфейса или ручками. Или разберись почему после дозвона к провайдеру resolv.conf.auto не замещает resolv.conf или не становится ему символической ссылкой.

anonymous ()
Ответ на: комментарий от anonymous

Вписал. На роутере пингуется, на ноуте не пингуется. Гуглил дальше и нашел это. Если кратко, то в OpenWrt есть только один WAN. Автор предложил свой велосипед, но мне не помогло.

Вобщем нашел костыльное решение: заставить роутер выдавать подключаемым машинам DNS в виде 10.10.13.2 и 10.10.10.2, тоесть такой себе обходной путь, но тогда все работает.

Gunnerua ()
Ответ на: комментарий от Gunnerua

А причём тут «один WAN»? Это провайдер нужные DNS не отдаёт. Вообще такого рода косяки связаны либо с кривым маршрутом, либо с днс, либо с настройкой файрволла. Всё правится. На крайняк никто не мешает прописать нужные скрипты в /etc/init.d или /etc/hotplug.d

alegz ★★ ()
Ответ на: комментарий от alegz

При том, что роутер может раздавать только L2TP, провайдер же отдает все правильно. В фаерволе настройки для wan и l2tp те же, локальный маршрут есть.

Gunnerua ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.