LINUX.ORG.RU

Intel HD4000 no h/w 3D

 , , ,


0

1

Добрый день! После очередного обновления Arch Linux перестало работать 3D на графическом ускорителе Intel HD4000 [8086:0162]. В /var/log/Xorg.0.log:

[     6.524] (WW) intel(0): [DRI2] Direct rendering is not supported when VGA arb is necessary for the device
[     6.524] (==) intel(0): Backing store enabled
[     6.524] (==) intel(0): Silken mouse enabled
[     6.524] (II) intel(0): Initializing HW Cursor
[     6.635] (II) intel(0): Use GLAMOR acceleration.
[     6.635] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[     6.637] (==) intel(0): DPMS enabled
[     6.637] (==) intel(0): Intel XvMC decoder enabled
[     6.637] (II) intel(0): Set up textured video
[     6.637] (II) intel(0): Set up textured video using glamor
[     6.637] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[     6.637] (II) intel(0): DRI2: Failed
[     6.637] (II) intel(0): DRI3: Disabled
[     6.637] (==) intel(0): hotplug detection: "enabled"
[     6.653] (--) RandR disabled
[     6.653] (II) Found 3 VGA devices: arbiter wrapping enabled
[     6.659] (II) AIGLX: Screen 0 is not DRI2 capable
[     6.659] (EE) AIGLX: reverting to software rendering
[     6.707] (II) AIGLX: Loaded and initialized swrast

Версии пакетов: linux-libre 3.14.9-99, xf86-video-intel 2.99.912-1, intel-dri 10.2.2-1, libva-intel-driver 1.3.2-1, mesa 10.2.2-1, mesa-libgl 10.2.2-1

Аппаратное обеспечение: ASRock Z77 Extreme 6, Intel Core i7 3770, AMD Radeon 5450 (для проброса в ВМ), AMD Radeon 6450 (для проброса в ВМ)

Случаем не после обновления xf86-video-intel ?

Medar ★★★★★ ()

https://bbs.archlinux.org/viewtopic.php?pid=1373872

Это не интел, но проблема схожая.

MasterSplinter777
Master Splinter

Ну-ну :)

Ставь Gentoo и тогда ты будешь контролировать все изменения, происходящие в твоей системе, а не та арчешколота в мейнтейнерах. Вот тогда будет ясно Мастер ты или нет...

Deleted ()
Ответ на: комментарий от Deleted

Ничего не мешает и в Arch ставить пакеты через AUR. Gentoo - не совсем подходит для тех задач, которые я выполняю.

P.S.: Установка *-git версий вышеописанных пакетов не решила проблему.

MasterSplinter777 ()
Ответ на: комментарий от wakuwaku

Толсто

Ты просто не в курсе. С гентой можно быть независимым от любой школоты в мейнтейнерах. Знаешь ведь как бывает, новый пакет может оказаться собранным без нужной особенности, например без glamour. Пересобирать пакеты со своей фичей особенно в бинарных роллинг-дистрибутивах каждый раз при обновлении не очень-то и удобно.

Deleted ()
Ответ на: комментарий от MasterSplinter777

Gentoo - не совсем подходит для тех задач, которые я выполняю.

Чем же арч так выделяется? Машинка ведь достаточно мощная, ставить на нее бинарщину это, я считаю, тяжкий грехъ.

Deleted ()
Ответ на: комментарий от Deleted

Быть полностью независимым невозможно, Говорю как гентовод уже лет 5. А пересборку пакетов с автоматическим наложением патчей при обновлении можно организовать и в арчике.

wakuwaku ★★★★ ()
Ответ на: комментарий от Deleted

Не надо тратить тонны времени на сборку из исходников всего и вся. Развернул базовую систему и ставишь из AUR + правка PKBUILD только того, что действительно по каким-то причинам не удовлетворяет твои потребности или собрано с неправильными зависимостями.

MasterSplinter777 ()
Ответ на: комментарий от wakuwaku

Быть полностью независимым невозможно

А полностью и не надо, указал нужные юзы, закинул заведомо рабочие версии критических пакетов в свой оверлей.

Ну в общем, чего мне объяснять гентоводу, ты и сам все знаешь.

Deleted ()
Ответ на: комментарий от MasterSplinter777

Не надо тратить тонны времени на сборку из исходников всего и вся.

Толсто.

Deleted ()
Ответ на: комментарий от Deleted

Отлично, т.е. не обновлять. Вот и я о том. При этом легко и непринуждённо могут сломать зависимости этого ебилда, а чтобы все нужные пакеты обновлять вручную необходимо слишком много лишнего времени (особенно учитывая, что это в большинстве случаев лишено смысла).

wakuwaku ★★★★ ()

If your Xorg log shows that dri is disabled due to VGA arbitration, then try enabling KMS.

А с бородатых времен оно включено по умолчанию. Может в device drivers при сборке забыли галку поставить? Попробуй явно задать i915.modeset=1 ну или какой-нибудь вариант отсюда:

https://wiki.archlinux.org/index.php/Intel_(Русский)#KMS_.28Kernel_Mode_Setti...

Dude ()
Ответ на: комментарий от steemandlinux
$ lsmod | grep kms
drm_kms_helper         35592  1 i915
drm                   239291  3 i915,drm_kms_helper
i2c_core               25208  6 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit,videodev
MasterSplinter777 ()

Написано же:

(WW) intel(0): [DRI2] Direct rendering is not supported when VGA arb is necessary for the device

Небось патчил ядро на предмет активации VGA arbitration для i915?

Deleted ()
Ответ на: комментарий от Deleted

Да, Вы правы. Патчил. Сейчас проверю работоспособность 3D с ядром по-умолчанию.

MasterSplinter777 ()

Intel

no 3D

И что не так?

anonymous ()
Ответ на: комментарий от Marlboro

Этой чурке

Сам такой. Ты расист?

с завышенным ЧСВ

Где? Ты еще и наркоман что ли?

после недели секаса с гентой

4.2. Since 2011

разорвал пукан Arch :)

Ты все неправильно понял. Я хотел знать, в чем смысл ставить вечно ломающийся бинарный арч вместо более гибкой стабильной генты. Только и всего. А уж bleeding-edge рач только насмешку вызывает :)

Deleted ()

Выяснил причину

Проблема крылась в наличии нескольких GPU. Даже после добавления устройств в pci-stub и blacklist radeon ОС считала основной видеокартой ту, которая находится на шине 1:00.00 или 2:00.0.

Теперь выясняю, каким образом можно поменять приоритет GPU на ранней стадии инициализации ОС.

MasterSplinter777 ()
Ответ на: комментарий от Deleted

Нет. Просто бесят люди вроде тебя (Арчеводы=школота), которые типа знают все и хаят остальное. Выучил немного генту, а уже пипец какой крутой. Не те ценности у тебя.

Marlboro ()
Ответ на: комментарий от anonymous

Да нет. Просто гуглил темы, нашлась своя - решил заглянуть, да и эта вкладка была открытой...
Единственный более-менее толковый ман сделали гентушники на старую модель zte. Вот тут я и подумал, если крутой гентушник, то сделает )) а так, он просто балабол малолетний.

Marlboro ()
Ответ на: комментарий от Marlboro

хаят все остальное

А арчик типа не такой, да...

Выучил немного генту, а уже пипец какой крутой

4.2. Тебе показалось. Нифига я не крутой :(

Deleted ()
Ответ на: комментарий от Marlboro

А ежели не школота, то заставь работать ZTE MF667

А если у меня нет сие девайса, то я студентоид?

Deleted ()
Ответ на: комментарий от Marlboro

Единственный более-менее толковый ман сделали гентушники на старую модель zte. Вот тут я и подумал, если крутой гентушник, то сделает )) а так, он просто балабол малолетний.

От билайна что ли? Ну я конечно балабол, если чип такой дерьмовый, что каждые пять минут обрывает коннект. В итоге запорол его прошивкой. Не прошилось - кирпич. Ну и ладно :)

Deleted ()
Ответ на: комментарий от anonymous

Тебя второй час не отпускает от этого клоуна?

Да мы просто тусуемся, ну чего ты, а?

Deleted ()
Ответ на: комментарий от Marlboro

ZTE MF667

Кусок говна от полосатого филиала майкрософт?

AlexVIP ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.