LINUX.ORG.RU

Thinkpad T520 и кнопка отключения микрофона.

 , , , ,


1

1

Добрый день! Продолжаю настройку Thinkpad T520 и Fedora 20. Чтобы все нормально было с выводом видео на плазму через DisplayPort, переключил в BIOS настройки видео с Optimus на дискретную графику NVidia. Также пришлось прописать nox2apic в параметры ядра, чтобы все нормально грузилось (описание проблемы). Соответственно, теперь имею одно видео устройство и два аудио:

$ lspci | grep -e VGA -e Audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [Quadro NVS 4200M] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF119 HDMI Audio Controller (rev a1)
Вывод звука работает и на том, и на другом. Однако, отвалилась возможность использования клавиши отключения звука микрофона.
При использовании «Optimus» Gnome 3 распознает эту клавишу: загорается красный светодиод, выводится индикатор, отключается звук.
При использовании дискретной графики, ноль реакции на нажатие. Однако, если зайти в PulseAudio Volume Control -> Input Devices, и там нажать кнопку «Mute Audio», то микрофон отключается, а индикатор загорается.
Подскажите в какую тсорону копать, чтобы настроить работу этой клавиши в режиме дискретной графики?

Навряд ди кто-то здесь сможет помочь. Тем более, что это просто мелочь на фоне того, что оставшееся железо завелось OK.

carasin ★★★★★ ()

Отдельно повесить на эту клавишу мьют не пробовал?

anonymous ()
Ответ на: комментарий от anonymous

Она (кстати, как и ThinkVantage) не распознается. Я пробовал в Gnome Control Center задать на них действия - не срабатывают. Xev тоже ничего не показывает.

exorcist ()

Попробуй

$ cat /etc/tmpfiles.d/thinkpad.conf
w /sys/devices/platform/thinkpad_acpi/hotkey_mask - - - - 0xffffffff

kernelpanic ★★★★★ ()
Ответ на: комментарий от kernelpanic

Спасибо, прогресс появился. Если выполняю в терминале:

su -c 'echo 0xffffffff > /sys/devices/platform/thinkpad_acpi/hotkey_mask'
то сразу после этого начинают работать и клавиша отключения микрофона, и клавиша ThinkVantage. Однако, на файл /etc/tmpfiles.d/thinkpad.conf никакой реакции. После перезаргузки значение остается 0x0000ffbf.
$ ls -l /etc/tmpfiles.d/thinkpad.conf 
-rw-r--r--. 1 root root 69 апр 27 19:09 /etc/tmpfiles.d/thinkpad.conf
$ cat /etc/tmpfiles.d/thinkpad.conf 
w /sys/devices/platform/thinkpad_acpi/hotkey_mask - - - - 0xffffffff
Почему может игнорироваться /etc/tmpfiles.d/thinkpad.conf?

exorcist ()
Ответ на: комментарий от exorcist

Пробовал также делать thinkpad.service:

$ cat /usr/lib/systemd/system/thinkpad.service 
[Unit]
Description=A small trick to activate Thinkpad extra keys
After=systemd-user-sessions.service

[Service]
ExecStart=/usr/bin/echo '0xffffffff' > /sys/devices/platform/thinkpad_acpi/hotkey_mask

[Install]
WantedBy = graphical.target
Ничего не изменилось. Пробовал размещать
/usr/bin/echo '0xffffffff' > /sys/devices/platform/thinkpad_acpi/hotkey_mask
в /etc/rc.d/rc.local (chmod +x ему тоже делал). Результат тот же.

В /var/log/messages сыплется информация такого вида:

Apr 27 21:36:03 t520 kernel: thinkpad_acpi: setting the hotkey mask to 0xffffffff is likely not the best way to go about it
Apr 27 21:36:03 t520 kernel: thinkpad_acpi: please consider using the driver defaults, and refer to up-to-date thinkpad-acpi documentation
Apr 27 21:36:03 t520 kernel: thinkpad_acpi: asked for hotkey mask 0xffffffff, but firmware forced it to 0x07ffffff

exorcist ()
Ответ на: комментарий от exorcist

Почему может игнорироваться /etc/tmpfiles.d/thinkpad.conf?

Возможно в этот момент у тебя еще не загружен модуль thinkpad_acpi.

kernelpanic ★★★★★ ()
Ответ на: комментарий от kernelpanic

Таким образом, получается, что мне надо либо отследить, когда загружается этот модуль (и запускать thinkpad.service после), либо вставить эту строчку в скрипт запуска X'ов (или gdm). Вечером протестирую.

exorcist ()
Ответ на: комментарий от exorcist

Что-то совсем печально. Пробовал создать:

$ cat /etc/modprobe.d/thinkpad_acpi.conf
options thinkpad_acpi hotkey=0x07ffffff
- игнорируется. Пробовал вставить в /usr/bin/startx
/usr/bin/echo '0x07ffffff' > /sys/devices/platform/thinkpad_acpi/hotkey_mask
- не помогает.

exorcist ()
Ответ на: комментарий от exorcist

Еще пробовал:

$ cat /etc/X11/xinit/xinitrc.d/thinkpad-acpi.sh 
#!/bin/sh
/usr/bin/echo '0x07ffffff' > /sys/devices/platform/thinkpad_acpi/hotkey_mask
и на это нет никакой реакции. Однако, как и в самом начале, если выполнить этот файл уже после логина в терминале - все начинает работать.

exorcist ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.