LINUX.ORG.RU

GTK-шные (2.х) проги не собираются.... :((


0

0

GTK-шные (2.х) проги не собираются.... :((
Подскажите, в чём трабла. Не собираются проги на GTK2. Сколько их не пробовал, приходится обычно качать уже собранные пакеты :(

Примеры ошибок --



http://www.linux.org.ru/profile/_white2/jump-message.jsp?msgid=993895

и теперь INSCAPE:

depbase=`echo io/simple-sax.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; \
if g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include/freetype2 -pthread -DORBIT2=1 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/orbit-2.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/freetype2/config -DPOTRACE=\"potrace\" -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -pthread -I/usr/local/include/gdkmm-2.4 -I/usr/local/lib/gdkmm-2.4/include -I/usr/local/include/glibmm-2.4 -I/usr/local/lib/glibmm-2.4/include -I/usr/local/include/pangomm-1.4 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/local/include/sigc++-2.0 -I/usr/local/lib/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/local/include/gtkmm-2.4 -I/usr/local/lib/gtkmm-2.4/include -I/usr/local/include/atkmm-1.6 -I/usr/include/atk-1.0 -I/usr/include/libxml2 -I/usr/include/gtkspell-2.0 -I../cxxtest -Wall -W -Wpointer-arith -Wcast-align -Wsign-compare -Woverloaded-virtual -Wswitch-Wno-unused-parameter -g -O2 -MT io/simple-sax.o -MD -MP -MF "$depbase.Tpo" -c -o io/simple-sax.o io/simple-sax.cpp; \
then mv -f "$depbase.Tpo" "$depbase.Po"; else rm -f "$depbase.Tpo"; exit 1; fi

io/simple-sax.cpp:494: error: `XML_SCHEMAP_SUPERNUMEROUS_LIST_ITEM_TYPE' was
not declared in this scope
io/simple-sax.cpp:495: error: `XML_SCHEMAP_INVALID_ATTR_COMBINATION' was not
declared in this scope
io/simple-sax.cpp:496: error: `XML_SCHEMAP_INVALID_ATTR_INLINE_COMBINATION' was
not declared in this scope
io/simple-sax.cpp:497: error: `XML_SCHEMAP_MISSING_SIMPLETYPE_CHILD' was not
declared in this scope
io/simple-sax.cpp:498: error: `XML_SCHEMAP_INVALID_ATTR_NAME' was not declared
in this scope
io/simple-sax.cpp:499: error: `XML_SCHEMAP_REF_AND_CONTENT' was not declared in
this scope
io/simple-sax.cpp:500: error: `XML_SCHEMAP_CT_PROPS_CORRECT_1' was not declared
in this scope
io/simple-sax.cpp:501: error: `XML_SCHEMAP_CT_PROPS_CORRECT_2' was not declared
in this scope
io/simple-sax.cpp:502: error: `XML_SCHEMAP_CT_PROPS_CORRECT_3' was not declared
in this scope
io/simple-sax.cpp:503: error: `XML_SCHEMAP_CT_PROPS_CORRECT_4' was not declared
in this scope
io/simple-sax.cpp:504: error: `XML_SCHEMAP_CT_PROPS_CORRECT_5' was not declared
in this scope
io/simple-sax.cpp:505: error: `XML_SCHEMAP_DERIVATION_OK_RESTRICTION_1' was not
declared in this scope
io/simple-sax.cpp:506: error: `XML_SCHEMAP_DERIVATION_OK_RESTRICTION_2_1_1' was
not declared in this scope
io/simple-sax.cpp:507: error: `XML_SCHEMAP_DERIVATION_OK_RESTRICTION_2_1_2' was
not declared in this scope
io/simple-sax.cpp:508: error: `XML_SCHEMAP_DERIVATION_OK_RESTRICTION_2_2' was
not declared in this scope
io/simple-sax.cpp:509: error: `XML_SCHEMAP_DERIVATION_OK_RESTRICTION_3' was not
declared in this scope
io/simple-sax.cpp:510: error: `XML_SCHEMAP_WILDCARD_INVALID_NS_MEMBER' was not
declared in this scope
io/simple-sax.cpp:511: error: `XML_SCHEMAP_INTERSECTION_NOT_EXPRESSIBLE' was
not declared in this scope
io/simple-sax.cpp:512: error: `XML_SCHEMAP_UNION_NOT_EXPRESSIBLE' was not
declared in this scope
io/simple-sax.cpp:513: error: `XML_SCHEMAP_SRC_IMPORT_3_1' was not declared in
this scope
io/simple-sax.cpp:514: error: `XML_SCHEMAP_SRC_IMPORT_3_2' was not declared in
this scope
io/simple-sax.cpp:515: error: `XML_SCHEMAP_DERIVATION_OK_RESTRICTION_4_1' was
not declared in this scope
io/simple-sax.cpp:516: error: `XML_SCHEMAP_DERIVATION_OK_RESTRICTION_4_2' was
not declared in this scope
io/simple-sax.cpp:517: error: `XML_SCHEMAP_DERIVATION_OK_RESTRICTION_4_3' was
not declared in this scope
io/simple-sax.cpp:518: error: `XML_SCHEMAP_COS_CT_EXTENDS_1_3' was not declared
in this scope
io/simple-sax.cpp:542: error: `XML_SCHEMAV_CVC_DATATYPE_VALID_1_2_1' was not
declared in this scope
io/simple-sax.cpp:543: error: `XML_SCHEMAV_CVC_DATATYPE_VALID_1_2_2' was not
declared in this scope
io/simple-sax.cpp:544: error: `XML_SCHEMAV_CVC_DATATYPE_VALID_1_2_3' was not
declared in this scope
io/simple-sax.cpp:545: error: `XML_SCHEMAV_CVC_TYPE_3_1_1' was not declared in
this scope
io/simple-sax.cpp:546: error: `XML_SCHEMAV_CVC_TYPE_3_1_2' was not declared in
this scope
io/simple-sax.cpp:547: error: `XML_SCHEMAV_CVC_FACET_VALID' was not declared in
this scope
io/simple-sax.cpp:548: error: `XML_SCHEMAV_CVC_LENGTH_VALID' was not declared
in this scope
io/simple-sax.cpp:549: error: `XML_SCHEMAV_CVC_MINLENGTH_VALID' was not
declared in this scope
io/simple-sax.cpp:550: error: `XML_SCHEMAV_CVC_MAXLENGTH_VALID' was not
declared in this scope
io/simple-sax.cpp:551: error: `XML_SCHEMAV_CVC_MININCLUSIVE_VALID' was not
declared in this scope
io/simple-sax.cpp:552: error: `XML_SCHEMAV_CVC_MAXINCLUSIVE_VALID' was not
declared in this scope
io/simple-sax.cpp:553: error: `XML_SCHEMAV_CVC_MINEXCLUSIVE_VALID' was not
declared in this scope
io/simple-sax.cpp:554: error: `XML_SCHEMAV_CVC_MAXEXCLUSIVE_VALID' was not
declared in this scope
io/simple-sax.cpp:555: error: `XML_SCHEMAV_CVC_TOTALDIGITS_VALID' was not
declared in this scope
io/simple-sax.cpp:556: error: `XML_SCHEMAV_CVC_FRACTIONDIGITS_VALID' was not
declared in this scope
io/simple-sax.cpp:557: error: `XML_SCHEMAV_CVC_PATTERN_VALID' was not declared
in this scope
io/simple-sax.cpp:558: error: `XML_SCHEMAV_CVC_ENUMERATION_VALID' was not
declared in this scope
io/simple-sax.cpp:559: error: `XML_SCHEMAV_CVC_COMPLEX_TYPE_2_1' was not
declared in this scope
io/simple-sax.cpp:560: error: `XML_SCHEMAV_CVC_COMPLEX_TYPE_2_2' was not
declared in this scope
io/simple-sax.cpp:561: error: `XML_SCHEMAV_CVC_COMPLEX_TYPE_2_3' was not
declared in this scope
io/simple-sax.cpp:562: error: `XML_SCHEMAV_CVC_COMPLEX_TYPE_2_4' was not
declared in this scope
io/simple-sax.cpp:616: error: `XML_SCHEMAP_SRC_SIMPLE_TYPE_1' was not declared
in this scope
io/simple-sax.cpp:617: error: `XML_SCHEMAP_SRC_SIMPLE_TYPE_2' was not declared
in this scope
io/simple-sax.cpp:618: error: `XML_SCHEMAP_SRC_SIMPLE_TYPE_3' was not declared
in this scope
io/simple-sax.cpp:619: error: `XML_SCHEMAP_SRC_SIMPLE_TYPE_4' was not declared
in this scope
io/simple-sax.cpp:620: error: `XML_SCHEMAP_SRC_RESOLVE' was not declared in
this scope
io/simple-sax.cpp:621: error: `XML_SCHEMAP_SRC_RESTRICTION_BASE_OR_SIMPLETYPE'
was not declared in this scope
io/simple-sax.cpp:622: error: `XML_SCHEMAP_SRC_LIST_ITEMTYPE_OR_SIMPLETYPE' was
not declared in this scope
io/simple-sax.cpp:623: error: `XML_SCHEMAP_SRC_UNION_MEMBERTYPES_OR_SIMPLETYPES
........................(урезано)..............................
io/simple-sax.cpp:648: error: `XML_SCHEMAP_COS_ST_DERIVED_OK_2_2' was not
declared in this scope
io/simple-sax.cpp:649: error: `XML_SCHEMAP_S4S_ELEM_NOT_ALLOWED' was not
declared in this scope
io/simple-sax.cpp:650: error: `XML_SCHEMAP_S4S_ELEM_MISSING' was not declared
in this scope
io/simple-sax.cpp:651: error: `XML_SCHEMAP_S4S_ATTR_NOT_ALLOWED' was not
declared in this scope
io/simple-sax.cpp:652: error: `XML_SCHEMAP_S4S_ATTR_MISSING' was not declared
in this scope
make[2]: *** [io/simple-sax.o] Ошибка 1
make[2]: Leaving directory `/home/vovans/new/new-2/inkscape/src'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Leaving directory `/home/vovans/new/new-2/inkscape'
make: *** [all] Ошибка 2

★★★★★

Re: GTK-шные (2.х) проги не собираются.... :((

Если бы не собирались только эти две проги, то я бьы и не писал сюда. Но почти всё, что на GTK2, всё выдаёт нечто подобное :(

vovans ★★★★★ ()

Re: GTK-шные (2.х) проги не собираются.... :((

А configure тебе ничего не говорил? Какой дистрибутив? Обнови libxml2 попробуй.

Selecter ★★★★ ()
Ответ на: Re: GTK-шные (2.х) проги не собираются.... :(( от Selecter

Re: GTK-шные (2.х) проги не собираются.... :((

>А configure тебе ничего не говорил?

Там всегда всё Ок проходит

>Какой дистрибутив?

Я в тексте (и заголовке) помянал Слаку (10.0, но значительно обновленна).

>Обнови libxml2 попробуй.

Попробую. Но едва ли проблема только в этой либе.

vovans ★★★★★ ()
Ответ на: Re: GTK-шные (2.х) проги не собираются.... :(( от Selecter

Re: GTK-шные (2.х) проги не собираются.... :((

И ГТКашные приложения часто валятся :( Уже собранные.
Вот пример:

Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)' failed
Bonobo accessibility support initialized
GTK Accessibility Module initialized

vovans ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.