LINUX.ORG.RU

Альтернатива okular?

 , , ,


0

2

Очень нравится okular, но очень не нравится зависимость от KDE (не потому что я тулкито-ДЕ-фоб, а потому что есть определённая задача где нужно сэкономить место).

Есть ли что нибудь схожее с этой программой, но менее тяжёлое?
Неаобходима поддержка как минимум форматов PDF, Djvu, CHM, ePub, желательно более-менее дружественный интерфейс (evince не предлагать) и по возможности сохранение позиции при чтении.

Рассматривал как альтернативу электронные читалки вроде CoolReader, но желательно не узкоспециализированное (с библиотекой, базой данных и т.д.) под книги, а просто просмотрщик документов.

Спасибо.

★★★★★

есть определённая задача где нужно сэкономить место

Пересаживайтесь на кошерные дистрибутивы, где окуляр будет зависеть только от пары библиотек метров на 50 в сумме.

fenris ★★★★★ ()
Ответ на: комментарий от fenris

Ну так у меня aur есть, я могу пересобрать, это не проблема. Но kdelibs и пару тройку других либ не обойдёшь всё равно. Хотя наверное придётся. Да и тот же Gwenview, который на кделибах сложно чем-то заменить (нужны превьюхи, минимальные операции с фотками, слайдшоу и т.д.).

soko1 ★★★★★ ()
Ответ на: комментарий от anonymous

Да хрен с ним, в принципе. Затура понравилась, ништяк. Но не подойдёт по причине «не пригодна для простого обывателя». Зато себе поставлю :)

soko1 ★★★★★ ()
Последнее исправление: soko1 (всего исправлений: 1)

Юзаю evince, но это не okular, конечно.
Когда-нибудь мне это надоест и я напишу пкгбилд для статически-собранных okular и konsole.

pekmop1024 ★★★★★ ()

Мне самому это говно (и evince, и okular) не нравится: жрет уж больно много. Если надо pdf открыть окуляром, то он в первый запуск минуты полторы тупит! С evince попроще, но он сам по себе говно.

Anon ()

Очень просто: придумай себе задачу, для которой нужно произвести запись большого количества DVD. Тогда тебе придётся тянуть kdelibs не только из-за Okular, но ещё и из-за K3B. Потом тебе приглянется что-нибудь типа KWrite или Kate и постепенно твой босоногий Гном обуется в Кеды.

proud_anon ★★★★★ ()
Ответ на: комментарий от proud_anon

твой босоногий Гном обуется в Кеды.

Упаси Господь.

В принципе согласен.

soko1 ★★★★★ ()
Ответ на: комментарий от ABW

Спасибо, гляну. У меня была идея заюзать эту софтину, да она qt5 тянет. Попробую потом с аура может собрать на четвёрке, если такая возможность есть.

soko1 ★★★★★ ()
Ответ на: комментарий от soko1

А не, похоже оно исключительно под Qt5...тянуть ещё одну версию либы из-за одной программы глупо. Хотя с другой стороны скоро наверное всем эмигрировать придётся

soko1 ★★★★★ ()
Ответ на: комментарий от soko1

На 5-ку по умолчанию перешли только в 0.4.5 (2013.09.06).
Если бы не твой пост, я бы этого ещё долго не знал.
Кстати, по поводу .chm: KchmViewer, несмотря на «К», можно тоже собрать без кед.
Нудобно, конечно, иметь отдельный просмотрщик для единственного типа, но ничего более вменяемого и не волокущего пол-кед я не встречал.

ABW ★★★★ ()

Кстати, okular почему-то не запускается из пункта меню LXDE. С консоли - всё ок. Интересно в чём проблема...

soko1 ★★★★★ ()
Ответ на: комментарий от soko1

Разобрался, в desktop-файле, который лежит в /usr/share/applications в Exec было прописано:

Exec=okular %U %i -caption %c
Сделал пользовательскую копию, исправил на
Exec=okular

И всё заработало. Интересно почему с аргументами не работало.

soko1 ★★★★★ ()
Ответ на: комментарий от sotrud_nik

Да, я уже подумываю его собрать, да зависимость от qt5 отпугивает, а старый аур-пакет найти не могу. Вернее, я даже не знаю как это делается в арче :))

soko1 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.